summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-12-03 11:39:50 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2020-12-03 11:40:09 +0100
commit9b28449fa0c087396229634de43b49224cb5b430 (patch)
tree6189d154fe48f877a4c11bae9fd5d57b645bc9b5 /x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
parentapp-admin/bitwarden-desktop-bin: version bump 1.23.1 (diff)
downloadgentoo-9b28449fa0c087396229634de43b49224cb5b430.tar.gz
gentoo-9b28449fa0c087396229634de43b49224cb5b430.tar.bz2
gentoo-9b28449fa0c087396229634de43b49224cb5b430.zip
x11-plugins/wmsystray: properly set CC
Also fix incorrect return statement Closes: https://bugs.gentoo.org/743073 Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild')
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
index 4756f31445fd..926644e2d5b7 100644
--- a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+inherit desktop toolchain-funcs
DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
HOMEPAGE="https://github.com/bbidulock/wmsystray"
@@ -17,11 +17,11 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86"
-# Let's honour Gentoo CFLAGS and use correct install program
-# Fix for #61704, cannot compile with gcc 3.4.1:
-# it's a trivial change and does not affect other compilers...
-PATCHES=( "${FILESDIR}/${P}-Makefile.patch"
- "${FILESDIR}/${P}-gcc-3.4.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+ "${FILESDIR}/${P}-gcc-3.4.patch"
+ "${FILESDIR}/${P}-return-type.patch"
+)
DOCS=( README HACKING AUTHORS )
@@ -35,7 +35,7 @@ src_prepare() {
}
src_compile() {
- emake EXTRACFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" EXTRACFLAGS="${CFLAGS}"
}
src_install() {