summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2024-06-09 01:06:01 +0200
committerSebastian Pipping <sping@gentoo.org>2024-06-09 01:20:34 +0200
commita11e422906cbb521697888a0629676addf9f1d61 (patch)
tree3e34a2fa77773e1f3b3126d0a69b8a30c95c7c3e /x11-misc
parentx11-misc/safeeyes: Drop old (diff)
downloadgentoo-a11e422906cbb521697888a0629676addf9f1d61.tar.gz
gentoo-a11e422906cbb521697888a0629676addf9f1d61.tar.bz2
gentoo-a11e422906cbb521697888a0629676addf9f1d61.zip
x11-misc/safeeyes: 2.1.8
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.8.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index 4fcd5e9d7940..4a7b721a70e4 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1 +1,2 @@
DIST safeeyes-2.1.6.tar.gz 286359 BLAKE2B a5e4b4d680d455f2ae9494705f1e4508341802f4826b2d11f5407eed4074f0eab45066a3741745dd164b47e26a2dbf2a393945bffef0f747cbebd5f87b3b1961 SHA512 6476284ed1d8cdde77f10b3fe962a5d9d5ead944b0418f797e375cc67affa6807d858279cf4a1189585b7688dbe983fc6b90c917e0e55a2a11ebfdc56b44ca93
+DIST safeeyes-2.1.8.tar.gz 288991 BLAKE2B 53fa71171c42679f7241a13b5542855c542c020814a4ec9e9c7480163bc2179e93787fb87291999815f900d5dea3522f5de8e35e85b714d3cb1cc4e24bad5638 SHA512 df3192ee751510449a0ee8946c8e59daff3dc5b4ef95a2f5563cc82834fbe8d3de52f39be2e0c26c13db7ac3d115ef1de63184ec8d069b99f411f4d60e9b5139
diff --git a/x11-misc/safeeyes/safeeyes-2.1.8.ebuild b/x11-misc/safeeyes/safeeyes-2.1.8.ebuild
new file mode 100644
index 000000000000..cd7e15330da3
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+python_install() {
+ distutils-r1_python_install
+
+ # Workaround for https://bugs.gentoo.org/926816
+ # Files were misplaced and also duplicate across Python slots.
+ local misplaced_usr="${D}/usr/lib/${EPYTHON}/site-packages/usr"
+ local i
+ for i in applications icons ; do
+ local source="${misplaced_usr}/share/${i}"
+ local target="${D}/usr/share/${i}"
+ if [[ ! -d "${target}" ]]; then
+ dodir /usr/share/
+ mv "${source}" "${target}" || die
+ fi
+ done
+ rm -R "${misplaced_usr}" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}