summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/okindd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/okindd')
-rw-r--r--x11-misc/okindd/Manifest2
-rw-r--r--x11-misc/okindd/files/okindd-0.6.1-gcc-4.7.patch10
-rw-r--r--x11-misc/okindd/metadata.xml5
-rw-r--r--x11-misc/okindd/okindd-0.6.0.ebuild40
-rw-r--r--x11-misc/okindd/okindd-0.6.1.ebuild45
5 files changed, 102 insertions, 0 deletions
diff --git a/x11-misc/okindd/Manifest b/x11-misc/okindd/Manifest
new file mode 100644
index 000000000000..1ba8cbea08b8
--- /dev/null
+++ b/x11-misc/okindd/Manifest
@@ -0,0 +1,2 @@
+DIST okindd-0.6.0-49-20110113.tar.bz2 11557 SHA256 a2a98c1bbe2e64b22542d7a0f131a4373dcd075fb569841e045aa6cfb827a236
+DIST okindd-0.6.1-23-20120304.tar.bz2 14778 SHA256 f99e48b56f312d9aa7f0d612eb926ee3a11cec1bec50538e4c3efa5e7df6a985
diff --git a/x11-misc/okindd/files/okindd-0.6.1-gcc-4.7.patch b/x11-misc/okindd/files/okindd-0.6.1-gcc-4.7.patch
new file mode 100644
index 000000000000..4cf7e4f20571
--- /dev/null
+++ b/x11-misc/okindd/files/okindd-0.6.1-gcc-4.7.patch
@@ -0,0 +1,10 @@
+--- src/okindd.h
++++ src/okindd.h
+@@ -9,6 +9,7 @@
+ #include "text.h"
+ #include "menu.h"
+ #include "global.h"
++#include <unistd.h>
+ #include <QApplication>
+ #include <QLabel>
+ #include <QtDBus>
diff --git a/x11-misc/okindd/metadata.xml b/x11-misc/okindd/metadata.xml
new file mode 100644
index 000000000000..ab02f994fdd2
--- /dev/null
+++ b/x11-misc/okindd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+</pkgmetadata>
diff --git a/x11-misc/okindd/okindd-0.6.0.ebuild b/x11-misc/okindd/okindd-0.6.0.ebuild
new file mode 100644
index 000000000000..2dbefddf7d89
--- /dev/null
+++ b/x11-misc/okindd/okindd-0.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit qt4-r2
+
+MY_P="${P}-49-20110113"
+
+DESCRIPTION="On Screen Display (OSD) for KDE 4.x - works on any qt desktop"
+HOMEPAGE="http://sites.kochkin.org/okindd/Home"
+SRC_URI="http://sites.kochkin.org/okindd/Home/development/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="dev-qt/qtgui:4
+ dev-qt/qtdbus:4"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ eqmake4 okindd.pro
+}
+
+DOCS=( changelog )
+src_install() {
+ qt4-r2_src_install
+ docinto examples
+ dodoc scripts/*
+ dodoc conf/okinddrc.example
+
+ elog "You can find an example configuration file at"
+ elog " /usr/share/doc/okindd/examples/okinddrc.example"
+ elog "It should be placed in \${HOME}/.okindd/"
+}
diff --git a/x11-misc/okindd/okindd-0.6.1.ebuild b/x11-misc/okindd/okindd-0.6.1.ebuild
new file mode 100644
index 000000000000..716796226f37
--- /dev/null
+++ b/x11-misc/okindd/okindd-0.6.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-r2
+
+MY_P=${P}-23-20120304
+
+DESCRIPTION="On Screen Display (OSD) for KDE 4.x - works on any Qt desktop"
+HOMEPAGE="http://sites.kochkin.org/okindd/Home"
+SRC_URI="http://sites.kochkin.org/okindd/Home/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}
+
+DOCS="changelog"
+PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
+
+src_install() {
+ qt4-r2_src_install
+
+ rm -rf "${ED}"usr/share/doc/${PN}
+ docinto examples
+ dodoc conf/okinddrc.{example,my} scripts/*
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ elog "You can find an example configuration file at"
+ elog " ${EROOT}usr/share/doc/${PF}/examples/okinddrc.example"
+ elog "It should be placed inside \${HOME}/.okindd/"
+}