summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-10-14 21:36:08 -0400
committerAnthony G. Basile <blueness@gentoo.org>2015-10-14 21:36:08 -0400
commit983b4c1124dd5d43b23af9561948ab225c8f4413 (patch)
tree25c2aac1477058af9cfb792dcf6603ce26734ec3 /www-servers/monkeyd/monkeyd-9999.ebuild
parentnet-dns/avahi: unconditionally depend on xmltoman, bug #563046. (diff)
downloadgentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.tar.gz
gentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.tar.bz2
gentoo-983b4c1124dd5d43b23af9561948ab225c8f4413.zip
www-servers/monkeyd: version bump 1.6.3. enable tls plugin.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'www-servers/monkeyd/monkeyd-9999.ebuild')
-rw-r--r--www-servers/monkeyd/monkeyd-9999.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/www-servers/monkeyd/monkeyd-9999.ebuild b/www-servers/monkeyd/monkeyd-9999.ebuild
index e0f015929ad5..fc9146ee2746 100644
--- a/www-servers/monkeyd/monkeyd-9999.ebuild
+++ b/www-servers/monkeyd/monkeyd-9999.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit flag-o-matic toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
@@ -21,22 +21,23 @@ fi
LICENSE="GPL-2"
SLOT="0"
-# Currently monkeyd_plugins_tls is off. It provides mbed TLS (formerly PolarSSL).
# jemalloc is also off until we figure out how to work CMakeLists.txt magic.
-#PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
#IUSE="cgi -debug fastcgi jemalloc php static-plugins ${PLUGINS}"
-PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril"
+PLUGINS="monkeyd_plugins_auth monkeyd_plugins_cheetah monkeyd_plugins_dirlisting +monkeyd_plugins_liana monkeyd_plugins_logger monkeyd_plugins_mandril monkeyd_plugins_tls"
IUSE="cgi -debug fastcgi php static-plugins ${PLUGINS}"
# uclibc is often compiled without backtrace info so we should
# force this off. If someone complains, consider relaxing it.
REQUIRED_USE="
+ monkeyd_plugins_tls? ( !static-plugins )
elibc_uclibc? ( !debug )
cgi? ( php )"
#DEPEND="jemalloc? ( >=dev-libs/jemalloc-3.3.1 )"
-DEPEND="dev-util/cmake"
+DEPEND="
+ dev-util/cmake
+ monkeyd_plugins_tls? ( net-libs/mbedtls:= )"
RDEPEND="
php? ( dev-lang/php )
cgi? ( dev-lang/php[cgi] )"
@@ -56,8 +57,9 @@ pkg_setup() {
}
src_prepare() {
- # Unconditionally get rid of the bundled jemalloc and mbedTLS
+ # Unconditionally get rid of the bundled jemalloc
rm -rf "${S}"/deps
+ epatch "${FILESDIR}"/${P}-system-mbedtls.patch
}
src_configure() {