summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-17 15:29:23 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-17 15:52:22 +0200
commitbee288dc0357117721b132cb344d6ca001b42a6d (patch)
treea797e7684737221a3020e196de1fc66133cd05d0 /www-servers/gunicorn
parentnet-p2p/cpuminer-opt: drop 23.9 (diff)
downloadgentoo-bee288dc0357117721b132cb344d6ca001b42a6d.tar.gz
gentoo-bee288dc0357117721b132cb344d6ca001b42a6d.tar.bz2
gentoo-bee288dc0357117721b132cb344d6ca001b42a6d.zip
www-servers/gunicorn: Bump to 22.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'www-servers/gunicorn')
-rw-r--r--www-servers/gunicorn/Manifest1
-rw-r--r--www-servers/gunicorn/gunicorn-22.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/www-servers/gunicorn/Manifest b/www-servers/gunicorn/Manifest
index ce58d1b98610..159662c6808d 100644
--- a/www-servers/gunicorn/Manifest
+++ b/www-servers/gunicorn/Manifest
@@ -1 +1,2 @@
DIST gunicorn-21.2.0.gh.tar.gz 361112 BLAKE2B 94c868435ecca25d4c83e348bff219d26f53fe28e15d284c00f6f981ee88a5a32e802014b121f1314ec337684fa7bb37fcc21e2ec2aeab4275e526aa84f22677 SHA512 47c21293bd5340e43074c87694d13241b2867437ad993b204ee4bd21ea923350763a424b3f7ce59737b10cd526d12127b1ae95ef60410eca9924605b522d637c
+DIST gunicorn-22.0.0.gh.tar.gz 368152 BLAKE2B 9d3e2955140d299af86b9370c352d0d7ae2b631a5cdf72200550d3ac8b2e5f51edbc686475d3507f8dfb5f4249ef261e29a6d5fa172e5356777297f5497c7c20 SHA512 cb366cfc2875a32e1e6ddd3bd521650cb87a51c29b036b2cfbd9f8371307d1ffefafbcc85d45753c29186a92def77112e2ddd49fdc2116d2d32702635e88ba53
diff --git a/www-servers/gunicorn/gunicorn-22.0.0.ebuild b/www-servers/gunicorn/gunicorn-22.0.0.ebuild
new file mode 100644
index 000000000000..d8eb6eabad27
--- /dev/null
+++ b/www-servers/gunicorn/gunicorn-22.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI HTTP Server for UNIX"
+HOMEPAGE="
+ https://gunicorn.org/
+ https://github.com/benoitc/gunicorn/
+ https://pypi.org/project/gunicorn/
+"
+SRC_URI="
+ https://github.com/benoitc/gunicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT PSF-2 doc? ( BSD )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+"
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx 'docs/source' --no-autodoc
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_IGNORE=(
+ # removed deps
+ tests/workers/test_geventlet.py
+ tests/workers/test_ggevent.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/source/_build/html/. )
+
+ distutils-r1_python_install_all
+}