summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-02-18 14:25:48 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-02-18 14:26:54 +0200
commit6fb4f8fd1f1c4a5e4dd18092d39448ac5639b52c (patch)
tree7427bddd30fe35443bfbd80a9aa31e0a2ba23213 /www-client/firefox
parentmail-client/thunderbird: stabilize 91.6.1 for amd64 (diff)
downloadgentoo-6fb4f8fd1f1c4a5e4dd18092d39448ac5639b52c.tar.gz
gentoo-6fb4f8fd1f1c4a5e4dd18092d39448ac5639b52c.tar.bz2
gentoo-6fb4f8fd1f1c4a5e4dd18092d39448ac5639b52c.zip
www-client/firefox: disable gold linker for good on 97.0.1
Closes: https://bugs.gentoo.org/833573 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/firefox')
-rw-r--r--www-client/firefox/firefox-97.0.1.ebuild14
1 files changed, 3 insertions, 11 deletions
diff --git a/www-client/firefox/firefox-97.0.1.ebuild b/www-client/firefox/firefox-97.0.1.ebuild
index 8ffecc9a4615..0470e6eb9aa3 100644
--- a/www-client/firefox/firefox-97.0.1.ebuild
+++ b/www-client/firefox/firefox-97.0.1.ebuild
@@ -826,11 +826,7 @@ src_configure() {
else
# ThinLTO is currently broken, see bmo#1644409
mozconfig_add_options_ac '+lto' --enable-lto=full
- if tc-ld-is-gold; then
- mozconfig_add_options_ac "linker is set to gold" --enable-linker=gold
- else
- mozconfig_add_options_ac "linker is set to bfd" --enable-linker=bfd
- fi
+ mozconfig_add_options_ac "linker is set to bfd" --enable-linker=bfd
fi
if use pgo ; then
@@ -847,11 +843,7 @@ src_configure() {
# This is upstream's default
mozconfig_add_options_ac "forcing ld=lld due to USE=clang" --enable-linker=lld
else
- if tc-ld-is-gold; then
- mozconfig_add_options_ac "linker is set to gold" --enable-linker=gold
- else
- mozconfig_add_options_ac "linker is set to bfd" --enable-linker=bfd
- fi
+ mozconfig_add_options_ac "linker is set to bfd" --enable-linker=bfd
fi
fi
@@ -946,7 +938,7 @@ src_configure() {
if use clang ; then
# Nothing to do
:;
- elif tc-ld-is-gold || use lto ; then
+ elif use lto ; then
append-ldflags -Wl,--no-keep-memory
else
append-ldflags -Wl,--no-keep-memory -Wl,--reduce-memory-overheads