summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-09-21 15:55:30 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-09-21 16:01:33 +0300
commit76fe0e2169db876370bf28f7ba45df50238a3ebf (patch)
tree76c3fb8fbb645ef7ca8f5a99ffaaeb07ab81d589 /www-apps
parentwww-apps/drupal: add 9.5.11 (diff)
downloadgentoo-76fe0e2169db876370bf28f7ba45df50238a3ebf.tar.gz
gentoo-76fe0e2169db876370bf28f7ba45df50238a3ebf.tar.bz2
gentoo-76fe0e2169db876370bf28f7ba45df50238a3ebf.zip
www-apps/drupal: drop 9.5.8
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-9.5.8.ebuild68
2 files changed, 0 insertions, 69 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 8ba22a1b3a69..da654e05f548 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,4 +1,3 @@
DIST drupal-10.0.8.tar.gz 17433029 BLAKE2B 8fbdb7ca86decea007ecd369f5f9c9c9a751ee56df9db5ce117be2cba8d3d82f09994344590be1d3ce690fa747d4a59cf3c04f7427ee531f322d0ecaab5a1a7a SHA512 e1fccce448019b3cfb3a08d0fdd6e6f3ff4ce5110c51393e5c99242e1250e25a647029e4c69600f0e52da8585ae2dcb53804de860fde952928e07b694a61a070
DIST drupal-7.97.tar.gz 3381082 BLAKE2B 3997305b91330db16843ee17927435b1bba4b080b72b36c1c90508e9edc0379f33aad3fae31fd637034d7ddeae425d75bd2252ed733ee00a6d9e12a75b909979 SHA512 2ea4ae63f9dc87043f3743f7e426c2fe940ca930a764c9eff0cb19e25fb3117599350c8fab92fc1bc45c2e6719ae20caba039180d63672cb1616f7526b798dcb
DIST drupal-9.5.11.tar.gz 22593304 BLAKE2B b978bed98649eb43999c414d11c1f168eca9800e65016e5e444799c9be75f6dd3914287e6845b9b9f698d3c0a3e368ac48f35b9b9cf989e23ad8f3abd70f028a SHA512 a8fe6756d4540c95af6d615d8eb2a063f79a502920d609db15ef07ede05727a933f5720e5ca64fe5d70c71d7d6971217633135675bb7f27db2130bbd01d8094d
-DIST drupal-9.5.8.tar.gz 22577412 BLAKE2B f0f372aa4af0356f22e8c37a16b68ae572382f63a0eb030b5a2331d61489769ecf1a99e0428b95f242d725d7125d82857df27c166d599da18b09f1c64fba48c0 SHA512 bb5d1441319d5fb15838535c2af66087ebf7a87f5f91d5a3ef33f74d92104846a8183bce1404b48454d49ff19d5b9afeef0e4bc790c1ac43e5d404fbf927361e
diff --git a/www-apps/drupal/drupal-9.5.8.ebuild b/www-apps/drupal/drupal-9.5.8.ebuild
deleted file mode 100644
index cfe37862af18..000000000000
--- a/www-apps/drupal/drupal-9.5.8.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit webapp
-
-MY_PV=${PV:0:3}.0
-MY_P=${P/_/-}
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="PHP-based open-source platform and content management system"
-HOMEPAGE="https://www.drupal.org/"
-SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-IUSE="+mysql postgres sqlite +uploadprogress"
-
-RDEPEND="
- dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
- virtual/httpd-php
- uploadprogress? ( dev-php/pecl-uploadprogress )
-"
-
-need_httpd_cgi
-
-REQUIRED_USE="|| ( mysql postgres sqlite )"
-
-src_install() {
- webapp_src_preinst
-
- local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
- core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
-
- dodoc ${docs}
- rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
-
- cp sites/default/{default.settings.php,settings.php} || die
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- dodir "${MY_HTDOCSDIR}"/files
- webapp_serverowned "${MY_HTDOCSDIR}"/files
-
- webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
- webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
-
- webapp_src_install
-}
-
-pkg_postinst() {
- echo
- ewarn "SECURITY NOTICE"
- ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
- ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
- echo
- ewarn "If this is a new install, unless you want anyone with network access to your server to be"
- ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
- echo
- ewarn "If you're doing a new drupal-9 install, you'll have to copy /sites/default/default.services.yml"
- ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
- ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
- ewarn "reported by the setup."
- echo
-}