summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2018-05-26 22:50:51 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-26 17:46:35 -0400
commit10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a (patch)
tree80b1bbc8699d379df931940b6ed6eca0402d7a31 /www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
parentmedia-libs/libdvbpsi: Drop 1.3.0-r1 (diff)
downloadgentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.tar.gz
gentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.tar.bz2
gentoo-10d8c1f67b3bd910fd7f9d1beb52da9d8322e76a.zip
www-apps/icingaweb2-module-graphite: fix SRC_URI for 1.0.1, EAPI=7
Also update HOMEPAGE and fix DESCRIPTION, remove deprecated patch from live ebuild and add upstream info to metadata.xml. Package-Manager: Portage-2.3.38, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8601
Diffstat (limited to 'www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild')
-rw-r--r--www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild18
1 files changed, 7 insertions, 11 deletions
diff --git a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
index 7e359c940e4c..312bc419e294 100644
--- a/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
+++ b/www-apps/icingaweb2-module-graphite/icingaweb2-module-graphite-9999.ebuild
@@ -1,29 +1,25 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-DESCRIPTION="Icinga Web 2 plugin for pnp4nagios"
-HOMEPAGE="http://www.icinga.org/"
+DESCRIPTION="Icinga Web 2 plugin for Graphite"
+HOMEPAGE="https://www.icinga.com/docs/graphite/latest/"
if [[ "${PV}" == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Icinga/icingaweb2-module-graphite.git"
else
KEYWORDS="~amd64 ~x86"
- MY_PN="icingaweb2-module-pnp"
- SRC_URI="https://codeload.github.com/Icinga/${MY_PN}/tar.gz/v${PV} -> ${P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV}"
+ SRC_URI="https://github.com/Icinga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="GPL-2"
SLOT="0"
-DEPEND=">=net-analyzer/icinga2-2.1.1
- >=www-apps/icingaweb2-2.0.0"
+DEPEND=">=net-analyzer/icinga2-2.4.0
+ >=www-apps/icingaweb2-2.5.0"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}/patch-unquote-service.patch" )
-
src_install() {
insinto "/usr/share/icingaweb2/modules/graphite/"
doins -r "${S}"/*