summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-09-08 20:42:38 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-09-11 12:37:23 +0300
commit0771ac7d333a5de1f1f4c3ae8a80a886e5c310b4 (patch)
treed2451ad236cae0ea040726ae8ffeb943b6ad1817 /www-apps/hugo
parentwww-apps/hugo: add 0.118.2 (diff)
downloadgentoo-0771ac7d333a5de1f1f4c3ae8a80a886e5c310b4.tar.gz
gentoo-0771ac7d333a5de1f1f4c3ae8a80a886e5c310b4.tar.bz2
gentoo-0771ac7d333a5de1f1f4c3ae8a80a886e5c310b4.zip
www-apps/hugo: drop 0.115.2
Signed-off-by: tastytea <gentoo@tastytea.de> Closes: https://github.com/gentoo/gentoo/pull/32691 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/hugo')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/hugo-0.115.2.ebuild98
2 files changed, 0 insertions, 100 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index be5b2f3abdce..50031c4ee0fc 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -1,5 +1,3 @@
-DIST hugo-0.115.2-vendor.tar.xz 6196068 BLAKE2B 0d98ed1f3553c5eb28ceb66751c36d4b0e6bb5838a37166d1c006e4a05a888bfd850250a77c1786293bc34bad2f731052782e42b0d8c1e6cc158c076d46945d4 SHA512 e1eb88cd8fbb01bb86c265e3416bf236cb6b049467218f5ff66e2702f4304eca4ab43edbfbb4d3972d636d4dcf0fd04375fd4ebce2a40b78c1a3de1f27e08049
-DIST hugo-0.115.2.tar.gz 28547893 BLAKE2B 18496be5d24be6b0b34ff88806b6621cb361f61641efd67ed11fd413379107aad029b241a7b8730ad016c1eb1469b29feee7af33fbf0b94bb0f2fbe2a209c1bb SHA512 4c35d5d6699de1e675fa0c1dfca0f2436ac3ab7a0c164e7662400fb7b81b16ed23a6961e297f262273c18ef2eaa551b813c7d99a8634d0687e78343b23f275f6
DIST hugo-0.115.4-vendor.tar.xz 6193628 BLAKE2B 427dc6c66a726ff944b0c782b443a6ae3d3ec1b916127db33ebb6789dc1a8271daf00a3bf47f4fbd4f18fc01648b632c5ad9978237d4a11aac0c30406626c107 SHA512 57d3a421eec9909995453aad032f7775722e6ea72c344a31337c62c0aa7b4b669cf5ba5229e3f6819845eed03712e9972328c13c14f93bee0b97a5392b49779b
DIST hugo-0.115.4.tar.gz 28554509 BLAKE2B b0a8776580b60af5b4e8d023ed2c046fec1d508eaef568fa06f8591653e0f3a2e1bb65352328de421353c02a5856a6cc713d15b6189184150fabc6a5d3a152b9 SHA512 b5a00aa6601a6df2d1cc9244899b26abdc92e0b57d7431409b483e1bbd892a8026b181f2b9dbe273385b5ca95c3564ca6128afa54d33cbda584946eba20d2eb5
DIST hugo-0.118.2-vendor.tar.xz 6633368 BLAKE2B a88e3422828a98ae220805a5853402b62c2b602de03909187a3694b1546a3fb27f9cb39651342039b5031840fd57e6f00152d5ff023628c6d491ee33245d3b24 SHA512 2e617cccf23931ba20dfac703445c63d0bebdf6178c943315dd7d4983b2a4626c1631751e3bbd925a247599af918638161d13b3e2af474e80ec204aa9ad0e2f6
diff --git a/www-apps/hugo/hugo-0.115.2.ebuild b/www-apps/hugo/hugo-0.115.2.ebuild
deleted file mode 100644
index b8cc129acc16..000000000000
--- a/www-apps/hugo/hugo-0.115.2.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 2018-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit go-module bash-completion-r1
-
-DESCRIPTION="Fast static HTML and CSS website generator"
-HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
-SRC_URI="
- https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
-"
-
-# NOTE: To create the vendor tarball, run:
-# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
-
-LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
-IUSE="doc +sass test"
-
-BDEPEND="
- >=dev-lang/go-1.18
- test? (
- dev-python/docutils
- dev-ruby/asciidoctor
- virtual/pandoc
- )
-"
-RDEPEND="
- >=media-libs/libwebp-1.2.3-r1:=
- sass? ( dev-libs/libsass:= )
-"
-DEPEND="${RDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
- "${FILESDIR}"/${PN}-0.115.2-skip-some-tests.patch
-)
-
-src_configure() {
- export CGO_ENABLED=1
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export MY_BUILD_FLAGS="$(usev sass "-tags extended")"
-
- default
-}
-
-src_prepare() {
- # wants to run command that require network access
- rm testscripts/commands/mod{,_vendor}.txt || die
-
- default
-}
-
-src_compile() {
- mkdir -pv bin || die
- ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
- ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
-
- bin/hugo gen man --dir man || die
-
- mkdir -pv completions || die
- bin/hugo completion bash > completions/hugo || die
- bin/hugo completion fish > completions/hugo.fish || die
- bin/hugo completion zsh > completions/_hugo || die
-
- if use doc ; then
- bin/hugo gen doc --dir doc || die
- fi
-}
-
-src_test() {
- ego test "./..." ${MY_BUILD_FLAGS}
-}
-
-src_install() {
- dobin bin/*
- doman man/*
-
- dobashcomp completions/${PN}
-
- insinto /usr/share/fish/vendor_completions.d
- doins completions/${PN}.fish
-
- insinto /usr/share/zsh/site-functions
- doins completions/_${PN}
-
- if use doc ; then
- dodoc -r doc/*
- fi
-}