summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Freeman <rich0@gentoo.org>2024-04-30 07:45:05 -0400
committerRichard Freeman <rich0@gentoo.org>2024-04-30 08:51:00 -0400
commit9650ada19875e027a46c5ce23dc15555bd0044d0 (patch)
tree950b4b67e43deb305efac5c9fa7774d3af668cb6 /sys-process
parentsys-kernel/pf-sources: add 6.8_p7 (diff)
downloadgentoo-9650ada19875e027a46c5ce23dc15555bd0044d0.tar.gz
gentoo-9650ada19875e027a46c5ce23dc15555bd0044d0.tar.bz2
gentoo-9650ada19875e027a46c5ce23dc15555bd0044d0.zip
sys-process/systemd-cron: add 2.4.0
Bug: https://bugs.gentoo.org/930950 Signed-off-by: Richard Freeman <rich0@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/systemd-cron/Manifest1
-rw-r--r--sys-process/systemd-cron/systemd-cron-2.4.0.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/sys-process/systemd-cron/Manifest b/sys-process/systemd-cron/Manifest
index 06b7f8013a30..830f4e8bbd72 100644
--- a/sys-process/systemd-cron/Manifest
+++ b/sys-process/systemd-cron/Manifest
@@ -1,2 +1,3 @@
DIST systemd-cron-2.2.0.tar.gz 55825 BLAKE2B ca4b02fdea5084439aa56b3f04603000d811f21922c11cd26a22ea6387e4b54575587ff4e1eb7fc7a3260d2f656ea0eb91365942c135982f4bd26aead1a080f1 SHA512 f26c7d7e2da7eb5cd5558f352aff852585bfefd961de6ecc2409a4a53b63f82662a89bdbf71f739ea8e44ef9e3e1fdec15cdc63ce1e90c289fb0e636ff679ca0
DIST systemd-cron-2.3.4.tar.gz 58458 BLAKE2B 594fff8f7cc126aa33b1dcbf74293a39b5939576203c11f8f0fc300285462f266c35503a6cfe46ee797e5e617e54e09b92dd6ba8a4044f962d1efd2822f0a87c SHA512 2a9743df6d0e1a83b65d15609e47b901fde1d77d1207c4cc0617395be8d9e94daece91aec9a3398c3d09f86383e01cfff301614df727ca598efe873453f5a3c9
+DIST systemd-cron-2.4.0.tar.gz 60462 BLAKE2B 6a4450637b69ed9c32ea5711018be9265db96a6bf19896bb72c13184817750e7d64d2fdd00ac885d5ae3393b671c04c89d1bf46f73fbb817c1b1798a4809b955 SHA512 88ce99307101d33e6fc6a5dfa25f16db9754785809b44da78c6b05b52592385c9a957770ee781b97a248ab475304bd7eb234bffa47114031bd804e2aa5f79c06
diff --git a/sys-process/systemd-cron/systemd-cron-2.4.0.ebuild b/sys-process/systemd-cron/systemd-cron-2.4.0.ebuild
new file mode 100644
index 000000000000..00738f1c0e07
--- /dev/null
+++ b/sys-process/systemd-cron/systemd-cron-2.4.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit systemd toolchain-funcs
+
+DESCRIPTION="systemd units to create timers for cron directories and crontab"
+HOMEPAGE="https://github.com/systemd-cron/systemd-cron/"
+SRC_URI="https://github.com/systemd-cron/${PN}/archive/v${PV}.tar.gz -> systemd-cron-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="cron-boot etc-crontab-systemd minutely +runparts setgid yearly"
+# We can't run the unshare tests within sandbox/with low privs, and the
+# 'test-nounshare' target just does static analysis (shellcheck etc).
+RESTRICT="test"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND="
+ !sys-process/cronie[anacron]
+ acct-user/_cron-failure
+ acct-group/_cron-failure
+ app-crypt/libmd:=
+ sys-process/cronbase
+ >=sys-apps/systemd-255[-split-usr(-)]
+ !etc-crontab-systemd? ( !sys-process/dcron )
+ runparts? ( sys-apps/debianutils )
+"
+DEPEND="
+ dev-libs/openssl:=
+ sys-process/cronbase
+"
+
+src_prepare() {
+ sed -i \
+ -e 's/^crontab/crontab-systemd/' \
+ -e 's/^CRONTAB/CRONTAB-SYSTEMD/' \
+ -- "${S}/src/man/crontab."{1,5}".in" || die
+
+ if use etc-crontab-systemd
+ then sed -i \
+ -e "s!/etc/crontab!/etc/crontab-systemd!" \
+ -- "${S}/src/man/crontab."{1,5}".in" \
+ "${S}/src/bin/systemd-crontab-generator.cpp" \
+ "${S}/test/test-generator" || die
+ fi
+
+ default
+}
+
+my_use_enable() {
+ if use ${1}; then
+ echo --enable-${2:-${1}}=yes
+ else
+ echo --enable-${2:-${1}}=no
+ fi
+}
+
+src_configure() {
+ tc-export PKG_CONFIG CXX CC
+
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --mandir="${EPREFIX}/usr/share/man" \
+ --unitdir="$(systemd_get_systemunitdir)" \
+ --generatordir="$(systemd_get_systemgeneratordir)" \
+ $(my_use_enable cron-boot boot) \
+ $(my_use_enable minutely) \
+ $(my_use_enable runparts) \
+ $(my_use_enable yearly) \
+ $(my_use_enable yearly quarterly) \
+ $(my_use_enable yearly semi_annually) || die
+
+ export CRONTAB=crontab-systemd
+}
+
+src_compile() {
+ emake PCH=
+}
+
+src_install() {
+ emake DESTDIR="${D}" PCH= install
+ rm -f "${ED}"/usr/lib/sysusers.d/systemd-cron.conf
+}
+
+pkg_postinst() {
+ elog "This package now supports USE=runparts which is enabled by default."
+ elog "This enables the traditional run-parts behavior."
+ elog "If you disable this flag you will get the new behavior of having"
+ elog "multiple jobs for each cron.* entry run in parallel with"
+ elog "separate services/logs/etc."
+}