summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/numad
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/numad')
-rw-r--r--sys-process/numad/Manifest1
-rw-r--r--sys-process/numad/files/0001-Fix-man-page-directory-creation.patch26
-rw-r--r--sys-process/numad/files/numad-0.5-ldlibs.patch34
-rw-r--r--sys-process/numad/metadata.xml9
-rw-r--r--sys-process/numad/numad-0.5-r1.ebuild45
-rw-r--r--sys-process/numad/numad-0.5-r2.ebuild44
-rw-r--r--sys-process/numad/numad-0.5.ebuild42
-rw-r--r--sys-process/numad/numad-9999.ebuild41
8 files changed, 242 insertions, 0 deletions
diff --git a/sys-process/numad/Manifest b/sys-process/numad/Manifest
new file mode 100644
index 000000000000..2883ddcadd10
--- /dev/null
+++ b/sys-process/numad/Manifest
@@ -0,0 +1 @@
+DIST numad-0.5-334278f.tar.bz2 21007 SHA256 5a288f3597d616211f7ce7cc9e7e9e65c72f2360754ac02f9e0e17f86118ea9b SHA512 1b4a577f0713bae1386f2064fcb2dcbfb9453e23e7617f40cfff4e56d02a8c26a48c8d03f1ac7aa36e4ba168824572377f84bc669d1dabdc1820c2cdc4c57911 WHIRLPOOL e4ca9eeaccab3544d39e0a7ef812f1d2eca4269f5ee8466ee043dbdabc9e987b9393b4f3f3d5f6e1d898256179515ca52985e2e38c4afa27b84c4514e2e9259d
diff --git a/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch b/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch
new file mode 100644
index 000000000000..0b8a1d7c27ff
--- /dev/null
+++ b/sys-process/numad/files/0001-Fix-man-page-directory-creation.patch
@@ -0,0 +1,26 @@
+From 276611ad637334a6e3ea464540b204318f832ba8 Mon Sep 17 00:00:00 2001
+From: Doug Goldstein <cardoe@cardoe.com>
+Date: Wed, 13 Jun 2012 17:49:52 -0500
+Subject: [PATCH] Fix man page directory creation
+
+When building inside of a buildroot, the path for the man page might not
+exist so create it before we attempt to install a file into it.
+---
+ Makefile | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index d9adca9..32ad480 100755
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,7 @@ RANLIB ?= ranlib
+
+ install: numad
+ mkdir -p ${prefix}/bin
++ mkdir -p ${prefix}/share/man/man8
+ install -m 0755 numad ${prefix}/bin
+ install -m 0644 numad.8 ${prefix}/share/man/man8
+
+--
+1.7.3.4
+
diff --git a/sys-process/numad/files/numad-0.5-ldlibs.patch b/sys-process/numad/files/numad-0.5-ldlibs.patch
new file mode 100644
index 000000000000..d124e32e9ee4
--- /dev/null
+++ b/sys-process/numad/files/numad-0.5-ldlibs.patch
@@ -0,0 +1,34 @@
+From 9eb3cc5c51d846c8c8b750a4eb55545d7b5fea6c Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Wed, 23 Apr 2014 15:41:26 -0400
+Subject: [PATCH] use LDLIBS for linker flags
+
+When you put -lfoo into the dependency line of make, it forces it to
+search /lib and /usr/lib for files to link against. This can cause
+problems when trying to cross-compile or build for different ABIs.
+Use the standard LDLIBS variable instead.
+
+URL: https://bugs.gentoo.org/505760
+Reported-by: Georgi Georgiev <chutzimir@gmail.com>
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index f3838b4..f2e9a6e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -31,7 +31,8 @@ docdir := ${prefix}/share/doc
+
+ all: numad
+
+-numad: numad.o -lpthread
++LDLIBS := -lpthread
++numad: numad.o
+
+ AR ?= ar
+ RANLIB ?= ranlib
+--
+1.9.2
+
diff --git a/sys-process/numad/metadata.xml b/sys-process/numad/metadata.xml
new file mode 100644
index 000000000000..6565d583883d
--- /dev/null
+++ b/sys-process/numad/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <maintainer>
+ <email>cardoe@gentoo.org</email>
+ <name>Doug Goldstein</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-process/numad/numad-0.5-r1.ebuild b/sys-process/numad/numad-0.5-r1.ebuild
new file mode 100644
index 000000000000..f8d4bf97e402
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info toolchain-funcs
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ KEYWORDS="~amd64 -arm -s390 x86"
+else
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ KEYWORDS="amd64 -arm -s390 x86"
+ S="${WORKDIR}/${PN}-334278f"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}
diff --git a/sys-process/numad/numad-0.5-r2.ebuild b/sys-process/numad/numad-0.5-r2.ebuild
new file mode 100644
index 000000000000..4aba3a848455
--- /dev/null
+++ b/sys-process/numad/numad-0.5-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ inherit git-2
+else
+ HASH="334278ff3d774d105939743436d7378a189e8693"
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=${HASH};sf=tbz2 -> numad-0.5-${HASH:0:7}.tar.bz2"
+ KEYWORDS="~amd64 -arm -s390 ~x86"
+ S="${WORKDIR}/${PN}-${HASH:0:7}"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
+ epatch "${FILESDIR}"/${PN}-0.5-ldlibs.patch #505760
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}
diff --git a/sys-process/numad/numad-0.5.ebuild b/sys-process/numad/numad-0.5.ebuild
new file mode 100644
index 000000000000..4b3b2e78f406
--- /dev/null
+++ b/sys-process/numad/numad-0.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ KEYWORDS="-arm -s390"
+else
+ SRC_URI="http://git.fedorahosted.org/git/?p=numad.git;a=snapshot;h=334278ff3d774d105939743436d7378a189e8693;sf=tbz2 -> numad-0.5-334278f.tar.bz2"
+ KEYWORDS="amd64 -arm -s390 x86"
+ S="${WORKDIR}/${PN}-334278f"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_configure() {
+ :
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}
diff --git a/sys-process/numad/numad-9999.ebuild b/sys-process/numad/numad-9999.ebuild
new file mode 100644
index 000000000000..1dd514c4a980
--- /dev/null
+++ b/sys-process/numad/numad-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info toolchain-funcs eutils
+
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="git://git.fedorahosted.org/numad.git"
+ inherit git-2
+else
+ SRC_URI=""
+ KEYWORDS="~amd64 ~x86 -arm -s390"
+fi
+
+DESCRIPTION="The NUMA daemon that manages application locality"
+HOMEPAGE="http://fedoraproject.org/wiki/Features/numad"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE=""
+
+CONFIG_CHECK="~NUMA ~CPUSETS"
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001-Fix-man-page-directory-creation.patch
+ tc-export CC
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -std=gnu99"
+}
+
+src_install() {
+ emake prefix="${ED}/usr" install
+}