summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2024-10-16 18:42:24 +0200
committerFlorian Schmaus <flow@gentoo.org>2024-10-16 18:46:59 +0200
commit34d81636b9e9d1fbe10a573e80a6106571188ece (patch)
tree6aa62cf2f94f925a0461dfc35d0c771e104de724 /sys-power/sandmann-bin
parentecm-common.eclass: Add missing dev-qt/qt{core,base}:[56] BDEPEND (diff)
downloadgentoo-34d81636b9e9d1fbe10a573e80a6106571188ece.tar.gz
gentoo-34d81636b9e9d1fbe10a573e80a6106571188ece.tar.bz2
gentoo-34d81636b9e9d1fbe10a573e80a6106571188ece.zip
sys-power/sandmann-bin: add 1.1
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-power/sandmann-bin')
-rw-r--r--sys-power/sandmann-bin/Manifest1
-rw-r--r--sys-power/sandmann-bin/sandmann-bin-1.1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/sys-power/sandmann-bin/Manifest b/sys-power/sandmann-bin/Manifest
index 0b4301de274d..df6e43ad9bd7 100644
--- a/sys-power/sandmann-bin/Manifest
+++ b/sys-power/sandmann-bin/Manifest
@@ -1 +1,2 @@
DIST sandmann-1.0.tar.xz 16661756 BLAKE2B 06a2ce44a0498987ce1dfafaa0aee560c2deef69efc7cfd6191dd12e265be21b15b167d7adc01066343a777cf66c88b2ec5d95f46fede003f80676966ad95ad3 SHA512 e9f5f41b4f2bf45f7d4528baf593f4f120e5a9c4eacf13a4c0961ba66f8ed5877abb3f10b6b35679dc56f2e55e80e0cc6bb3a42800859ff40354b0a750b16d66
+DIST sandmann-1.1.tar.xz 16864028 BLAKE2B d0ce1a575cfdfa67bc87f98e41146dd5dee9dc60e1baa9d58402255108d566efa6ade113b959e9590eef48778a1e386b09a47e3536ca7e6ba80e3e690a35dd4d SHA512 4d13c112df55352e1981ab79e804136dc4ff7ccd78697fdba4123069e84078e535e68f1661049b0fd22de2b6ad1cadf1f136dbacb6da612359420beb5b37e613
diff --git a/sys-power/sandmann-bin/sandmann-bin-1.1.ebuild b/sys-power/sandmann-bin/sandmann-bin-1.1.ebuild
new file mode 100644
index 000000000000..601f1616d2cf
--- /dev/null
+++ b/sys-power/sandmann-bin/sandmann-bin-1.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-utils-2 systemd tmpfiles
+
+MY_PN=${PN%-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An autosuspend and wakeup daemon"
+HOMEPAGE="https://gitlab.com/flow/sandmann"
+SRC_URI="https://geekplace.eu/projects/${MY_PN}/archive/${MY_P}.tar.xz"
+
+S="${WORKDIR}/${MY_P}"
+LICENSE="GPL-3+ LGPL-3"
+SLOT="0"
+
+KEYWORDS="~amd64"
+
+# >=java-config-2.3.2 to get the libdir fix.
+RDEPEND="
+ acct-user/sandmann
+ >=dev-java/java-config-2.3.2
+ sys-apps/systemd
+ sys-auth/polkit
+ >=virtual/jre-17
+"
+
+src_prepare() {
+ default
+ sed -i \
+ -e 's|^ExecStart=.*|ExecStart=/usr/bin/sandmann|' \
+ sandmann.service || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ local my_emake_args=(
+ DESTDIR="${D}"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+ TARGET_BINARY=
+ SOURCELESS_INSTALL=true
+ )
+
+ emake ${my_emake_args[@]} install
+
+ java-pkg_newjar out/main/assembly.dest/out.jar sandmann.jar
+ java-pkg_dolauncher sandmann
+
+ dodoc README.md
+}
+
+pkg_postinst() {
+ tmpfiles_process sandmann.conf
+}