summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-11 17:43:18 +0100
committerSam James <sam@gentoo.org>2022-09-11 17:43:18 +0100
commit9989744ef3d623582544d3715bf99dcd00399dbe (patch)
tree6ac74685f94110e1292969e38106dc17a5c619fc /sys-libs
parentsys-libs/pam: fix configure with Clang 15 (diff)
downloadgentoo-9989744ef3d623582544d3715bf99dcd00399dbe.tar.gz
gentoo-9989744ef3d623582544d3715bf99dcd00399dbe.tar.bz2
gentoo-9989744ef3d623582544d3715bf99dcd00399dbe.zip
sys-libs/ncurses: add additional mirrors
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/ncurses/ncurses-6.3_p20220910-r1.ebuild2
-rw-r--r--sys-libs/ncurses/ncurses-6.3_p20220910.ebuild2
2 files changed, 4 insertions, 0 deletions
diff --git a/sys-libs/ncurses/ncurses-6.3_p20220910-r1.ebuild b/sys-libs/ncurses/ncurses-6.3_p20220910-r1.ebuild
index 9a584b3a4e76..ef69dddce7cb 100644
--- a/sys-libs/ncurses/ncurses-6.3_p20220910-r1.ebuild
+++ b/sys-libs/ncurses/ncurses-6.3_p20220910-r1.ebuild
@@ -102,6 +102,8 @@ if [[ ${PV} == *_p* ]] ; then
for ((my_patch_index=0; my_patch_index < "${#PATCH_DATES[@]}"; my_patch_index++)); do
patch_url="$(printf "https://invisible-island.net/archives/${PN}/${PV/_p*}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
+ patch_url="$(printf "https://invisible-mirror.net/archives/${PN}/${PV/_p*}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
+ patch_url+=" $(printf "https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
SRC_URI+=" ${patch_url}"
SRC_URI+=" verify-sig? ( ${patch_url}.asc )"
UPSTREAM_PATCHES+=( "${WORKDIR}"/${MY_P}-${PATCH_DATES[${my_patch_index}]}.patch )
diff --git a/sys-libs/ncurses/ncurses-6.3_p20220910.ebuild b/sys-libs/ncurses/ncurses-6.3_p20220910.ebuild
index 9a584b3a4e76..ef69dddce7cb 100644
--- a/sys-libs/ncurses/ncurses-6.3_p20220910.ebuild
+++ b/sys-libs/ncurses/ncurses-6.3_p20220910.ebuild
@@ -102,6 +102,8 @@ if [[ ${PV} == *_p* ]] ; then
for ((my_patch_index=0; my_patch_index < "${#PATCH_DATES[@]}"; my_patch_index++)); do
patch_url="$(printf "https://invisible-island.net/archives/${PN}/${PV/_p*}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
+ patch_url="$(printf "https://invisible-mirror.net/archives/${PN}/${PV/_p*}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
+ patch_url+=" $(printf "https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${MY_P}-%s" ${PATCH_DATES[${my_patch_index}]}.patch.gz)"
SRC_URI+=" ${patch_url}"
SRC_URI+=" verify-sig? ( ${patch_url}.asc )"
UPSTREAM_PATCHES+=( "${WORKDIR}"/${MY_P}-${PATCH_DATES[${my_patch_index}]}.patch )