summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 09:55:36 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 09:58:55 +0100
commit38bca441a665b8aeeaaf51e8fdffe84c4067f0e2 (patch)
treeef2fa27d449c81fd528bdba2b3b2b6dc122acd26 /sys-libs/compiler-rt
parentdev-util/lldb: Delay llvm.org_set_globals after vars (diff)
downloadgentoo-38bca441a665b8aeeaaf51e8fdffe84c4067f0e2.tar.gz
gentoo-38bca441a665b8aeeaaf51e8fdffe84c4067f0e2.tar.bz2
gentoo-38bca441a665b8aeeaaf51e8fdffe84c4067f0e2.zip
sys-libs/compiler-rt: Delay llvm.org_set_globals after vars
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs/compiler-rt')
-rw-r--r--sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild8
-rw-r--r--sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild8
2 files changed, 10 insertions, 6 deletions
diff --git a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
index f913057ff615..38a2cbc81fbb 100644
--- a/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-11.0.0.9999.ebuild
@@ -8,8 +8,6 @@ inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( compiler-rt )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -26,9 +24,13 @@ BDEPEND="
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
- =sys-devel/clang-${PV%_*}*:${CLANG_SLOT} )
+ =sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
+ )
${PYTHON_DEPS}"
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
+
python_check_deps() {
use test || return 0
has_version "dev-python/lit[${PYTHON_USEDEP}]"
diff --git a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
index f913057ff615..38a2cbc81fbb 100644
--- a/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt/compiler-rt-12.0.0.9999.ebuild
@@ -8,8 +8,6 @@ inherit cmake flag-o-matic llvm llvm.org python-any-r1 toolchain-funcs
DESCRIPTION="Compiler runtime library for clang (built-in part)"
HOMEPAGE="https://llvm.org/"
-LLVM_COMPONENTS=( compiler-rt )
-llvm.org_set_globals
LICENSE="Apache-2.0-with-LLVM-exceptions || ( UoI-NCSA MIT )"
SLOT="$(ver_cut 1-3)"
@@ -26,9 +24,13 @@ BDEPEND="
clang? ( sys-devel/clang )
test? (
$(python_gen_any_dep ">=dev-python/lit-9.0.1[\${PYTHON_USEDEP}]")
- =sys-devel/clang-${PV%_*}*:${CLANG_SLOT} )
+ =sys-devel/clang-${PV%_*}*:${CLANG_SLOT}
+ )
${PYTHON_DEPS}"
+LLVM_COMPONENTS=( compiler-rt )
+llvm.org_set_globals
+
python_check_deps() {
use test || return 0
has_version "dev-python/lit[${PYTHON_USEDEP}]"