summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2020-09-27 19:29:25 -0400
committerMike Pagano <mpagano@gentoo.org>2020-09-27 19:29:25 -0400
commit35101426890f72636118c5e73faa80a43e662762 (patch)
treee521acf1088150f8d4e5640916b553a286909be4 /sys-kernel/git-sources/git-sources-5.9_rc7.ebuild
parentdev-embedded/libjaylink: Add BDEPEND on virtual/pkgconfig (diff)
downloadgentoo-35101426890f72636118c5e73faa80a43e662762.tar.gz
gentoo-35101426890f72636118c5e73faa80a43e662762.tar.bz2
gentoo-35101426890f72636118c5e73faa80a43e662762.zip
sys-kernel/git-sources: Linux patch 5.9-rc7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources/git-sources-5.9_rc7.ebuild')
-rw-r--r--sys-kernel/git-sources/git-sources-5.9_rc7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild
new file mode 100644
index 000000000000..c239fcfa16c8
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.9_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.8"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}