summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-02-02 08:33:16 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-02-02 10:53:06 +0200
commitbca5d4fb45ce222ce38ec21941d7af4ebe687a79 (patch)
tree859181f2856f602ca83a3834ea7b09147d1352ea /sys-fs
parentmedia-gfx/plantuml: bump to 1.2022.1 (diff)
downloadgentoo-bca5d4fb45ce222ce38ec21941d7af4ebe687a79.tar.gz
gentoo-bca5d4fb45ce222ce38ec21941d7af4ebe687a79.tar.bz2
gentoo-bca5d4fb45ce222ce38ec21941d7af4ebe687a79.zip
sys-fs/lxcfs: add 4.0.12
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/lxcfs/Manifest2
-rw-r--r--sys-fs/lxcfs/lxcfs-4.0.12.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/sys-fs/lxcfs/Manifest b/sys-fs/lxcfs/Manifest
index 00de6fa22034..4e0149e0c420 100644
--- a/sys-fs/lxcfs/Manifest
+++ b/sys-fs/lxcfs/Manifest
@@ -1,2 +1,4 @@
DIST lxcfs-4.0.11.tar.gz 451424 BLAKE2B 8cb1f16ec8f2f5dbcaea9897553c21f2894ce75713c4de7fd9412254ef4e74cef93fbd9c79e259e0caf2426520d9454858bc0f09b652b00305699d52b4240cbf SHA512 60a76b8d3ab8a164ead8424cf2a20cdb616919318881348016299d2b5bff9d221c12b9208b46e6f72a84695632a762292313e0b51579d590ce505cf5b6fec6de
DIST lxcfs-4.0.11.tar.gz.asc 833 BLAKE2B f70bcf119588c1e667111fe0e820c1bbd53c912027a94b600ce69713eb824f0b495cee4ab0107cf92bd5f10c0a17e9e5e85833f15f7ff570931c9df454f16bf9 SHA512 a9190c5913d0879c0034b1ff1f06b7755f8b78094270d64c89a371b56737e32c2a14681a58643e8ebde9d654ff2c66959ee9a4f6d5f6a6002f52da1362017d9f
+DIST lxcfs-4.0.12.tar.gz 461251 BLAKE2B c0d1cc699461eed2e29ddb1937e8f4719be78a8f17c20b9dd682a617bc0423b22b4491399b934aa7f4be8f5ca292ab4c9e97e7bf149700c0c3760c8b3804ae11 SHA512 da8415599bb08e4e15a7e4044edbcad217e4034d96366d508e06cceb2a75d459e24aeb7efd5716e2f41449ec653ecd9916f0d934f738e1df8e9576738cc1ac18
+DIST lxcfs-4.0.12.tar.gz.asc 833 BLAKE2B af8bf08039e7bc1f405c468de0dd628175cef3ea6087c5fa1c0d95f9153df939a84f9a5d9d895fb471c0262616eb88f03532ac789b0c6198ad1349cff9a6c5de SHA512 20f1919ff216f5459e8e387c78b1430b5122e662adec27bdd9c6fd4565645b73ed5bce5e7e843da05d8cfdc17f1a3e964c20c6ad47d4dbd5df68c3f9359fb362
diff --git a/sys-fs/lxcfs/lxcfs-4.0.12.ebuild b/sys-fs/lxcfs/lxcfs-4.0.12.ebuild
new file mode 100644
index 000000000000..8b6377221315
--- /dev/null
+++ b/sys-fs/lxcfs/lxcfs-4.0.12.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic systemd verify-sig
+
+DESCRIPTION="FUSE filesystem for LXC"
+HOMEPAGE="https://linuxcontainers.org/lxcfs/introduction/ https://github.com/lxc/lxcfs/"
+SRC_URI="https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz
+ verify-sig? ( https://linuxcontainers.org/downloads/lxcfs/${P}.tar.gz.asc )"
+
+LICENSE="Apache-2.0 LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="sys-fs/fuse:3"
+DEPEND="${RDEPEND}"
+BDEPEND="sys-apps/help2man
+ verify-sig? ( sec-keys/openpgp-keys-linuxcontainers )"
+
+# Looks like these won't ever work in a container/chroot environment. #764620
+RESTRICT="test"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/linuxcontainers.asc
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # Needed for x86 support, bug #819762
+ # May be able to drop when/if ported to meson, but re-test w/ x86 chroot
+ append-lfs-flags
+
+ # Without the localstatedir the filesystem isn't mounted correctly
+ # Without with-distro ./configure will fail when cross-compiling
+ econf --localstatedir=/var --with-distro=gentoo --disable-static
+}
+
+src_test() {
+ cd tests/ || die
+ emake -j1 tests
+ ./main.sh || die "Tests failed"
+}
+
+src_install() {
+ default
+
+ newconfd "${FILESDIR}"/lxcfs-4.0.0.confd lxcfs
+ newinitd "${FILESDIR}"/lxcfs-4.0.0.initd lxcfs
+
+ # Provide our own service file (copy of upstream) due to paths being different from upstream,
+ # #728470
+ systemd_newunit "${FILESDIR}"/lxcfs-4.0.0.service lxcfs.service
+
+ find "${ED}" -name '*.la' -delete || die
+}