summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/dmg2img
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/dmg2img')
-rw-r--r--sys-fs/dmg2img/Manifest5
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.1.ebuild36
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.2.ebuild36
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.4.ebuild36
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.5.ebuild36
-rw-r--r--sys-fs/dmg2img/dmg2img-1.6.ebuild36
-rw-r--r--sys-fs/dmg2img/metadata.xml13
7 files changed, 198 insertions, 0 deletions
diff --git a/sys-fs/dmg2img/Manifest b/sys-fs/dmg2img/Manifest
new file mode 100644
index 000000000000..23e8b3a4eae8
--- /dev/null
+++ b/sys-fs/dmg2img/Manifest
@@ -0,0 +1,5 @@
+DIST dmg2img-1.6.1.tar.gz 38025 SHA256 55e65c1e47bf78f09fb061b2db4f41c515c0cbaa932e3ff3b40bd2d981946ad2
+DIST dmg2img-1.6.2.tar.gz 24541 SHA256 8f1508a70cbe2275023ec293667790a813fada07fb4a39223e07bd44b3967dc5
+DIST dmg2img-1.6.4.tar.gz 24335 SHA256 cbbb8366196eea4609b35807a72b39b9edae7e518748a42c6dc6b69ee19d99ed SHA512 4c40e4b58c010e40661f4061e1c111ce362d341309c0d16669f481f31051f026ac7af5fb1c196ea2da263f79900e03bee3ca88c15cb5ec58617721b01212469c WHIRLPOOL 30c247c90eb624c78e72b2bbd287cb07ce511f0586c96d571fe6451b1ad3b70ceab2cb92cf1e4d7a011bd0177abf8f1b0ffb647f0831dbd3677def0f6e151219
+DIST dmg2img-1.6.5.tar.gz 23442 SHA256 400a16cbe5cb2bf8a9eec4a43ef3546e0329f248bbd2a79f6d9a1ebc0b503308 SHA512 31528a23986848a8ab319768a8254db6b0035324cbac8328ef865b98ab2cddfd606da19a27202c4ef53cdc5dda75aca489859f82115a5dde6fe9b1f20cd6bd46 WHIRLPOOL bbf35c53b42f821603610a33faa1868b2c4d66e76347d39ba2069662c7ea65d3b5aacfa6f2d09e5e602b5fb47e68d3914cd8cab8d6009aba2b6f8fff40f5077d
+DIST dmg2img-1.6.tar.gz 38003 SHA256 c9a8253772eeccc18f3e92f72c7969a034cf2a7856f6a709b601e5a8e5188c48
diff --git a/sys-fs/dmg2img/dmg2img-1.6.1.ebuild b/sys-fs/dmg2img/dmg2img-1.6.1.ebuild
new file mode 100644
index 000000000000..94cbdb407db5
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+#SRC_URI="http://vu1tur.eu.org/tools/download.pl?${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dosbin dmg2img vfdecrypt || die "dosbin failed"
+ dodoc README
+}
diff --git a/sys-fs/dmg2img/dmg2img-1.6.2.ebuild b/sys-fs/dmg2img/dmg2img-1.6.2.ebuild
new file mode 100644
index 000000000000..f247b5a181e5
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dosbin dmg2img vfdecrypt || die "dosbin failed"
+ dodoc README
+ doman vfdecrypt.1
+}
diff --git a/sys-fs/dmg2img/dmg2img-1.6.4.ebuild b/sys-fs/dmg2img/dmg2img-1.6.4.ebuild
new file mode 100644
index 000000000000..5f9c703d031b
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dosbin dmg2img vfdecrypt
+ dodoc README
+ doman vfdecrypt.1
+}
diff --git a/sys-fs/dmg2img/dmg2img-1.6.5.ebuild b/sys-fs/dmg2img/dmg2img-1.6.5.ebuild
new file mode 100644
index 000000000000..711fe160f4df
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+SRC_URI="http://vu1tur.eu.org/tools/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin dmg2img vfdecrypt
+ dodoc README
+ doman vfdecrypt.1
+}
diff --git a/sys-fs/dmg2img/dmg2img-1.6.ebuild b/sys-fs/dmg2img/dmg2img-1.6.ebuild
new file mode 100644
index 000000000000..b89b644e2af5
--- /dev/null
+++ b/sys-fs/dmg2img/dmg2img-1.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit toolchain-funcs
+
+DESCRIPTION="Converts Apple DMG files to standard HFS+ images"
+HOMEPAGE="http://vu1tur.eu.org/tools"
+#SRC_URI="http://vu1tur.eu.org/tools/download.pl?${P}.tar.gz"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl
+ app-arch/bzip2
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ sys-apps/sed"
+
+src_prepare() {
+ sed -i -e 's:-s:$(LDFLAGS):g' Makefile || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dosbin dmg2img vfdecrypt || die "dosbin failed"
+ dodoc README
+}
diff --git a/sys-fs/dmg2img/metadata.xml b/sys-fs/dmg2img/metadata.xml
new file mode 100644
index 000000000000..05318e4ef169
--- /dev/null
+++ b/sys-fs/dmg2img/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+<email>josejx@gentoo.org</email>
+<name>Joseph Jezak</name>
+</maintainer>
+<longdescription lang="en">
+ dmg2img is an application that can convert .dmg files, popular on Mac OSX
+ systems, to HFS+ disk images, suitable for mounting on Linux systems.
+</longdescription>
+</pkgmetadata>