summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorColin Gillespie <colin@cgillespie.xyz>2023-08-14 12:16:49 +1000
committerSam James <sam@gentoo.org>2023-08-28 07:16:51 +0100
commitd40b04ded7d8c6505ad6a958ab8eda9b0ad842f2 (patch)
tree759ec091a7362be2b3db0b27088910c6e647cb54 /sys-fs/bcachefs-tools
parentsys-kernel/gentoo-kernel-bin: Bump to 6.1.49 (diff)
downloadgentoo-d40b04ded7d8c6505ad6a958ab8eda9b0ad842f2.tar.gz
gentoo-d40b04ded7d8c6505ad6a958ab8eda9b0ad842f2.tar.bz2
gentoo-d40b04ded7d8c6505ad6a958ab8eda9b0ad842f2.zip
sys-fs/bcachefs-tools: move binaries to /sbin
bcachefs and mount/fsck/mkfs helpers are expected to reside in /sbin. Signed-off-by: Colin Gillespie <colin@cgillespie.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/bcachefs-tools')
-rw-r--r--sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild16
1 files changed, 10 insertions, 6 deletions
diff --git a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
index 3e057d19c8ff..e0dd0d66a627 100644
--- a/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
+++ b/sys-fs/bcachefs-tools/bcachefs-tools-9999.ebuild
@@ -23,7 +23,7 @@ if [[ ${PV} == "9999" ]]; then
else
MY_COMMIT=1f78fed4693a5361f56508daac59bebd5b556379
SRC_URI="https://github.com/koverstreet/bcachefs-tools/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz
- $(cargo_crate_uris ${CRATES})"
+ ${CARGO_CRATE_URIS}"
S="${WORKDIR}/${PN}-${MY_COMMIT}"
KEYWORDS="~amd64"
fi
@@ -129,11 +129,15 @@ src_test() {
}
src_install() {
- exeinto /usr/bin
- local file
- for file in bcachefs fsck.bcachefs mkfs.bcachefs mount.bcachefs; do
- doexe $file
- done
+ into /
+ dosbin bcachefs fsck.bcachefs mkfs.bcachefs mount.bcachefs
+
+ if use fuse; then
+ dosbin mount.fuse.bcachefs
+ newsbin fsck.bcachefs fsck.fuse.bcachefs
+ newsbin mkfs.bcachefs mkfs.fuse.bcachefs
+ fi
+
doman bcachefs.8
}