summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Kanzenbach <kurt@kmk-computers.de>2021-07-15 21:31:45 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-07-23 17:33:14 +0300
commitd87f72e801ea53c3d2707558eefd1eca60e11acc (patch)
tree40bc18c926bfcbb0693732d50db83788ae77dc69 /sys-cluster
parentdev-libs/libfido2: Bump to version 1.8.0 (diff)
downloadgentoo-d87f72e801ea53c3d2707558eefd1eca60e11acc.tar.gz
gentoo-d87f72e801ea53c3d2707558eefd1eca60e11acc.tar.bz2
gentoo-d87f72e801ea53c3d2707558eefd1eca60e11acc.zip
sys-cluster/hpx: Bump to v1.7.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/hpx/Manifest1
-rw-r--r--sys-cluster/hpx/files/hpx-1.7.0-python.patch30
-rw-r--r--sys-cluster/hpx/hpx-1.7.0.ebuild102
3 files changed, 133 insertions, 0 deletions
diff --git a/sys-cluster/hpx/Manifest b/sys-cluster/hpx/Manifest
index 3cdb83c4d054..dddef438e7fd 100644
--- a/sys-cluster/hpx/Manifest
+++ b/sys-cluster/hpx/Manifest
@@ -1 +1,2 @@
DIST hpx-1.6.0.tar.gz 4596486 BLAKE2B e19d88d70d3dec45536b4f174bc1bae49285bde3db37517381071bec318748913ff239c66f02acb15451dc2f38a7799e9424fc5269851478b33da81654bd6c16 SHA512 cd717db3812fc26117d72c8afa654972b16f7059d8e6965484edd938788f3369fcd5ca791eee80e803703d6f3c39b3a3cd0525ab9f58ff1312e1b49f06ce67bc
+DIST hpx-1.7.0.tar.gz 4729879 BLAKE2B 05be1461eb0867b690a8f34a7ddf46d4fa19e05b5666df6cf5a3dfd28fa6a6ecacf6305bf2eaa42a669f18264b61c9690988695b8748ba09a27011001b543952 SHA512 052b3278710d8047c8e0e0979a668aa5161c495fcd12b089dd5039c64bd414b4ec0b96dfcd414d68e0db5b31c360dffb84374413c53794f37ce77d9cabc89518
diff --git a/sys-cluster/hpx/files/hpx-1.7.0-python.patch b/sys-cluster/hpx/files/hpx-1.7.0-python.patch
new file mode 100644
index 000000000000..21b7ce3ceeff
--- /dev/null
+++ b/sys-cluster/hpx/files/hpx-1.7.0-python.patch
@@ -0,0 +1,30 @@
+From 3d8d3acf0daad9cec8b092d67f7187265f7704e3 Mon Sep 17 00:00:00 2001
+From: Kurt Kanzenbach <kurt@kmk-computers.de>
+Date: Tue, 17 Mar 2020 16:20:35 +0100
+Subject: [PATCH 1/4] cmake: python: Use standard python interpreter
+
+These scripts are needed during build and run time. So, use a python interpreter
+which works for both cases.
+
+Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
+---
+ cmake/templates/hpxcxx.in | 2 +-
+ cmake/templates/hpxrun.py.in | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+--- a/cmake/templates/hpxcxx.in
++++ b/cmake/templates/hpxcxx.in
+@@ -1,4 +1,4 @@
+-#! @PYTHON_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Steven R. Brandt
+ #
+--- a/cmake/templates/hpxrun.py.in
++++ b/cmake/templates/hpxrun.py.in
+@@ -1,4 +1,4 @@
+-#! @PYTHON_EXECUTABLE@
++#! /usr/bin/env python
+ #
+ # Copyright (c) 2014 Thomas Heller
+ #
diff --git a/sys-cluster/hpx/hpx-1.7.0.ebuild b/sys-cluster/hpx/hpx-1.7.0.ebuild
new file mode 100644
index 000000000000..e7e729860daa
--- /dev/null
+++ b/sys-cluster/hpx/hpx-1.7.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/STEllAR-GROUP/hpx.git"
+else
+ SRC_URI="https://github.com/STEllAR-GROUP/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+fi
+inherit check-reqs cmake multiprocessing python-single-r1
+
+DESCRIPTION="C++ runtime system for parallel and distributed applications"
+HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
+
+SLOT="0"
+LICENSE="Boost-1.0"
+IUSE="examples jemalloc mpi papi +perftools tbb"
+# tests fail to compile
+RESTRICT="test"
+
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ?? ( jemalloc perftools tbb )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/boost:=
+ sys-apps/hwloc
+ sys-libs/zlib
+ mpi? ( virtual/mpi )
+ papi? ( dev-libs/papi )
+ perftools? ( dev-util/google-perftools )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-python.patch"
+)
+
+hpx_memory_requirement() {
+ # HPX needs enough main memory for compiling
+ # rule of thumb: 1G per job
+ if [[ -z ${MAKEOPTS} ]] ; then
+ echo "2G"
+ else
+ local jobs=$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")
+ echo "${jobs}G"
+ fi
+}
+
+pkg_pretend() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+}
+
+pkg_setup() {
+ local CHECKREQS_MEMORY=$(hpx_memory_requirement)
+ check-reqs_pkg_setup
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DHPX_WITH_EXAMPLES=OFF
+ -DHPX_WITH_DOCUMENTATION=OFF
+ -DHPX_WITH_PARCELPORT_MPI=$(usex mpi)
+ -DHPX_WITH_PAPI=$(usex papi)
+ -DHPX_WITH_GOOGLE_PERFTOOLS=$(usex perftools)
+ -DBUILD_TESTING=OFF
+ )
+ if use jemalloc; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=jemalloc )
+ elif use perftools; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tcmalloc )
+ elif use tbb; then
+ mycmakeargs+=( -DHPX_WITH_MALLOC=tbbmalloc )
+ else
+ mycmakeargs+=( -DHPX_WITH_MALLOC=system )
+ fi
+
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+}
+
+src_install() {
+ cmake_src_install
+ use examples && dodoc -r examples/
+ python_fix_shebang "${ED}"
+}