summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-05-04 15:37:12 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-05-04 15:43:24 -0700
commitcf1586831645abb734e92e5f4224f8d6d825c23a (patch)
treeb9a7a2b5ea17b35b50cc869dc8249063c5a37a54 /sys-cluster
parentx11-misc/virtualgl: Stabilize 3.0-r1 amd64, #842600 (diff)
downloadgentoo-cf1586831645abb734e92e5f4224f8d6d825c23a.tar.gz
gentoo-cf1586831645abb734e92e5f4224f8d6d825c23a.tar.bz2
gentoo-cf1586831645abb734e92e5f4224f8d6d825c23a.zip
sys-cluster/ceph: add 17.2.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/ceph/Manifest2
-rw-r--r--sys-cluster/ceph/ceph-17.2.0.ebuild455
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-boost-1.74.patch25
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch53
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch69
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-findre2.patch22
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch12
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch68
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch26
-rw-r--r--sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch20
-rw-r--r--sys-cluster/ceph/metadata.xml5
11 files changed, 757 insertions, 0 deletions
diff --git a/sys-cluster/ceph/Manifest b/sys-cluster/ceph/Manifest
index 45f6d44762e5..884ad263bca6 100644
--- a/sys-cluster/ceph/Manifest
+++ b/sys-cluster/ceph/Manifest
@@ -1,3 +1,5 @@
DIST ceph-14.2.22.tar.gz 130597047 BLAKE2B 58bbb3243de076ed1d25dfd7bd75717c50ad15d16690dcbd1511d1b506477845efc3ff7fbe713cf18fb8cfcc8c16707ad2a0f30159e3198ff82e57fbd2eb3cf2 SHA512 1c66661e1a39fa9151e95e33c390b810ffe269465d8785e2197cc15b8d83bd2edde77de48a8abd71a4da68cd5830ff14bcdf6b98fd17edabe85caeb1eca018d3
DIST ceph-15.2.16.tar.gz 148628915 BLAKE2B 4f624078027c706428eae3eddd5b5479efe3b4442c19a4e6b6cdf8d3839cf56e2863b18249dc3c5079a7e25f60796bfec3202ffd695537587654f5e2f820caaa SHA512 532b8a5073e157fe9ed552b26976faeb64dc29b79a249910c0982134ad5f945d4f57d8bf451adf63487b6d285c6e4bd5c39f0e3fcd449230d6fb3087539f8c3b
DIST ceph-16.2.7.tar.gz 156621262 BLAKE2B 3c79cb1586e71927df4578fe7f3a13f4ab257a5e145b6bf76d942292cbca7bf32583350373f3d816f6d8f8700ee0f98a14f350c823b0eb89ffd7735acee7de63 SHA512 eab047e646970d444acf1064d98237b8b1677fb16b5e771082d55880f7bc6d8bdb278c2fe514c82ae12c438878d9ecea29139fa6b8d890f9f737138f10fb740c
+DIST ceph-17.2.0.tar.gz 168742006 BLAKE2B 15272da3471722936198f62b5ef7537d29bd944b35ef1552e87cf0f0f400a8be5fd1fa873494eb17ca71df9360d7ffa4fa20a6f1b1ba819520b180770a4e6299 SHA512 70b96e709f153f16069bec8346ea73812d699eaab91a012351d02addb3fd176b84fce32c3dae84fdf91d0ffe49f2bb258410b47caeee81d81a672b4dbd04cc7e
+DIST ceph-xsimd-17.2.0.tar.gz 173025 BLAKE2B 54679c24804c195ae55b9f49589e331dde92c6d89aaa20e827539e9a4e0010c7549cdd5cf02a7ebed83f953ab2a6f1d9cc9a98cf45c3dc7758ae4938c9c43713 SHA512 ecc58e7909648aaa22aefbf76ee2c5a2bece4b1b88da9c7eda1b69a46247e619ff99c4366afd6015f95debd68c1a6b89292c677b9049462d0fc0255fbc0c2a33
diff --git a/sys-cluster/ceph/ceph-17.2.0.ebuild b/sys-cluster/ceph/ceph-17.2.0.ebuild
new file mode 100644
index 000000000000..74a067688a6d
--- /dev/null
+++ b/sys-cluster/ceph/ceph-17.2.0.ebuild
@@ -0,0 +1,455 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+LUA_COMPAT=( lua5-{3..4} )
+
+inherit check-reqs bash-completion-r1 cmake flag-o-matic lua-single \
+ python-r1 udev readme.gentoo-r1 toolchain-funcs systemd tmpfiles
+
+SRC_URI="
+ https://download.ceph.com/tarballs/${P}.tar.gz
+ parquet? ( https://github.com/xtensor-stack/xsimd/archive/aeec9c872c8b475dedd7781336710f2dd2666cb2.tar.gz -> ceph-xsimd-${PV}.tar.gz )
+"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Ceph distributed filesystem"
+HOMEPAGE="https://ceph.com/"
+
+LICENSE="Apache-2.0 LGPL-2.1 CC-BY-SA-3.0 GPL-2 GPL-2+ LGPL-2+ LGPL-2.1 LGPL-3 GPL-3 BSD Boost-1.0 MIT public-domain"
+SLOT="0"
+
+CPU_FLAGS_X86=(avx2 avx512f pclmul sse{,2,3,4_1,4_2} ssse3)
+
+IUSE="
+ babeltrace +cephfs custom-cflags diskprediction dpdk fuse grafana
+ jemalloc jaeger kafka kerberos ldap lttng +mgr +parquet pmdk rabbitmq
+ +radosgw rbd-rwl rbd-ssd rdma rgw-lua +ssl spdk +sqlite +system-boost
+ systemd +tcmalloc test +uring xfs zbd zfs
+"
+
+IUSE+="$(printf "cpu_flags_x86_%s\n" ${CPU_FLAGS_X86[@]})"
+
+DEPEND="
+ ${LUA_DEPS}
+ ${PYTHON_DEPS}
+ acct-group/ceph
+ acct-user/ceph
+ virtual/libudev:=
+ app-arch/bzip2:=
+ app-arch/lz4:=
+ app-arch/snappy:=
+ || ( >=app-arch/snappy-1.1.9-r1 <app-arch/snappy-1.1.9 )
+ app-arch/zstd:=
+ app-shells/bash:0
+ app-misc/jq:=
+ dev-libs/crypto++:=
+ dev-cpp/gflags:=
+ <dev-libs/leveldb-1.23:=[snappy,tcmalloc(-)?]
+ dev-libs/libaio:=
+ >=dev-libs/libfmt-6.2.1:=
+ dev-libs/libnl:3=
+ dev-libs/libxml2:=
+ dev-libs/libevent:=
+ dev-libs/libutf8proc:=
+ dev-libs/openssl:=
+ <dev-libs/rocksdb-6.15:=
+ dev-libs/thrift:=
+ dev-libs/xmlsec:=[openssl]
+ dev-cpp/yaml-cpp:=
+ dev-libs/nss:=
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ net-dns/c-ares:=
+ net-libs/gnutls:=
+ sys-auth/oath-toolkit:=
+ sys-apps/coreutils
+ sys-apps/hwloc:=
+ sys-apps/keyutils:=
+ sys-apps/util-linux:=
+ sys-libs/libcap-ng:=
+ sys-libs/ncurses:0=
+ sys-libs/zlib:=
+ sys-process/numactl:=
+ virtual/libcrypt:=
+ x11-libs/libpciaccess:=
+ babeltrace? ( dev-util/babeltrace )
+ fuse? ( sys-fs/fuse:0= )
+ jemalloc? ( dev-libs/jemalloc:= )
+ !jemalloc? ( >=dev-util/google-perftools-2.6.1:= )
+ jaeger? (
+ dev-cpp/nlohmann_json:=
+ dev-cpp/opentelemetry-cpp:=[jaeger]
+ )
+ kafka? ( dev-libs/librdkafka:= )
+ kerberos? ( virtual/krb5 )
+ ldap? ( net-nds/openldap:= )
+ lttng? ( dev-util/lttng-ust:= )
+ parquet? ( dev-libs/re2:= )
+ pmdk? ( dev-libs/pmdk:= )
+ rabbitmq? ( net-libs/rabbitmq-c:= )
+ radosgw? (
+ dev-libs/icu:=
+ dev-libs/expat:=
+ net-misc/curl:=[curl_ssl_openssl]
+ )
+ rbd-rwl? ( dev-libs/pmdk:= )
+ rdma? ( sys-cluster/rdma-core:= )
+ spdk? ( dev-util/cunit )
+ sqlite? ( dev-db/sqlite:= )
+ system-boost? ( >=dev-libs/boost-1.72:=[threads(+),context,python,${PYTHON_USEDEP}] )
+ uring? ( sys-libs/liburing:= )
+ xfs? ( sys-fs/xfsprogs:= )
+ zbd? ( sys-block/libzbd:= )
+ zfs? ( sys-fs/zfs:= )
+"
+BDEPEND="
+ amd64? ( dev-lang/nasm )
+ x86? ( dev-lang/yasm )
+ app-arch/cpio
+ >=dev-util/cmake-3.5.0
+ dev-python/cython[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/sphinx
+ dev-util/gperf
+ dev-util/ragel
+ dev-util/valgrind
+ sys-apps/coreutils
+ sys-apps/grep
+ sys-apps/sed
+ sys-apps/util-linux
+ sys-apps/which
+ sys-devel/bc
+ sys-devel/patch
+ virtual/pkgconfig
+ jaeger? (
+ sys-devel/bison
+ sys-devel/flex
+ )
+ test? (
+ dev-util/cunit
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/requests-mock[${PYTHON_USEDEP}]
+ sys-apps/grep[pcre]
+ sys-fs/btrfs-progs
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ app-admin/sudo
+ net-misc/socat
+ sys-apps/gptfdisk
+ sys-apps/nvme-cli
+ >=sys-apps/smartmontools-7.0
+ sys-block/parted
+ sys-fs/cryptsetup
+ sys-fs/lsscsi
+ sys-fs/lvm2[-device-mapper-only(-)]
+ virtual/awk
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/cherrypy[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pecan[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ mgr? (
+ dev-python/jsonpatch[${PYTHON_USEDEP}]
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pyjwt[${PYTHON_USEDEP}]
+ dev-python/routes[${PYTHON_USEDEP}]
+ diskprediction? (
+ >=dev-python/scipy-1.4.0[${PYTHON_USEDEP}]
+ )
+ sci-libs/scikit-learn[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ )
+"
+# diskprediction needs older scipy not compatible with py38
+# bug #724438
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
+ ${LUA_REQUIRED_USE}
+ ?? ( jemalloc tcmalloc )
+ diskprediction? ( mgr )
+ kafka? ( radosgw )
+ mgr? ( cephfs )
+ rabbitmq? ( radosgw )
+ rgw-lua? ( radosgw )
+"
+
+RESTRICT="
+ !test? ( test )
+"
+
+# tests need root access, and network access
+RESTRICT+="test"
+
+# false positives unless all USE flags are on
+CMAKE_WARN_UNUSED_CLI=no
+
+PATCHES=(
+ "${FILESDIR}/ceph-12.2.0-use-provided-cpu-flag-values.patch"
+ "${FILESDIR}/ceph-14.2.0-cflags.patch"
+ "${FILESDIR}/ceph-12.2.4-boost-build-none-options.patch"
+ "${FILESDIR}/ceph-16.2.2-cflags.patch"
+ "${FILESDIR}/ceph-17.2.0-no-virtualenvs.patch"
+ "${FILESDIR}/ceph-13.2.2-dont-install-sysvinit-script.patch"
+ "${FILESDIR}/ceph-14.2.0-dpdk-cflags.patch"
+ "${FILESDIR}/ceph-16.2.0-rocksdb-cmake.patch"
+ "${FILESDIR}/ceph-16.2.0-spdk-tinfo.patch"
+ "${FILESDIR}/ceph-16.2.0-jaeger-system-boost.patch"
+ "${FILESDIR}/ceph-16.2.0-liburing.patch"
+ "${FILESDIR}/ceph-17.2.0-cyclic-deps.patch"
+ "${FILESDIR}/ceph-17.2.0-pybind-boost-1.74.patch"
+ "${FILESDIR}/ceph-17.2.0-findre2.patch"
+ "${FILESDIR}/ceph-17.2.0-install-dbstore.patch"
+ "${FILESDIR}/ceph-17.2.0-deprecated-boost.patch"
+ "${FILESDIR}/ceph-17.2.0-system-opentelemetry.patch"
+)
+
+check-reqs_export_vars() {
+ CHECKREQS_DISK_BUILD="6G"
+
+ if use system-boost; then
+ CHECKREQS_DISK_USR="350M"
+ else
+ CHECKREQS_DISK_USR="510M"
+ fi
+
+ export CHECKREQS_DISK_BUILD CHECKREQS_DISK_USR
+}
+
+pkg_pretend() {
+ check-reqs_export_vars
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ python_setup
+ lua_setup
+ check-reqs_export_vars
+ check-reqs_pkg_setup
+}
+
+src_prepare() {
+ cmake_src_prepare
+
+ if use system-boost; then
+ find "${S}" -name '*.cmake' -or -name 'CMakeLists.txt' -print0 \
+ | xargs --null sed -r \
+ -e 's|Boost::|boost_|g' \
+ -e 's|Boost_|boost_|g' \
+ -e 's|[Bb]oost_boost|boost_system|g' \
+ -i || die
+ fi
+
+ if ! use systemd; then
+ find "${S}"/src/ceph-volume/ceph_volume -name '*.py' -print0 \
+ | xargs --null sed \
+ -e '/^from ceph_volume.systemd import systemctl/ d' \
+ -i || die
+ fi
+
+ sed -r -e "s:DESTINATION .+\\):DESTINATION $(get_bashcompdir)\\):" \
+ -i src/bash_completion/CMakeLists.txt || die
+
+ sed -e "s:objdump -p:$(tc-getOBJDUMP) -p:" -i CMakeLists.txt || die
+
+ # force lua version to use selected version
+ local lua_version
+ lua_version=$(ver_cut 1-2 $(lua_get_version))
+ sed "s:find_package(Lua [0-9][.][0-9] REQUIRED):find_package(Lua ${lua_version} EXACT REQUIRED):" \
+ -i src/CMakeLists.txt
+
+ # remove tests that need root access
+ rm src/test/cli/ceph-authtool/cap*.t || die
+}
+
+ceph_src_configure() {
+ local mycmakeargs=(
+ -DWITH_BABELTRACE:BOOL=$(usex babeltrace)
+ -DWITH_BLUESTORE_PMEM:BOOL=$(usex pmdk)
+ -DWITH_CEPHFS:BOOL=$(usex cephfs)
+ -DWITH_CEPHFS_SHELL:BOOL=$(usex cephfs)
+ -DWITH_DPDK:BOOL=$(usex dpdk)
+ -DWITH_SPDK:BOOL=$(usex spdk)
+ -DWITH_FUSE:BOOL=$(usex fuse)
+ -DWITH_LTTNG:BOOL=$(usex lttng)
+ -DWITH_GSSAPI:BOOL=$(usex kerberos)
+ -DWITH_GRAFANA:BOOL=$(usex grafana)
+ -DWITH_MGR:BOOL=$(usex mgr)
+ -DWITH_MGR_DASHBOARD_FRONTEND:BOOL=OFF
+ -DWITH_OPENLDAP:BOOL=$(usex ldap)
+ -DWITH_PYTHON3:STRING=3
+ -DWITH_RADOSGW:BOOL=$(usex radosgw)
+ -DWITH_RADOSGW_AMQP_ENDPOINT:BOOL=$(usex rabbitmq)
+ -DWITH_RADOSGW_KAFKA_ENDPOINT:BOOL=$(usex kafka)
+ -DWITH_RADOSGW_LUA_PACKAGES:BOOL=$(usex rgw-lua "$(usex radosgw)" "NO")
+ -DWITH_RBD_RWL:BOOL=$(usex rbd-rwl)
+ -DWITH_RBD_SSD_CACHE:BOOL=$(usex rbd-ssd)
+ -DWITH_SYSTEMD:BOOL=$(usex systemd)
+ -DWITH_TESTS:BOOL=$(usex test)
+ -DWITH_LIBURING:BOOL=$(usex uring)
+ -DWITH_SYSTEM_LIBURING:BOOL=$(usex uring)
+ -DWITH_LIBCEPHSQLITE:BOOL=$(usex sqlite)
+ -DWITH_XFS:BOOL=$(usex xfs)
+ -DWITH_ZBD:BOOL=$(usex zbd)
+ -DWITH_ZFS:BOOL=$(usex zfs)
+ -DENABLE_SHARED:BOOL=ON
+ -DALLOCATOR:STRING=$(usex tcmalloc 'tcmalloc' "$(usex jemalloc 'jemalloc' 'libc')")
+ -DWITH_SYSTEM_PMDK:BOOL=$(usex pmdk 'YES' "$(usex rbd-rwl '')")
+ -DWITH_SYSTEM_BOOST:BOOL=$(usex system-boost)
+ -DWITH_SYSTEM_ROCKSDB:BOOL=ON
+ -DWITH_SYSTEM_ZSTD:BOOL=ON
+ -DWITH_RDMA:BOOL=$(usex rdma)
+ -DCMAKE_INSTALL_DOCDIR:PATH="${EPREFIX}/usr/share/doc/${PN}-${PVR}"
+ -DCMAKE_INSTALL_SYSCONFDIR:PATH="${EPREFIX}/etc"
+ -Wno-dev
+ )
+
+ # this breaks when re-configuring for python impl
+ if [[ ${EBUILD_PHASE} == configure ]]; then
+ mycmakeargs+=(
+ -DWITH_JAEGER:BOOL=$(usex jaeger)
+ -DWITH_RADOSGW_SELECT_PARQUET:BOOL=$(usex parquet)
+ )
+ else
+ mycmakeargs+=(
+ -DWITH_RADOSGW_SELECT_PARQUET:BOOL=OFF
+ )
+ fi
+
+ # conditionally used cmake args
+ use test && mycmakearts+=( -DWITH_SYSTEM_GTEST:BOOL=$(usex test) )
+ use systemd && mycmakeargs+=( -DSYSTEMD_SYSTEM_UNIT_DIR:PATH=$(systemd_get_systemunitdir) )
+
+ if use amd64 || use x86; then
+ local flag
+ for flag in "${CPU_FLAGS_X86[@]}"; do
+ case "${flag}" in
+ avx*)
+ local var=${flag%f}
+ mycmakeargs+=(
+ "-DHAVE_NASM_X64_${var^^}:BOOL=$(usex cpu_flags_x86_${flag})"
+ )
+ ;;
+ *) mycmakeargs+=(
+ "-DHAVE_INTEL_${flag^^}:BOOL=$(usex cpu_flags_x86_${flag})"
+ );;
+ esac
+ done
+ fi
+
+ # needed for >=glibc-2.32
+ has_version '>=sys-libs/glibc-2.32' && mycmakeargs+=( -DWITH_REENTRANT_STRSIGNAL:BOOL=ON )
+
+ rm -f "${BUILD_DIR:-${S}}/CMakeCache.txt" \
+ || die "failed to remove cmake cache"
+
+ # hopefully this will not be necessary in the next release
+ use parquet && export ARROW_XSIMD_URL="file:///${DISTDIR}/ceph-xsimd-${PV}.tar.gz"
+
+ cmake_src_configure
+
+ # bug #630232
+ sed -i "s:\"${T//:\\:}/${EPYTHON}/bin/python\":\"${PYTHON}\":" \
+ "${BUILD_DIR:-${S}}"/include/acconfig.h \
+ || die "sed failed"
+}
+
+src_configure() {
+ use custom-cflags || strip-flags
+ ceph_src_configure
+}
+
+src_compile() {
+ cmake_build all
+
+ # we have to do this here to prevent from building everything multiple times
+ python_copy_sources
+ python_foreach_impl python_compile
+}
+
+python_compile() {
+ local CMAKE_USE_DIR="${S}"
+ ceph_src_configure
+
+ cmake_build src/pybind/CMakeFiles/cython_modules
+}
+
+src_install() {
+ python_foreach_impl python_install
+
+ python_setup
+ cmake_src_install
+
+ find "${ED}" -name '*.la' -type f -delete || die
+
+ exeinto /usr/$(get_libdir)/ceph
+ newexe "${BUILD_DIR}/bin/init-ceph" init-ceph
+
+ insinto /etc/logrotate.d/
+ newins "${FILESDIR}"/ceph.logrotate-r2 ${PN}
+
+ keepdir /var/lib/${PN}{,/tmp} /var/log/${PN}/stat
+
+ fowners -R ceph:ceph /var/log/ceph
+
+ newinitd "${FILESDIR}/rbdmap.initd-r1" rbdmap
+ newinitd "${FILESDIR}/${PN}.initd-r12" ${PN}
+ newconfd "${FILESDIR}/${PN}.confd-r5" ${PN}
+
+ insinto /etc/sudoers.d
+ doins sudoers.d/*
+
+ insinto /etc/sysctl.d
+ newins "${FILESDIR}"/sysctld 90-${PN}.conf
+
+ use tcmalloc && newenvd "${FILESDIR}"/envd-tcmalloc 99${PN}-tcmalloc
+
+ # units aren't installed by the build system unless systemd is enabled
+ # so no point installing these with the USE flag disabled
+ if use systemd; then
+ systemd_install_serviced "${FILESDIR}/ceph-mds_at.service.conf" "ceph-mds@.service"
+ systemd_install_serviced "${FILESDIR}/ceph-osd_at.service.conf" "ceph-osd@.service"
+ fi
+
+ udev_dorules udev/*.rules
+ newtmpfiles "${FILESDIR}"/ceph-tmpfilesd ${PN}.conf
+
+ readme.gentoo_create_doc
+
+ # bug #630232
+ sed -i -r "s:${T//:/\\:}/${EPYTHON}:/usr:" "${ED}"/usr/bin/ceph{,-crash} \
+ || die "sed failed"
+
+ python_fix_shebang "${ED}"/usr/{,s}bin/
+
+ # python_fix_shebang apparently is not idempotent
+ local shebang_regex='(/usr/lib/python-exec/python[0-9]\.[0-9]/python)[0-9]\.[0-9]'
+ grep -r -E -l --null "${shebang_regex}" "${ED}"/usr/{s,}bin/ \
+ | xargs --null --no-run-if-empty -- sed -i -r "s:${shebang_regex}:\1:" || die
+
+ local -a rados_classes=( "${ED}/usr/$(get_libdir)/rados-classes"/* )
+ dostrip -x "${rados_classes[@]#${ED}}"
+}
+
+python_install() {
+ local CMAKE_USE_DIR="${S}"
+ DESTDIR="${ED}" cmake_build src/pybind/install
+
+ python_optimize
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+ tmpfiles_process ${PN}.conf
+ udev_reload
+}
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-boost-1.74.patch b/sys-cluster/ceph/files/ceph-17.2.0-boost-1.74.patch
new file mode 100644
index 000000000000..8fa7330520d8
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-boost-1.74.patch
@@ -0,0 +1,25 @@
+From 722b4303b1986ce93744af5baeecde7681d8e347 Mon Sep 17 00:00:00 2001
+From: Casey Bodley <cbodley@redhat.com>
+Date: Mon, 25 Jan 2021 13:08:35 -0500
+Subject: [PATCH] cmake: boost>=1.74 adds BOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT
+ to radosgw
+
+Fixes: https://tracker.ceph.com/issues/48988
+
+Signed-off-by: Casey Bodley <cbodley@redhat.com>
+---
+ src/rgw/CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/rgw/CMakeLists.txt b/src/rgw/CMakeLists.txt
+index 1b8cb81b8f2c1..12b42e4077f5a 100644
+--- a/src/rgw/CMakeLists.txt
++++ b/src/rgw/CMakeLists.txt
+@@ -1,3 +1,7 @@
++if(Boost_VERSION VERSION_GREATER_EQUAL 1.74)
++ add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++endif()
++
+ add_custom_target(civetweb_h
+ COMMAND ${CMAKE_COMMAND} -E make_directory
+ "${CMAKE_BINARY_DIR}/src/include/civetweb"
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
new file mode 100644
index 000000000000..f80edddd8de7
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-cyclic-deps.patch
@@ -0,0 +1,53 @@
+From 78edb6a91788133334ceeeda0c95529df5f40da8 Mon Sep 17 00:00:00 2001
+From: "Kaleb S. KEITHLEY" <kkeithle@redhat.com>
+Date: Mon, 14 Feb 2022 07:42:08 -0500
+Subject: [PATCH] rgw: cmake configure error on fedora-37/rawhide
+
+see
+https://kojipkgs.fedoraproject.org//work/tasks/6624/82706624/build.log,
+excerpted below
+
+...
+CMake Error: The inter-target dependency graph contains the following
+strongly connected component (cycle): "rgw_common" of type
+STATIC_LIBRARY depends on "dbstore" (weak) depends on "sqlite_db" (weak)
+"dbstore" of type SHARED_LIBRARY depends on "rgw_common" (weak) depends
+on "sqlite_db" (weak) "sqlite_db" of type SHARED_LIBRARY depends on
+"rgw_common" (weak) depends on "dbstore" (weak) At least one of these
+targets is not a STATIC_LIBRARY. Cyclic dependencies are allowed only
+among static libraries. CMake Generate step failed. Build files cannot
+be regenerated correctly.
+...
+
+https://tracker.ceph.com/issues/54266
+
+Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
+---
+ src/rgw/store/dbstore/CMakeLists.txt | 2 +-
+ src/rgw/store/dbstore/sqlite/CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
+index 143ede3c094c9..18e032b73f54f 100644
+--- a/src/rgw/store/dbstore/CMakeLists.txt
++++ b/src/rgw/store/dbstore/CMakeLists.txt
+@@ -47,7 +47,7 @@ else()
+ endif()
+
+ include_directories(${CMAKE_INCLUDE_DIR})
+-add_library(dbstore ${dbstore_mgr_srcs})
++add_library(dbstore STATIC ${dbstore_mgr_srcs})
+ target_link_libraries(dbstore ${CMAKE_LINK_LIBRARIES})
+
+ # testing purpose
+diff --git a/src/rgw/store/dbstore/sqlite/CMakeLists.txt b/src/rgw/store/dbstore/sqlite/CMakeLists.txt
+index cce59b9ec0aa9..909765e3058b6 100644
+--- a/src/rgw/store/dbstore/sqlite/CMakeLists.txt
++++ b/src/rgw/store/dbstore/sqlite/CMakeLists.txt
+@@ -12,5 +12,5 @@ include_directories(${CMAKE_INCLUDE_DIR})
+ set(SQLITE_COMPILE_FLAGS "-DSQLITE_THREADSAFE=1")
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SQLITE_COMPILE_FLAGS}")
+
+-add_library(sqlite_db ${sqlite_db_srcs})
++add_library(sqlite_db STATIC ${sqlite_db_srcs})
+ target_link_libraries(sqlite_db sqlite3 dbstore_lib rgw_common)
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch b/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch
new file mode 100644
index 000000000000..64b6d5c614c8
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-deprecated-boost.patch
@@ -0,0 +1,69 @@
+diff --git a/src/common/ConfUtils.cc b/src/common/ConfUtils.cc
+index ad791ece4f7..2f78fd02bf9 100644
+--- a/src/common/ConfUtils.cc
++++ b/src/common/ConfUtils.cc
+@@ -26,7 +26,7 @@
+ #include <boost/algorithm/string.hpp>
+ #include <boost/algorithm/string/trim_all.hpp>
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/spirit/include/support_line_pos_iterator.hpp>
+
+ #include "include/buffer.h"
+diff --git a/src/mds/MDSAuthCaps.cc b/src/mds/MDSAuthCaps.cc
+index b78ebd6615b..f8158be6866 100644
+--- a/src/mds/MDSAuthCaps.cc
++++ b/src/mds/MDSAuthCaps.cc
+@@ -17,8 +17,8 @@
+ #include <errno.h>
+
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix_operator.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix/operator.hpp>
++#include <boost/phoenix.hpp>
+
+ #include "common/debug.h"
+ #include "MDSAuthCaps.h"
+diff --git a/src/mgr/MgrCap.cc b/src/mgr/MgrCap.cc
+index cba758083c3..6e5e1f9bb99 100644
+--- a/src/mgr/MgrCap.cc
++++ b/src/mgr/MgrCap.cc
+@@ -16,7 +16,7 @@
+ #include <boost/spirit/include/qi_uint.hpp>
+ #include <boost/spirit/include/qi.hpp>
+ #include <boost/fusion/include/std_pair.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/fusion/adapted/struct/adapt_struct.hpp>
+ #include <boost/fusion/include/adapt_struct.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+diff --git a/src/mon/MonCap.cc b/src/mon/MonCap.cc
+index e1dc3723965..0ff9fefdd15 100644
+--- a/src/mon/MonCap.cc
++++ b/src/mon/MonCap.cc
+@@ -16,7 +16,7 @@
+ #include <boost/spirit/include/qi_uint.hpp>
+ #include <boost/spirit/include/qi.hpp>
+ #include <boost/fusion/include/std_pair.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/fusion/adapted/struct/adapt_struct.hpp>
+ #include <boost/fusion/include/adapt_struct.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+diff --git a/src/osd/OSDCap.cc b/src/osd/OSDCap.cc
+index e7bf0582799..f847e80e337 100644
+--- a/src/osd/OSDCap.cc
++++ b/src/osd/OSDCap.cc
+@@ -14,8 +14,8 @@
+
+ #include <boost/config/warning_disable.hpp>
+ #include <boost/spirit/include/qi.hpp>
+-#include <boost/spirit/include/phoenix_operator.hpp>
+-#include <boost/spirit/include/phoenix.hpp>
++#include <boost/phoenix/operator.hpp>
++#include <boost/phoenix.hpp>
+ #include <boost/algorithm/string/predicate.hpp>
+
+ #include "OSDCap.h"
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch b/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch
new file mode 100644
index 000000000000..e42f291e55bf
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-findre2.patch
@@ -0,0 +1,22 @@
+diff --git a/src/arrow/cpp/cmake_modules/Findre2.cmake b/src/arrow/cpp/cmake_modules/Findre2.cmake
+new file mode 100644
+index 00000000000..6f39de75461
+--- /dev/null
++++ b/src/arrow/cpp/cmake_modules/Findre2.cmake
+@@ -0,0 +1,16 @@
++FIND_PATH(SYSTEM_RE2_INCLUDE_DIR re2/re2.h)
++IF (SYSTEM_RE2_INCLUDE_DIR)
++ MESSAGE(STATUS "Found RE2 include dir")
++ FIND_LIBRARY(SYSTEM_RE2_LIBRARY re2)
++ IF (SYSTEM_RE2_LIBRARY)
++ MESSAGE(STATUS "Found RE2 library")
++ SET(RE2_INCLUDE_DIR ${SYSTEM_RE2_INCLUDE_DIR})
++ SET(RE2_LIBRARY ${SYSTEM_RE2_LIBRARY})
++ ELSE ()
++ MESSAGE(FATAL_ERROR "Found RE2 headers, but not the library")
++ ENDIF ()
++ELSE ()
++ MESSAGE(STATUS "Did not find system RE2")
++ENDIF ()
++
++
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
new file mode 100644
index 000000000000..e50030071c81
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-install-dbstore.patch
@@ -0,0 +1,12 @@
+diff --git a/src/rgw/store/dbstore/CMakeLists.txt b/src/rgw/store/dbstore/CMakeLists.txt
+index 143ede3c094..204ef653010 100644
+--- a/src/rgw/store/dbstore/CMakeLists.txt
++++ b/src/rgw/store/dbstore/CMakeLists.txt
+@@ -24,6 +24,7 @@ if(WITH_JAEGER)
+ list(APPEND link_targets ${jaeger_base})
+ endif()
+ target_link_libraries(dbstore_lib PUBLIC ${link_targets})
++install(TARGETS dbstore_lib DESTINATION ${CMAKE_INSTALL_LIBDIR})
+
+ set (CMAKE_LINK_LIBRARIES ${CMAKE_LINK_LIBRARIES} dbstore_lib)
+
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch b/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch
new file mode 100644
index 000000000000..930dd08e8630
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-no-virtualenvs.patch
@@ -0,0 +1,68 @@
+diff --git a/cmake/modules/AddCephTest.cmake b/cmake/modules/AddCephTest.cmake
+index 0df7125b508..01afc88289c 100644
+--- a/cmake/modules/AddCephTest.cmake
++++ b/cmake/modules/AddCephTest.cmake
+@@ -57,7 +57,6 @@ endfunction()
+
+ function(add_tox_test name)
+ set(test_name run-tox-${name})
+- set(venv_path ${CEPH_BUILD_VIRTUALENV}/${name}-virtualenv)
+ cmake_parse_arguments(TOXTEST "" "TOX_PATH" "TOX_ENVS" ${ARGN})
+ if(DEFINED TOXTEST_TOX_PATH)
+ set(tox_path ${TOXTEST_TOX_PATH})
+@@ -71,27 +70,13 @@ function(add_tox_test name)
+ endif()
+ string(REPLACE ";" "," tox_envs "${tox_envs}")
+ find_package(Python3 QUIET REQUIRED)
+- add_test(
+- NAME setup-venv-for-${name}
+- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${venv_path}
+- WORKING_DIRECTORY ${tox_path})
+- set_tests_properties(setup-venv-for-${name} PROPERTIES
+- FIXTURES_SETUP venv-for-${name})
+- add_test(
+- NAME teardown-venv-for-${name}
+- COMMAND ${CMAKE_COMMAND} -E remove_directory ${venv_path})
+- set_tests_properties(teardown-venv-for-${name} PROPERTIES
+- FIXTURES_CLEANUP venv-for-${name})
+ add_test(
+ NAME ${test_name}
+ COMMAND ${CMAKE_SOURCE_DIR}/src/script/run_tox.sh
+ --source-dir ${CMAKE_SOURCE_DIR}
+ --build-dir ${CMAKE_BINARY_DIR}
+ --tox-path ${tox_path}
+- --tox-envs ${tox_envs}
+- --venv-path ${venv_path})
+- set_tests_properties(${test_name} PROPERTIES
+- FIXTURES_REQUIRED venv-for-${name})
++ --tox-envs ${tox_envs})
+ set_property(
+ TEST ${test_name}
+ PROPERTY ENVIRONMENT
+diff --git a/src/ceph-volume/CMakeLists.txt b/src/ceph-volume/CMakeLists.txt
+index 9166553dc73..9a6c87595b9 100644
+--- a/src/ceph-volume/CMakeLists.txt
++++ b/src/ceph-volume/CMakeLists.txt
+@@ -8,22 +8,6 @@ if(FREEBSD)
+ add_subdirectory(plugin/zfs)
+ endif()
+
+-# Required for running ceph-volume inventory in a vstart environment
+-set(CEPH_VOLUME_VIRTUALENV ${CEPH_BUILD_VIRTUALENV}/ceph-volume-virtualenv)
+-
+-add_custom_command(
+- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/python
+- COMMAND ${CMAKE_SOURCE_DIR}/src/tools/setup-virtualenv.sh --python=${Python3_EXECUTABLE} ${CEPH_VOLUME_VIRTUALENV}
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+- COMMENT "ceph-volume venv is being created")
+-
+-add_custom_command(
+- OUTPUT ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume
+- DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/python
+- COMMAND . ${CEPH_VOLUME_VIRTUALENV}/bin/activate && ${CEPH_VOLUME_VIRTUALENV}/bin/python setup.py develop && deactivate
+- WORKING_DIRECTORY ${CMAKE_SOURCE_DIR}/src/ceph-volume
+- COMMENT "${CMAKE_SOURCE_DIR}/src/ceph-volume")
+-
+ add_custom_target(ceph-volume-venv-setup
+ DEPENDS ${CEPH_VOLUME_VIRTUALENV}/bin/ceph-volume)
+
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
new file mode 100644
index 000000000000..8591b0bc7f89
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-pybind-boost-1.74.patch
@@ -0,0 +1,26 @@
+diff --git a/src/pybind/CMakeLists.txt b/src/pybind/CMakeLists.txt
+index cd9b27623d2..12688ad32b9 100644
+--- a/src/pybind/CMakeLists.txt
++++ b/src/pybind/CMakeLists.txt
+@@ -36,6 +36,10 @@ execute_process(
+ OUTPUT_VARIABLE "PYTHON3_INSTDIR"
+ OUTPUT_STRIP_TRAILING_WHITESPACE)
+
++if(Boost_VERSION VERSION_GREATER_EQUAL 1.74)
++ add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++endif()
++
+ install(FILES
+ ceph_argparse.py
+ ceph_daemon.py
+diff --git a/src/test/librados/CMakeLists.txt b/src/test/librados/CMakeLists.txt
+index fc033766cc4..0ba3bc56e98 100644
+--- a/src/test/librados/CMakeLists.txt
++++ b/src/test/librados/CMakeLists.txt
+@@ -1,3 +1,6 @@
++
++add_definitions(-DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
++
+ # radostest
+ add_library(radostest_shared OBJECT test_shared.cc)
+ target_include_directories(radostest_shared PRIVATE
diff --git a/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch b/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch
new file mode 100644
index 000000000000..6e0788a093e5
--- /dev/null
+++ b/sys-cluster/ceph/files/ceph-17.2.0-system-opentelemetry.patch
@@ -0,0 +1,20 @@
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 30cf3605468..902e2123d04 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -430,9 +430,12 @@ add_dependencies(common-objs legacy-option-headers)
+
+ if(WITH_JAEGER)
+ find_package(thrift 0.13.0 REQUIRED)
+- include(BuildOpentelemetry)
+- build_opentelemetry()
+- set(jaeger_base opentelemetry::libopentelemetry thrift::libthrift)
++ find_package(opentelemetry-cpp 1.3.0 REQUIRED)
++ set(jaeger_base
++ opentelemetry-cpp::common
++ opentelemetry-cpp::trace
++ opentelemetry-cpp::jaeger_trace_exporter
++ thrift::libthrift)
+ add_dependencies(common-objs ${jaeger_base})
+ target_link_libraries(common-objs ${jaeger_base})
+ endif()
diff --git a/sys-cluster/ceph/metadata.xml b/sys-cluster/ceph/metadata.xml
index 3bafabc339fd..b9a4aabfe140 100644
--- a/sys-cluster/ceph/metadata.xml
+++ b/sys-cluster/ceph/metadata.xml
@@ -25,11 +25,13 @@
<flag name="lttng">Add support for LTTng</flag>
<flag name="mgr">Build the ceph-mgr daemon</flag>
<flag name="numa">Use <pkg>sys-process/numactl</pkg> for numa support in rocksdb</flag>
+ <flag name="parquet">Support for s3 select on parquet objects</flag>
<flag name="pmdk">Enable PMDK libraries</flag>
<flag name="rabbitmq">Use rabbitmq-c to build rgw amqp push endpoint</flag>
<flag name="radosgw">Add radosgw support</flag>
<flag name="rbd-rwl">Enable librbd persistent write back cache</flag>
<flag name="rbd-ssd">Enable librbd persistent write back cache for SSDs</flag>
+ <flag name="rdma">Enable RDMA support via <pkg>sys-cluster/rdma-core</pkg></flag>
<flag name="rgw-lua">Rados Gateway's support for dynamically adding lua packagess</flag>
<flag name="system-boost">Use system <pkg>dev-libs/boost</pkg> instead of the bundled one</flag>
<flag name="uring">Build with support for <pkg>sys-libs/liburing</pkg></flag>
@@ -37,4 +39,7 @@
<flag name="xfs">Add xfs support</flag>
<flag name="zfs">Add zfs support</flag>
</use>
+ <upstream>
+ <bugs-to>https://tracker.ceph.com/issues</bugs-to>
+ </upstream>
</pkgmetadata>