summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-11-11 11:35:00 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-12 20:28:23 +0100
commitb14315d85f599afd00c1343732dcb175fe4a9ffc (patch)
tree6dabb5cf3f5111ee276a87653e841bb49acbfe2e /sys-cluster/rdma-core
parentapp-portage/pycargoebuild: new Cargo .ebuild generator, v0.1.0 (diff)
downloadgentoo-b14315d85f599afd00c1343732dcb175fe4a9ffc.tar.gz
gentoo-b14315d85f599afd00c1343732dcb175fe4a9ffc.tar.bz2
gentoo-b14315d85f599afd00c1343732dcb175fe4a9ffc.zip
sys-cluster/rdma-core: set perldir
Closes: https://bugs.gentoo.org/876757 Closes: https://github.com/gentoo/gentoo/pull/28222 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-cluster/rdma-core')
-rw-r--r--sys-cluster/rdma-core/rdma-core-42.0-r1.ebuild (renamed from sys-cluster/rdma-core/rdma-core-42.0.ebuild)4
1 files changed, 3 insertions, 1 deletions
diff --git a/sys-cluster/rdma-core/rdma-core-42.0.ebuild b/sys-cluster/rdma-core/rdma-core-42.0-r1.ebuild
index 0fa2ec46e46b..b67855bafe1f 100644
--- a/sys-cluster/rdma-core/rdma-core-42.0.ebuild
+++ b/sys-cluster/rdma-core/rdma-core-42.0-r1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{8..11} )
-inherit cmake python-single-r1 udev systemd
+inherit cmake perl-functions python-single-r1 udev systemd
DESCRIPTION="Userspace components for the Linux Kernel's drivers/infiniband subsystem"
HOMEPAGE="https://github.com/linux-rdma/rdma-core"
@@ -60,10 +60,12 @@ BDEPEND="
PATCHES=( "${FILESDIR}"/${PN}-39.0-RDMA_BuildType.patch )
src_configure() {
+ perl_set_version
local mycmakeargs=(
-DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}"/etc
-DCMAKE_INSTALL_RUNDIR=/run
-DCMAKE_INSTALL_SHAREDSTATEDIR="${EPREFIX}"/var/lib
+ -DCMAKE_INSTALL_PERLDIR="${VENDOR_LIB}"
-DCMAKE_INSTALL_UDEV_RULESDIR="${EPREFIX}$(get_udevdir)"/rules.d
-DCMAKE_INSTALL_SYSTEMD_SERVICEDIR="$(systemd_get_systemunitdir)"
-DCMAKE_DISABLE_FIND_PACKAGE_Systemd="$(usex !systemd)"