summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-29 23:39:10 +0100
committerSam James <sam@gentoo.org>2021-10-29 23:43:39 +0100
commitac398431d5c1ef8d5e237d2cd47c1b4a867c526a (patch)
tree9551983c426d8962a9b5f13b63710657d064fa8b /sys-cluster/legion
parentsys-cluster/mpich2: add hwloc subslot operator (diff)
downloadgentoo-ac398431d5c1ef8d5e237d2cd47c1b4a867c526a.tar.gz
gentoo-ac398431d5c1ef8d5e237d2cd47c1b4a867c526a.tar.bz2
gentoo-ac398431d5c1ef8d5e237d2cd47c1b4a867c526a.zip
sys-cluster/legion: add hwloc subslot operator
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-cluster/legion')
-rw-r--r--sys-cluster/legion/legion-16.08.0-r2.ebuild (renamed from sys-cluster/legion/legion-16.08.0-r1.ebuild)5
-rw-r--r--sys-cluster/legion/legion-16.10.0-r1.ebuild (renamed from sys-cluster/legion/legion-16.10.0.ebuild)5
-rw-r--r--sys-cluster/legion/legion-17.02.0-r1.ebuild (renamed from sys-cluster/legion/legion-17.02.0.ebuild)5
-rw-r--r--sys-cluster/legion/legion-17.05.0-r1.ebuild (renamed from sys-cluster/legion/legion-17.05.0.ebuild)3
-rw-r--r--sys-cluster/legion/legion-17.08.0-r1.ebuild (renamed from sys-cluster/legion/legion-17.08.0.ebuild)3
-rw-r--r--sys-cluster/legion/legion-17.10.0-r1.ebuild (renamed from sys-cluster/legion/legion-17.10.0.ebuild)3
-rw-r--r--sys-cluster/legion/legion-18.02.0-r1.ebuild (renamed from sys-cluster/legion/legion-18.02.0.ebuild)3
-rw-r--r--sys-cluster/legion/legion-18.05.0-r1.ebuild (renamed from sys-cluster/legion/legion-18.05.0.ebuild)3
-rw-r--r--sys-cluster/legion/legion-18.12.0-r1.ebuild41
-rw-r--r--sys-cluster/legion/legion-18.12.0.ebuild40
-rw-r--r--sys-cluster/legion/legion-19.06.0-r1.ebuild41
-rw-r--r--sys-cluster/legion/legion-19.06.0.ebuild40
-rw-r--r--sys-cluster/legion/legion-9999.ebuild3
13 files changed, 103 insertions, 92 deletions
diff --git a/sys-cluster/legion/legion-16.08.0-r1.ebuild b/sys-cluster/legion/legion-16.08.0-r2.ebuild
index c785d40df28f..7295a5f41e45 100644
--- a/sys-cluster/legion/legion-16.08.0-r1.ebuild
+++ b/sys-cluster/legion/legion-16.08.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,8 +16,9 @@ IUSE="gasnet +hwloc"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${P}"
diff --git a/sys-cluster/legion/legion-16.10.0.ebuild b/sys-cluster/legion/legion-16.10.0-r1.ebuild
index 6ed64ffe46d3..50372479f2c9 100644
--- a/sys-cluster/legion/legion-16.10.0.ebuild
+++ b/sys-cluster/legion/legion-16.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,8 +16,9 @@ IUSE="gasnet +hwloc"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${P}"
diff --git a/sys-cluster/legion/legion-17.02.0.ebuild b/sys-cluster/legion/legion-17.02.0-r1.ebuild
index 415747a8aa60..4ab8ed801e4e 100644
--- a/sys-cluster/legion/legion-17.02.0.ebuild
+++ b/sys-cluster/legion/legion-17.02.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,8 +16,9 @@ IUSE="gasnet +hwloc"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}-${P}"
diff --git a/sys-cluster/legion/legion-17.05.0.ebuild b/sys-cluster/legion/legion-17.05.0-r1.ebuild
index d54f220af2c9..0746074ce71d 100644
--- a/sys-cluster/legion/legion-17.05.0.ebuild
+++ b/sys-cluster/legion/legion-17.05.0-r1.ebuild
@@ -22,8 +22,9 @@ IUSE="gasnet +hwloc"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
diff --git a/sys-cluster/legion/legion-17.08.0.ebuild b/sys-cluster/legion/legion-17.08.0-r1.ebuild
index b2a4fc2de9c9..c883f98f82d2 100644
--- a/sys-cluster/legion/legion-17.08.0.ebuild
+++ b/sys-cluster/legion/legion-17.08.0-r1.ebuild
@@ -23,8 +23,9 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
diff --git a/sys-cluster/legion/legion-17.10.0.ebuild b/sys-cluster/legion/legion-17.10.0-r1.ebuild
index b2a4fc2de9c9..c883f98f82d2 100644
--- a/sys-cluster/legion/legion-17.10.0.ebuild
+++ b/sys-cluster/legion/legion-17.10.0-r1.ebuild
@@ -23,8 +23,9 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
diff --git a/sys-cluster/legion/legion-18.02.0.ebuild b/sys-cluster/legion/legion-18.02.0-r1.ebuild
index b2a4fc2de9c9..c883f98f82d2 100644
--- a/sys-cluster/legion/legion-18.02.0.ebuild
+++ b/sys-cluster/legion/legion-18.02.0-r1.ebuild
@@ -23,8 +23,9 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( sys-apps/hwloc )
+ hwloc? ( sys-apps/hwloc:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
diff --git a/sys-cluster/legion/legion-18.05.0.ebuild b/sys-cluster/legion/legion-18.05.0-r1.ebuild
index c9eb5be36ea1..bc5ad7cee85d 100644
--- a/sys-cluster/legion/legion-18.05.0.ebuild
+++ b/sys-cluster/legion/legion-18.05.0-r1.ebuild
@@ -23,8 +23,9 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2 )
+ hwloc? ( <sys-apps/hwloc-2:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(
diff --git a/sys-cluster/legion/legion-18.12.0-r1.ebuild b/sys-cluster/legion/legion-18.12.0-r1.ebuild
new file mode 100644
index 000000000000..bc5ad7cee85d
--- /dev/null
+++ b/sys-cluster/legion/legion-18.12.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="https://legion.stanford.edu/"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2:= )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/legion/legion-18.12.0.ebuild b/sys-cluster/legion/legion-18.12.0.ebuild
deleted file mode 100644
index c9eb5be36ea1..000000000000
--- a/sys-cluster/legion/legion-18.12.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A data-centric parallel programming system"
-HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
-else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="gasnet +hwloc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2 )
- "
-
-src_configure() {
- mycmakeargs=(
- -DLegion_USE_HWLOC=$(usex hwloc)
- -DLegion_USE_GASNet=$(usex gasnet)
- -DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
- -DLegion_BUILD_TESTS=ON
- -DLegion_BUILD_TUTORIAL=ON
- )
- cmake-utils_src_configure
-}
diff --git a/sys-cluster/legion/legion-19.06.0-r1.ebuild b/sys-cluster/legion/legion-19.06.0-r1.ebuild
new file mode 100644
index 000000000000..bc5ad7cee85d
--- /dev/null
+++ b/sys-cluster/legion/legion-19.06.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A data-centric parallel programming system"
+HOMEPAGE="https://legion.stanford.edu/"
+if [[ ${PV} = 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
+else
+ SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-${P}"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="gasnet +hwloc test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
+ hwloc? ( <sys-apps/hwloc-2:= )
+ "
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ -DLegion_USE_HWLOC=$(usex hwloc)
+ -DLegion_USE_GASNet=$(usex gasnet)
+ -DLegion_ENABLE_TESTING=$(usex test)
+ -DBUILD_SHARED_LIBS=ON
+ -DLegion_BUILD_EXAMPLES=ON
+ -DLegion_BUILD_TESTS=ON
+ -DLegion_BUILD_TUTORIAL=ON
+ )
+ cmake-utils_src_configure
+}
diff --git a/sys-cluster/legion/legion-19.06.0.ebuild b/sys-cluster/legion/legion-19.06.0.ebuild
deleted file mode 100644
index c9eb5be36ea1..000000000000
--- a/sys-cluster/legion/legion-19.06.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit cmake-utils
-
-DESCRIPTION="A data-centric parallel programming system"
-HOMEPAGE="https://legion.stanford.edu/"
-if [[ ${PV} = 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://StanfordLegion/${PN}.git https://github.com/StanfordLegion/${PN}.git"
-else
- SRC_URI="https://github.com/StanfordLegion/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/${PN}-${P}"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-IUSE="gasnet +hwloc test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2 )
- "
-
-src_configure() {
- mycmakeargs=(
- -DLegion_USE_HWLOC=$(usex hwloc)
- -DLegion_USE_GASNet=$(usex gasnet)
- -DLegion_ENABLE_TESTING=$(usex test)
- -DBUILD_SHARED_LIBS=ON
- -DLegion_BUILD_EXAMPLES=ON
- -DLegion_BUILD_TESTS=ON
- -DLegion_BUILD_TUTORIAL=ON
- )
- cmake-utils_src_configure
-}
diff --git a/sys-cluster/legion/legion-9999.ebuild b/sys-cluster/legion/legion-9999.ebuild
index c9eb5be36ea1..bc5ad7cee85d 100644
--- a/sys-cluster/legion/legion-9999.ebuild
+++ b/sys-cluster/legion/legion-9999.ebuild
@@ -23,8 +23,9 @@ RESTRICT="!test? ( test )"
DEPEND="
gasnet? ( >=sys-cluster/gasnet-1.26.4-r1 )
- hwloc? ( <sys-apps/hwloc-2 )
+ hwloc? ( <sys-apps/hwloc-2:= )
"
+RDEPEND="${DEPEND}"
src_configure() {
mycmakeargs=(