summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-02 01:57:34 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-02 20:04:42 +0100
commit87dba25ff56f7f54573d2a1f52d5241b7f4f1247 (patch)
tree1e014836043c009e2ddcfc7f8b877adb9b1a98e9 /sys-cluster/hpx
parentnet-vpn/wireguard-tools: bump to 1.0.20200102 (diff)
downloadgentoo-87dba25ff56f7f54573d2a1f52d5241b7f4f1247.tar.gz
gentoo-87dba25ff56f7f54573d2a1f52d5241b7f4f1247.tar.bz2
gentoo-87dba25ff56f7f54573d2a1f52d5241b7f4f1247.zip
*/*: Switch m-n packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-cluster/hpx')
-rw-r--r--sys-cluster/hpx/hpx-1.2.1.ebuild8
-rw-r--r--sys-cluster/hpx/hpx-9999.ebuild8
2 files changed, 8 insertions, 8 deletions
diff --git a/sys-cluster/hpx/hpx-1.2.1.ebuild b/sys-cluster/hpx/hpx-1.2.1.ebuild
index 64c2d82ce771..92be9c4426d8 100644
--- a/sys-cluster/hpx/hpx-1.2.1.ebuild
+++ b/sys-cluster/hpx/hpx-1.2.1.ebuild
@@ -13,7 +13,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -64,16 +64,16 @@ src_configure() {
mycmakeargs+=( -DHPX_WITH_MALLOC=system )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# avoid over-suscribing
- cmake-utils_src_make -j1 tests
+ cmake_build -j1 tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}
diff --git a/sys-cluster/hpx/hpx-9999.ebuild b/sys-cluster/hpx/hpx-9999.ebuild
index 64c2d82ce771..92be9c4426d8 100644
--- a/sys-cluster/hpx/hpx-9999.ebuild
+++ b/sys-cluster/hpx/hpx-9999.ebuild
@@ -13,7 +13,7 @@ else
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
S="${WORKDIR}/${PN}_${PV}"
fi
-inherit cmake-utils fortran-2 python-any-r1
+inherit cmake fortran-2 python-any-r1
DESCRIPTION="C++ runtime system for parallel and distributed applications"
HOMEPAGE="https://stellar.cct.lsu.edu/tag/hpx/"
@@ -64,16 +64,16 @@ src_configure() {
mycmakeargs+=( -DHPX_WITH_MALLOC=system )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_test() {
# avoid over-suscribing
- cmake-utils_src_make -j1 tests
+ cmake_build -j1 tests
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
mv "${D}/usr/bin/spin" "${D}/usr/bin/hpx_spin" || die
insinto /usr/share/doc/${PF}