summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-08-16 20:39:22 +0200
committerUlrich Müller <ulm@gentoo.org>2023-08-17 10:13:09 +0200
commit6880f4bcceda4e799eb25190f25cd6ef28550d4d (patch)
treee190818d90b5b74445292af8e3f9ca0e3876c222 /sys-apps
parentdev-util/cookiecutter: add 2.3.0 (diff)
downloadgentoo-6880f4bcceda4e799eb25190f25cd6ef28550d4d.tar.gz
gentoo-6880f4bcceda4e799eb25190f25cd6ef28550d4d.tar.bz2
gentoo-6880f4bcceda4e799eb25190f25cd6ef28550d4d.zip
sys-apps/heirloom-tools: Don't create subdirs in /usr/bin
The FHS says that /usr/bin has no subdirectories: https://refspecs.linuxfoundation.org/FHS_3.0/fhs/ch04s04.html#requirements9a Therefore, install the binaries in /usr/lib instead. EAPI 8. Inherit and use readme.gentoo-r1.eclass. Update HOMEPAGE and SRC_URI. Specify LICENSE more precisely ("or later" for GPL and LGPL). Other minor QA fixes. Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/heirloom-tools/heirloom-tools-070715-r4.ebuild94
-rw-r--r--sys-apps/heirloom-tools/heirloom-tools-070715-r5.ebuild98
2 files changed, 98 insertions, 94 deletions
diff --git a/sys-apps/heirloom-tools/heirloom-tools-070715-r4.ebuild b/sys-apps/heirloom-tools/heirloom-tools-070715-r4.ebuild
deleted file mode 100644
index c91cfdb53b42..000000000000
--- a/sys-apps/heirloom-tools/heirloom-tools-070715-r4.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Heirloom toolchest - original Unix tools"
-HOMEPAGE="http://heirloom.sourceforge.net/tools.html"
-SRC_URI="http://downloads.sourceforge.net/project/heirloom/heirloom/${PV}/heirloom-${PV}.tar.bz2"
-
-LICENSE="CDDL GPL-2 LGPL-2.1 9base ZLIB"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- sys-libs/ncurses:=
- sys-libs/zlib
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- sys-apps/ed
- sys-devel/bc
- virtual/pkgconfig
-"
-
-S="${WORKDIR}/heirloom-${PV}"
-
-PATCHES=(
- "${FILESDIR}"/${P}-major.patch
- "${FILESDIR}"/${P}-makefile.patch
- "${FILESDIR}"/${P}-glibc-2.30.patch
- "${FILESDIR}"/${P}-glibc-2.31.patch
- "${FILESDIR}"/${P}-gcc-10.patch
- "${FILESDIR}"/${P}-clang.patch
-)
-
-# slightly broken
-RESTRICT="test"
-
-src_prepare() {
- default
-
- sed -i "s/\bar\b/$(tc-getAR)/g" libwchar/Makefile.mk || die
-}
-
-src_compile() {
- append-cppflags -D_GNU_SOURCE
- emake -j1 \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- CFLAGS="${CFLAGS}" \
- CFLAGS2="${CFLAGS}" \
- CFLAGSS="${CFLAGS}" \
- CFLAGSU="${CFLAGS}" \
- CPPFLAGS="${CPPFLAGS}" \
- LCURS="$( $(tc-getPKG_CONFIG) --libs ncurses)" \
- LDFLAGS="${LDFLAGS}" \
- DEFBIN="/usr/bin/${PN}/5bin" \
- DEFSBIN="/usr/bin/${PN}/5bin" \
- SV3BIN="/usr/bin/${PN}/5bin" \
- S42BIN="/usr/bin/${PN}/5bin/s42" \
- SUSBIN="/usr/bin/${PN}/5bin/posix" \
- UCBBIN="/usr/bin/${PN}/ucb" \
- CCSBIN="/usr/bin/${PN}/ccs/bin" \
- SU3BIN="/usr/bin/${PN}/5bin/posix2001" \
- DEFLIB="/usr/bin/${PN}/5lib" \
- LIBZ=-lz
-}
-
-src_install() {
- # we don't want to strip here, so use "true" as noop
- emake -j1 \
- STRIP="true" \
- ROOT="${ED}" \
- DEFBIN="/usr/bin/${PN}/5bin" \
- DEFSBIN="/usr/bin/${PN}/5bin" \
- SV3BIN="/usr/bin/${PN}/5bin" \
- S42BIN="/usr/bin/${PN}/5bin/s42" \
- SUSBIN="/usr/bin/${PN}/5bin/posix" \
- UCBBIN="/usr/bin/${PN}/ucb" \
- CCSBIN="/usr/bin/${PN}/ccs/bin" \
- SU3BIN="/usr/bin/${PN}/5bin/posix2001" \
- DEFLIB="/usr/bin/${PN}/5lib" \
- install
-}
-
-pkg_postinst() {
- elog "You may want to adjust your \$PATH, to enable "
- elog "using the apps of heirloom toolchest by default."
- elog "Man pages are installed in /usr/share/man/5man/"
- elog "You may need to set \$MANPATH to access them."
-}
diff --git a/sys-apps/heirloom-tools/heirloom-tools-070715-r5.ebuild b/sys-apps/heirloom-tools/heirloom-tools-070715-r5.ebuild
new file mode 100644
index 000000000000..62c7605beca7
--- /dev/null
+++ b/sys-apps/heirloom-tools/heirloom-tools-070715-r5.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic readme.gentoo-r1 toolchain-funcs
+
+DESCRIPTION="Heirloom toolchest - original Unix tools"
+HOMEPAGE="https://heirloom.sourceforge.net/tools.html"
+SRC_URI="mirror://sourceforge/heirloom/heirloom/${PV}/heirloom-${PV}.tar.bz2"
+S="${WORKDIR}/heirloom-${PV}"
+
+LICENSE="CDDL GPL-2+ LGPL-2.1+ 9base ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# slightly broken
+RESTRICT="test"
+
+RDEPEND="
+ sys-libs/ncurses:=
+ sys-libs/zlib
+ virtual/libcrypt:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-apps/ed
+ sys-devel/bc
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-major.patch
+ "${FILESDIR}"/${P}-makefile.patch
+ "${FILESDIR}"/${P}-glibc-2.30.patch
+ "${FILESDIR}"/${P}-glibc-2.31.patch
+ "${FILESDIR}"/${P}-gcc-10.patch
+ "${FILESDIR}"/${P}-clang.patch
+)
+
+src_prepare() {
+ default
+ sed -i "s:\bar\b:$(tc-getAR):g" libwchar/Makefile.mk || die
+}
+
+src_compile() {
+ mypaths=(
+ DEFBIN="${EPREFIX}/usr/lib/${PN}/5bin"
+ SV3BIN="${EPREFIX}/usr/lib/${PN}/5bin"
+ S42BIN="${EPREFIX}/usr/lib/${PN}/5bin/s42"
+ SUSBIN="${EPREFIX}/usr/lib/${PN}/5bin/posix"
+ SU3BIN="${EPREFIX}/usr/lib/${PN}/5bin/posix2001"
+ UCBBIN="${EPREFIX}/usr/lib/${PN}/ucb"
+ CCSBIN="${EPREFIX}/usr/lib/${PN}/ccs/bin"
+ DEFLIB="${EPREFIX}/usr/lib/${PN}/5lib"
+ DEFSBIN="${EPREFIX}/usr/lib/${PN}/5bin"
+ MANDIR="${EPREFIX}/usr/share/man/5man"
+ DFLDIR="${EPREFIX}/etc/default"
+ SPELLHIST="/dev/null"
+ SULOG="${EPREFIX}/var/log/sulog"
+ )
+
+ append-cppflags -D_GNU_SOURCE
+ emake -j1 \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)" \
+ RANLIB="$(tc-getRANLIB)" \
+ CFLAGS="${CFLAGS}" \
+ CFLAGS2="${CFLAGS}" \
+ CFLAGSS="${CFLAGS}" \
+ CFLAGSU="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LCURS="$($(tc-getPKG_CONFIG) --libs ncurses)" \
+ LDFLAGS="${LDFLAGS}" \
+ LIBZ="-lz" \
+ "${mypaths[@]}"
+}
+
+src_install() {
+ # we don't want to strip here, so use "true" as noop
+ emake -j1 \
+ STRIP="true" \
+ ROOT="${D}" \
+ "${mypaths[@]}" \
+ install
+ rm -r "${D}/dev" || die
+
+ dodoc CHANGES README
+
+ local DOC_CONTENTS="You may want to adjust your PATH, to enable
+ using the apps of ${PN} by default.
+ \\n\\nMan pages are installed in /usr/share/man/5man/.
+ You may need to set MANPATH to access them."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}