summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-08-17 19:41:35 +0200
committerUlrich Müller <ulm@gentoo.org>2023-08-17 21:25:28 +0200
commit53aae885d64f2284895359d9366641656d82b49e (patch)
tree063465513d1fbe1882ff83dbe4c18c71eeb229fe /sys-apps
parentapp-portage/getuto: new package, add 1.0 (diff)
downloadgentoo-53aae885d64f2284895359d9366641656d82b49e.tar.gz
gentoo-53aae885d64f2284895359d9366641656d82b49e.tar.bz2
gentoo-53aae885d64f2284895359d9366641656d82b49e.zip
sys-apps/sysvinit: Add postinst message about halt bugfix
Bug: https://bugs.gentoo.org/911257#c7 Signed-off-by: Ulrich Müller <ulm@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/sysvinit/sysvinit-3.07-r2.ebuild (renamed from sys-apps/sysvinit/sysvinit-3.07-r1.ebuild)9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys-apps/sysvinit/sysvinit-3.07-r1.ebuild b/sys-apps/sysvinit/sysvinit-3.07-r2.ebuild
index 349a3b1db05e..71e4fdb7f074 100644
--- a/sys-apps/sysvinit/sysvinit-3.07-r1.ebuild
+++ b/sys-apps/sysvinit/sysvinit-3.07-r2.ebuild
@@ -187,4 +187,13 @@ pkg_postinst() {
if [[ ! -e "${EROOT}/var/log/boot" ]] ; then
touch "${EROOT}/var/log/boot"
fi
+
+ local ver
+ for ver in ${REPLACING_VERSIONS}; do
+ ver_test ${ver} -ge 3.07-r2 && continue
+ ewarn "Previously, the 'halt' command caused the system to power off"
+ ewarn "even if option -p was not given. This long-standing bug has"
+ ewarn "been fixed, and the command now behaves as documented."
+ break
+ done
}