summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 04:45:56 +0100
committerSam James <sam@gentoo.org>2022-04-07 04:57:16 +0100
commit0e5cbc3642670e7741a551eb4775fcdc8694cd10 (patch)
tree93b031c156ca46e964868c5e339695d323448500 /sys-apps
parentsec-keys/openpgp-keys-coreutils: new package, add 20220407 (diff)
downloadgentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.tar.gz
gentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.tar.bz2
gentoo-0e5cbc3642670e7741a551eb4775fcdc8694cd10.zip
sys-apps/coreutils: add verify-sig
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/coreutils/Manifest1
-rw-r--r--sys-apps/coreutils/coreutils-9.0-r2.ebuild17
2 files changed, 15 insertions, 3 deletions
diff --git a/sys-apps/coreutils/Manifest b/sys-apps/coreutils/Manifest
index b820e36cb8ba..e13c336609db 100644
--- a/sys-apps/coreutils/Manifest
+++ b/sys-apps/coreutils/Manifest
@@ -1,3 +1,4 @@
DIST coreutils-8.30-patches-01.tar.xz 5788 BLAKE2B a41511ce39ac570cb14b7f12d125eebef92217469a9490808719fa0665f5e5c0adb96fbd02c4bac4d280d1502295669575790a81dbc01afe2ca3a9d384cbefb0 SHA512 b1e1933637de4581d5f8c6ede4e80a012435d13f0cf5550a76ab5bbe9441e3c15ce19ef3f78a7ea3b8368d5e9a3bb17c1207c471d26171b59786f38adeba0454
DIST coreutils-8.32.tar.xz 5547836 BLAKE2B 0ad99c176c19ec214fcfd0845523e5362f0151827707c759bd46c0fe8d2501c6ad1c29c5b71266f6525857bc0d56c472db0d7fe29953b6c65e2e6c76bdf3c515 SHA512 1c8f3584efd61b4b02e7ac5db8e103b63cfb2063432caaf1e64cb2dcc56d8c657d1133bbf10bd41468d6a1f31142e6caa81d16ae68fa3e6e84075c253613a145
DIST coreutils-9.0.tar.xz 5612752 BLAKE2B 59617cd25fd4c70f51bfbef851bd83e73f9c9ba5c11eb539f7f75c0184d55832e004b28e9268fb8064db145cb071ead2b9c0c3346bc35a11934ffe1b15bf17ac SHA512 9be08212891dbf48e5b22e7689dc27dac50df4631ebf29313470b72b7921f0b2aa5242917d05587785358495ca56e3b21f5b3ca81043d53cab92354da6c53a03
+DIST coreutils-9.0.tar.xz.sig 833 BLAKE2B 1393f60361524e0a6eab5631aada50ee4124bd0e9ff3020b7593914a888f0edaec78339caee28847e85e1a1af6ea519ab9fad208db605f0c6b8a4e7ab19853a8 SHA512 1a368c92ddb57f386c188ef72f1edad7e217c983c296f9be0d27ffbaa673bf2f004c321fbaff8ae6cdebf6ffef402e3e8c69e6c8e30aca988e0ea38f2296cf30
diff --git a/sys-apps/coreutils/coreutils-9.0-r2.ebuild b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
index c8d7eca8e649..e55e9bf82f73 100644
--- a/sys-apps/coreutils/coreutils-9.0-r2.ebuild
+++ b/sys-apps/coreutils/coreutils-9.0-r2.ebuild
@@ -4,8 +4,8 @@
EAPI=7
PYTHON_COMPAT=( python3_{8..10} )
-
-inherit flag-o-matic python-any-r1 toolchain-funcs
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/coreutils.asc
+inherit flag-o-matic python-any-r1 toolchain-funcs verify-sig
PATCH="${PN}-8.30-patches-01"
DESCRIPTION="Standard GNU utilities (chmod, cp, dd, ls, sort, tr, head, wc, who,...)"
@@ -14,7 +14,8 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
!vanilla? (
mirror://gentoo/${PATCH}.tar.xz
https://dev.gentoo.org/~polynomial-c/dist/${PATCH}.tar.xz
- )"
+ )
+ verify-sig? ( mirror://gnu/${PN}/${P}.tar.xz.sig )"
LICENSE="GPL-3"
SLOT="0"
@@ -42,6 +43,7 @@ BDEPEND="
dev-util/strace
${PYTHON_DEPS}
)
+ verify-sig? ( sec-keys/openpgp-keys-coreutils )
"
RDEPEND+="
hostname? ( !sys-apps/net-tools[hostname] )
@@ -64,6 +66,15 @@ pkg_setup() {
fi
}
+src_unpack() {
+ if use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.xz{,.sig}
+ fi
+
+ default
+}
+
src_prepare() {
local PATCHES=(
# Upstream patches