summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-16 20:53:47 +0000
committerSam James <sam@gentoo.org>2023-01-16 20:55:06 +0000
commit96ea06e0350497b1b842de47201a3844f3377da3 (patch)
tree93fff88960dcb6631259adfb0b6afdb798369a75 /sys-apps/texinfo
parentsys-apps/ed: use unpacker_src_uri_depends again (diff)
downloadgentoo-96ea06e0350497b1b842de47201a3844f3377da3.tar.gz
gentoo-96ea06e0350497b1b842de47201a3844f3377da3.tar.bz2
gentoo-96ea06e0350497b1b842de47201a3844f3377da3.zip
sys-apps/texinfo: add 7.0.1.90 (pre-release, unkeyworded)
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/texinfo')
-rw-r--r--sys-apps/texinfo/Manifest1
-rw-r--r--sys-apps/texinfo/texinfo-7.0.1.90.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/texinfo/Manifest b/sys-apps/texinfo/Manifest
index 4c62f67fbdb4..4209537dc64c 100644
--- a/sys-apps/texinfo/Manifest
+++ b/sys-apps/texinfo/Manifest
@@ -1,2 +1,3 @@
DIST texinfo-6.8.tar.xz 4961528 BLAKE2B 0256dac5ba9c7f171c970644907b763f7a88fd9995111244df0458591aed1a0fe94c76045dde69f9138d65d6f780aae6869bbbc013f58e04ae7c62456b222bbb SHA512 0ff9290b14e4d83e32b889cfa24e6d065f98b2a764daf6b92c6c895fddbb35258398da6257c113220d5a4d886f7b54b09c4b117ca5eacfee6797f9bffde0f909
+DIST texinfo-7.0.1.90.tar.xz 4854076 BLAKE2B 5332f0d71e04049cb88b7542902db794eceda2707587ccb4df5d0afbbea29861d9eeef6229610e137a4a17cdde4a9a14b22301ab420f4888d2e728322a12f2ac SHA512 8a05553a7fc80bb180cc9fcab335bdf67ae4202fc46b610bc06ee210a8141a8c1d1f23cf8166b63d10c1a36029723e5eab47e2cab69e1db8b08c5ce33f3fb1a2
DIST texinfo-7.0.1.tar.xz 4890348 BLAKE2B 9d61722e7ff8a71e05770552050cc861d778b9faa95f801e40d4353601a5692f01ad8e794dfb0e7b5b29efa2c701de4a76505732a806b0303b5c1fe0599816f1 SHA512 8e1616341fbbfe0cd90bd1b0452874c75b99d88dffe5f88c53fdc32f00d67c07c15c6c774b241e1f7507f0347314737e533854939c3be6334ca9feb9cd049009
diff --git a/sys-apps/texinfo/texinfo-7.0.1.90.ebuild b/sys-apps/texinfo/texinfo-7.0.1.90.ebuild
new file mode 100644
index 000000000000..2e06ad1a4026
--- /dev/null
+++ b/sys-apps/texinfo/texinfo-7.0.1.90.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Note: if your package uses the texi2dvi utility, it must depend on the
+# virtual/texi2dvi package to pull in all the right deps. The tool is not
+# usable out-of-the-box because it requires the large tex packages.
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="The GNU info program and utilities"
+HOMEPAGE="https://www.gnu.org/software/texinfo/"
+
+if [[ $(ver_cut 3) -ge 90 || $(ver_cut 4) -ge 90 ]] ; then
+ SRC_URI="https://alpha.gnu.org/gnu/${PN}/${P}.tar.xz"
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="nls +standalone static"
+
+RDEPEND="
+ !=app-text/tetex-2*
+ >=sys-libs/ncurses-5.2-r2:=
+ virtual/perl-Data-Dumper
+ virtual/perl-Encode
+ standalone? ( >=dev-lang/perl-5.8.1 )
+ !standalone? ( >=dev-lang/perl-5.8.1:= )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( >=sys-devel/gettext-0.19.6 )
+"
+
+src_prepare() {
+ default
+
+ # Needed if a patch touches install-info.c
+ #touch man/install-info.1 || die
+
+ if use prefix ; then
+ sed -i -e '1c\#!/usr/bin/env sh' util/texi2dvi util/texi2pdf || die
+ touch {doc,man}/{texi2dvi,texi2pdf,pdftexi2dvi}.1 || die
+ fi
+}
+
+src_configure() {
+ # Respect compiler and CPPFLAGS/CFLAGS/LDFLAGS for Perl extensions
+ # bug #622576
+ local -x PERL_EXT_CC="$(tc-getCC)" PERL_EXT_CPPFLAGS="${CPPFLAGS}"
+ local -x PERL_EXT_CFLAGS="${CFLAGS}" PERL_EXT_LDFLAGS="${LDFLAGS}"
+
+ use static && append-ldflags -static
+
+ local myeconfargs=(
+ --cache-file="${S}"/config.cache
+ $(use_enable nls)
+ $(use_enable !standalone perl-xs)
+ )
+
+ econf "${myeconfargs[@]}"
+}