summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-18 20:38:51 +0100
committerSam James <sam@gentoo.org>2024-10-18 20:43:22 +0100
commit627572a9b3064067a523063b0fca25b0791d99eb (patch)
treebb10dc8c17606e397db55c06af72c989d8476f8b /sys-apps/kbd
parentdev-util/debugedit: run tests in parallel (diff)
downloadgentoo-627572a9b3064067a523063b0fca25b0791d99eb.tar.gz
gentoo-627572a9b3064067a523063b0fca25b0791d99eb.tar.bz2
gentoo-627572a9b3064067a523063b0fca25b0791d99eb.zip
sys-apps/kbd: run tests in parallel
They're not really slow anyway but why not? Plus it's a useful way to grep for things using autotest. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-apps/kbd')
-rw-r--r--sys-apps/kbd/kbd-2.6.4.ebuild8
-rw-r--r--sys-apps/kbd/kbd-9999.ebuild8
2 files changed, 14 insertions, 2 deletions
diff --git a/sys-apps/kbd/kbd-2.6.4.ebuild b/sys-apps/kbd/kbd-2.6.4.ebuild
index d4f32c7cb2bd..ebceb5c788ba 100644
--- a/sys-apps/kbd/kbd-2.6.4.ebuild
+++ b/sys-apps/kbd/kbd-2.6.4.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit multiprocessing
+
if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
@@ -75,6 +77,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake -Onone check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}
+
src_install() {
default
diff --git a/sys-apps/kbd/kbd-9999.ebuild b/sys-apps/kbd/kbd-9999.ebuild
index 7cb13a1a8a2d..ca0b13cdd97e 100644
--- a/sys-apps/kbd/kbd-9999.ebuild
+++ b/sys-apps/kbd/kbd-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit multiprocessing
+
if [[ ${PV} == 9999 ]] ; then
inherit autotools git-r3
EGIT_REPO_URI="https://github.com/legionus/kbd.git https://git.kernel.org/pub/scm/linux/kernel/git/legion/kbd.git"
@@ -75,6 +77,10 @@ src_configure() {
econf "${myeconfargs[@]}"
}
+src_test() {
+ emake -Onone check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
+}
+
src_install() {
default