summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-07 05:05:23 +0100
committerSam James <sam@gentoo.org>2022-04-07 05:07:32 +0100
commit1d53d8583332d7881e24172edd90c5d98552ba15 (patch)
tree0d22094261a09a336f8a179917bd9a19a55c71f8 /sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild
parentsys-libs/gdbm: add verify-sig (diff)
downloadgentoo-1d53d8583332d7881e24172edd90c5d98552ba15.tar.gz
gentoo-1d53d8583332d7881e24172edd90c5d98552ba15.tar.bz2
gentoo-1d53d8583332d7881e24172edd90c5d98552ba15.zip
sec-keys/openpgp-keys-wget: new package, add 20220407
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild')
-rw-r--r--sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild b/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild
new file mode 100644
index 000000000000..a9389cc15a08
--- /dev/null
+++ b/sec-keys/openpgp-keys-wget/openpgp-keys-wget-20220407.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenPGP keys used by GNU wget"
+HOMEPAGE="https://savannah.gnu.org/projects/wget/"
+SRC_URI="https://savannah.gnu.org/project/memberlist-gpgkeys.php?group=wget&download=1 -> ${P}.asc"
+S="${WORKDIR}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ newins - wget.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
+}