summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/spyview
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/spyview')
-rw-r--r--sci-visualization/spyview/Manifest2
-rw-r--r--sci-visualization/spyview/metadata.xml10
-rw-r--r--sci-visualization/spyview/spyview-20111018.ebuild51
-rw-r--r--sci-visualization/spyview/spyview-20130823.ebuild52
4 files changed, 115 insertions, 0 deletions
diff --git a/sci-visualization/spyview/Manifest b/sci-visualization/spyview/Manifest
new file mode 100644
index 000000000000..874ee4885676
--- /dev/null
+++ b/sci-visualization/spyview/Manifest
@@ -0,0 +1,2 @@
+DIST spyview-20111018.tar.gz 3721357 SHA256 aad98c243e4455cbb4c82af6aeb374b50d9483cf25945ba571cb59b3d7c71a41 SHA512 6191068a431486692918029a0350275500d46993252ac29678f470e0a4c89ab0e57feb438241b8159dd6aa6583eb4d4d3d970553abae515ce5b8c1dc49deabb6 WHIRLPOOL c6c0bec9301fd89cb8f00198f403d36da4ed93b2ad8e09ad0456e2533e8b4a46dc2ae8565664be8f71d3ed75dc8b86d2c172b0511d02b0ec49a02dd42be22168
+DIST spyview-20130823.tgz 3279013 SHA256 1927278ed31ab3b1a15d6294f73ae55de71f97165b1787e5abd7e323272d4ea1 SHA512 c25b3955e32000c0477091aad465d18c0c1aa4bcd00f8f9aee3454cdbdf98d8bbfa4e072a860d37836710dd6cd859deba1a764c8453526602317eda1b3ce0435 WHIRLPOOL f1aefa797571aaba8cc95c3925eb0f6bafe1568f2952eb9c7b98e8c544242305ce9d963524610536bd1d0d9df9b16f2f8b0356e001561be68f4d4e61d891fc42
diff --git a/sci-visualization/spyview/metadata.xml b/sci-visualization/spyview/metadata.xml
new file mode 100644
index 000000000000..331d38a1cc6f
--- /dev/null
+++ b/sci-visualization/spyview/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ <name>Andreas K. Huettel</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+</pkgmetadata>
diff --git a/sci-visualization/spyview/spyview-20111018.ebuild b/sci-visualization/spyview/spyview-20111018.ebuild
new file mode 100644
index 000000000000..4252f092e489
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20111018.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://kavli.nano.tudelft.nl/~gsteele/${PN}/versions/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+COMMON_DEPEND="
+ >=dev-libs/boost-1.42
+ media-libs/netpbm
+ x11-libs/fltk:1[opengl]
+ app-text/ghostscript-gpl
+ virtual/glu
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+src_unpack() {
+ default
+ mv -v "${WORKDIR}"/spyview-20* "${S}" || die
+}
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+
+ append-ldflags -L$(dirname $(fltk-config --libs))
+
+ find "${S}" -name Makefile.in -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
+}
diff --git a/sci-visualization/spyview/spyview-20130823.ebuild b/sci-visualization/spyview/spyview-20130823.ebuild
new file mode 100644
index 000000000000..f6c4fd0e1c47
--- /dev/null
+++ b/sci-visualization/spyview/spyview-20130823.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools flag-o-matic eutils multilib
+
+DESCRIPTION="Interactive plotting program"
+HOMEPAGE="http://kavli.nano.tudelft.nl/~gsteele/spyview/"
+SRC_URI="http://nsweb.tn.tudelft.nl/gitweb/?p=spyview.git;a=snapshot;h=879615fcc662e8572f99854557010d014bb4651e;sf=tgz -> $P.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+COMMON_DEPEND="
+ dev-libs/boost:=
+ media-libs/netpbm
+ x11-libs/fltk:1[opengl]
+ app-text/ghostscript-gpl
+ virtual/glu
+"
+
+DEPEND="${COMMON_DEPEND}
+ sys-apps/groff"
+
+RDEPEND="${COMMON_DEPEND}
+ sci-visualization/gnuplot"
+
+src_unpack() {
+ default
+ mv -v "${WORKDIR}"/spyview-* "${S}" || die
+}
+
+src_prepare() {
+ append-cflags $(fltk-config --cflags)
+ append-cxxflags $(fltk-config --cxxflags) -I/usr/include/netpbm
+
+ # append-ldflags $(fltk-config --ldflags)
+ # this one leads to an insane amount of warnings
+ append-ldflags -L$(dirname $(fltk-config --libs))
+
+ find "${S}" -name Makefile.am -exec sed -i -e 's:-mwindows -mconsole::g' {} + || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --datadir=/usr/share/spyview --docdir=/usr/share/doc/${PF}
+}