summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuilherme Amadio <amadio@gentoo.org>2024-03-09 17:53:01 +0100
committerGuilherme Amadio <amadio@gentoo.org>2024-03-10 13:16:25 +0100
commit40b3ddf883cb691287779d01fea1faef1c73debb (patch)
treeac4c9defc6f0e465386039a63c434a1204404725 /sci-physics
parentsci-physics/root: filter lto flags, bug #879323 (diff)
downloadgentoo-40b3ddf883cb691287779d01fea1faef1c73debb.tar.gz
gentoo-40b3ddf883cb691287779d01fea1faef1c73debb.tar.bz2
gentoo-40b3ddf883cb691287779d01fea1faef1c73debb.zip
sci-physics/root: reorder variables reported by pkgcheck
Signed-off-by: Guilherme Amadio <amadio@gentoo.org>
Diffstat (limited to 'sci-physics')
-rw-r--r--sci-physics/root/root-6.28.12.ebuild7
-rw-r--r--sci-physics/root/root-6.30.04.ebuild7
-rw-r--r--sci-physics/root/root-6.30.9999.ebuild7
-rw-r--r--sci-physics/root/root-9999.ebuild7
4 files changed, 12 insertions, 16 deletions
diff --git a/sci-physics/root/root-6.28.12.ebuild b/sci-physics/root/root-6.28.12.ebuild
index 47324a37ee7d..5f5e960bd68f 100644
--- a/sci-physics/root/root-6.28.12.ebuild
+++ b/sci-physics/root/root-6.28.12.ebuild
@@ -12,15 +12,13 @@ inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
+LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
-RESTRICT="test"
-PROPERTIES="test_network"
-
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/root-project/root.git"
@@ -36,7 +34,8 @@ else
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi
-LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
+RESTRICT="test"
+PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
diff --git a/sci-physics/root/root-6.30.04.ebuild b/sci-physics/root/root-6.30.04.ebuild
index 47324a37ee7d..5f5e960bd68f 100644
--- a/sci-physics/root/root-6.30.04.ebuild
+++ b/sci-physics/root/root-6.30.04.ebuild
@@ -12,15 +12,13 @@ inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
+LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
-RESTRICT="test"
-PROPERTIES="test_network"
-
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/root-project/root.git"
@@ -36,7 +34,8 @@ else
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi
-LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
+RESTRICT="test"
+PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
diff --git a/sci-physics/root/root-6.30.9999.ebuild b/sci-physics/root/root-6.30.9999.ebuild
index 47324a37ee7d..5f5e960bd68f 100644
--- a/sci-physics/root/root-6.30.9999.ebuild
+++ b/sci-physics/root/root-6.30.9999.ebuild
@@ -12,15 +12,13 @@ inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
+LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
-RESTRICT="test"
-PROPERTIES="test_network"
-
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/root-project/root.git"
@@ -36,7 +34,8 @@ else
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi
-LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
+RESTRICT="test"
+PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )
diff --git a/sci-physics/root/root-9999.ebuild b/sci-physics/root/root-9999.ebuild
index 47324a37ee7d..5f5e960bd68f 100644
--- a/sci-physics/root/root-9999.ebuild
+++ b/sci-physics/root/root-9999.ebuild
@@ -12,15 +12,13 @@ inherit cmake cuda flag-o-matic fortran-2 python-single-r1 toolchain-funcs
DESCRIPTION="C++ data analysis framework and interpreter from CERN"
HOMEPAGE="https://root.cern"
+LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
IUSE="+X aqua +asimage cuda cudnn +davix debug +examples fits fftw fortran
+gdml graphviz +gsl http jupyter libcxx +minuit mpi mysql odbc +opengl
oracle postgres pythia6 pythia8 +python qt5 R +roofit +root7 shadow
sqlite +ssl +tbb test +tmva +unuran uring vc +xml xrootd"
-RESTRICT="test"
-PROPERTIES="test_network"
-
if [[ ${PV} =~ "9999" ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/root-project/root.git"
@@ -36,7 +34,8 @@ else
SRC_URI="https://root.cern/download/${PN}_v${PV}.source.tar.gz"
fi
-LICENSE="LGPL-2.1 freedist MSttfEULA LGPL-3 libpng UoI-NCSA"
+RESTRICT="test"
+PROPERTIES="test_network"
REQUIRED_USE="
cuda? ( tmva )