summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2018-09-26 16:28:32 +0700
committerAndrey Grozin <grozin@gentoo.org>2018-09-26 16:28:32 +0700
commite1c4cf1df7dcccc70404b0400e4a6c3119351e61 (patch)
tree94babd086f5a76558484163847d1c26b7bb863d3 /sci-mathematics/wxmaxima
parentsci-mathematics/wxmaxima: cleaning old versions (diff)
downloadgentoo-e1c4cf1df7dcccc70404b0400e4a6c3119351e61.tar.gz
gentoo-e1c4cf1df7dcccc70404b0400e4a6c3119351e61.tar.bz2
gentoo-e1c4cf1df7dcccc70404b0400e4a6c3119351e61.zip
sci-mathematics/wxmaxima: bump to 18.10.0
Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'sci-mathematics/wxmaxima')
-rw-r--r--sci-mathematics/wxmaxima/Manifest1
-rw-r--r--sci-mathematics/wxmaxima/wxmaxima-18.10.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/sci-mathematics/wxmaxima/Manifest b/sci-mathematics/wxmaxima/Manifest
index 2ea4791497f6..e34ec2b03ecb 100644
--- a/sci-mathematics/wxmaxima/Manifest
+++ b/sci-mathematics/wxmaxima/Manifest
@@ -1,2 +1,3 @@
DIST wxmaxima-15.08.2.tar.gz 5592673 BLAKE2B cacb508cbcb24e27a43998ba0079b14117980669c25b39b017c0c659ef48d2ad338c6503aea99447a14250ed1a68a3414880828fc8ffdcbd3177b8eb9355a919 SHA512 a537c49477f54df4fd9e4e42a5e0d0d740f1ede817d807a98b7cec877a3ad77b2be0a61ae487a7fa5beb193b112eca163b8873292ecab5acf118d58a91e91af6
DIST wxmaxima-18.02.0.tar.gz 10131174 BLAKE2B d2137d4dfb23244c677a64578ea8cd132514d6e80b39ed1ed938a64952fcd9928459a64ceafccd34ef925fea6161a79112da9e8091de2ba8f93b4137f3240692 SHA512 e40a5fa701bd40c279de95bc16269a72678443ef0bdb14c3770c81feeaf33ddfff6c10f00b32239adcdf696f2a449c6d88d168b732d1273764c98c6ff807fd84
+DIST wxmaxima-18.10.0.tar.gz 12144997 BLAKE2B 78cfe2cfa5532271cc07eb7bb106b0c9708df4ae3086c02a859f51affe87dd813b3ca28b7fb1137cfb2acbef4f2ce12d2464c30a6dd39d47c028cf4f6c6b030e SHA512 b8cc4288db6bd673a7de7e05d3ff9e3dec1660a78944c2fcd80422cbb6102eea81de33dbc19e7f66e31e0a044be9e935a7f7323b855a1dd3302c3763e5c98196
diff --git a/sci-mathematics/wxmaxima/wxmaxima-18.10.0.ebuild b/sci-mathematics/wxmaxima/wxmaxima-18.10.0.ebuild
new file mode 100644
index 000000000000..56c7b4a3e198
--- /dev/null
+++ b/sci-mathematics/wxmaxima/wxmaxima-18.10.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg-utils gnome2-utils
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="http://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+ dev-libs/libxml2:2
+ x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+ media-fonts/jsmath
+ sci-visualization/gnuplot[wxwidgets]
+ sci-mathematics/maxima"
+
+src_prepare() {
+ setup-wxwidgets
+ cmake-utils_src_prepare
+
+ sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+ || die "sed info/CMakeLists.txt failed"
+
+ # locales
+ rm_po() {
+ rm "${S}"/locales/${1}.po || die "rm ${1}.po failed"
+ }
+ l10n_find_plocales_changes "${S}"/locales '' '.po'
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}