summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-01-12 01:48:42 +0100
committerMaciej Barć <xgqt@gentoo.org>2023-01-12 02:23:40 +0100
commitc0916c566e65101186abaa59fb0329a92f93072a (patch)
tree8da29d7f2c8d5d760c47599b3a67fa917a5206c7 /sci-mathematics/cryptominisat
parentsci-mathematics/coq-serapi: drop old 0.15.0-r3 (diff)
downloadgentoo-c0916c566e65101186abaa59fb0329a92f93072a.tar.gz
gentoo-c0916c566e65101186abaa59fb0329a92f93072a.tar.bz2
gentoo-c0916c566e65101186abaa59fb0329a92f93072a.zip
sci-mathematics/cryptominisat: bump to 5.11.4
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'sci-mathematics/cryptominisat')
-rw-r--r--sci-mathematics/cryptominisat/Manifest1
-rw-r--r--sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/sci-mathematics/cryptominisat/Manifest b/sci-mathematics/cryptominisat/Manifest
index 9ed3ae1590c6..ab7269c69b85 100644
--- a/sci-mathematics/cryptominisat/Manifest
+++ b/sci-mathematics/cryptominisat/Manifest
@@ -1 +1,2 @@
+DIST cryptominisat-5.11.4.tar.gz 1044845 BLAKE2B b6df4e61c5f37d24a61a5c782f08f223c413e19fc2b1625718f7d19d4df8f4d955a92ae447f6c98889927ddc7407b4790092086996a0a32879c7dcb614ca1024 SHA512 8593848c468a6b1ac3d9ae343384aa323fb6ddc17802c9b184c178b9a41314c463b1c5f02ffd19d6e844894c7998e41d6e9b808ed70dcc235aa595607f52bc76
DIST cryptominisat-5.8.0.tar.gz 943785 BLAKE2B 534af88a8432c7e3da63989cad8fd5e1491bd69a80b44977fa681e0356e857a505a82dc860b0d04d07987e3edae2861da67ec9dd781261e03a1120dc342b9759 SHA512 3eb954f01524b189a8de57a05f6060471a083addc4b9077c1e32b769d26393ce3d33468819ba8169deedce43fc3663b0ad8bbad95c6afe5e562e438c57b75496
diff --git a/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild b/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild
new file mode 100644
index 000000000000..a4f699cc2afd
--- /dev/null
+++ b/sci-mathematics/cryptominisat/cryptominisat-5.11.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Advanced SAT solver with C++ and command-line interfaces"
+HOMEPAGE="https://github.com/msoos/cryptominisat/"
+SRC_URI="https://github.com/msoos/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2 MIT"
+RESTRICT="test" # tests require many convoluted bundled (git) modules
+
+RDEPEND="
+ dev-libs/boost:=
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local -a mycmakeargs=(
+ -DNOBREAKID=ON
+ -DNOM4RI=ON
+ -DENABLE_TESTING=OFF
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ dodir /usr/share/man
+ mv "${ED}"/usr/man "${ED}"/usr/share/man || die
+}