summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-05-14 23:30:21 +0200
committerDavid Seifert <soap@gentoo.org>2022-05-14 23:30:21 +0200
commitdb08774d96d5eb0b797cf0199625d7275587f428 (patch)
treedc345a2c937ab57312490f5b144b8e62afe08bff /sci-libs
parentsci-chemistry/tinker: [QA] tc-has-openmp → tc-check-openmp (diff)
downloadgentoo-db08774d96d5eb0b797cf0199625d7275587f428.tar.gz
gentoo-db08774d96d5eb0b797cf0199625d7275587f428.tar.bz2
gentoo-db08774d96d5eb0b797cf0199625d7275587f428.zip
sci-libs/ceres-solver: [QA] tc-has-openmp → tc-check-openmp
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild10
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild10
-rw-r--r--sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild8
3 files changed, 8 insertions, 20 deletions
diff --git a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
index 4bd35e1b7fc8..67f410873961 100644
--- a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,15 +48,11 @@ DEPEND="${RDEPEND}"
DOCS=( README.md VERSION )
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use doc && python-any-r1_pkg_setup
}
diff --git a/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
index 8ed07b8f792e..66ffb261da7c 100644
--- a/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-2.0.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -48,15 +48,11 @@ DOCS=( README.md VERSION )
PATCHES=( "${FILESDIR}/${P}-system-mathjax.patch" )
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use doc && python-any-r1_pkg_setup
}
diff --git a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
index 92fefb044a1a..fa2a76ca48ac 100644
--- a/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-2.1.0.ebuild
@@ -48,15 +48,11 @@ PATCHES=(
)
pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]] && use openmp; then
- if [[ $(tc-getCXX) == *g++* ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- fi
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
}
pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
use doc && python-any-r1_pkg_setup
}