summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bettler <thomas.bettler@gmail.com>2024-11-04 17:21:03 +0100
committerSam James <sam@gentoo.org>2024-11-11 22:39:01 +0000
commit9015bb68ace477338299e410925bda10c0a490c4 (patch)
tree69dfd99b04e6f884a8b16ae8d856c09cd621bddd /sci-libs
parentsci-libs/gdal: simplify lerc dep (diff)
downloadgentoo-9015bb68ace477338299e410925bda10c0a490c4.tar.gz
gentoo-9015bb68ace477338299e410925bda10c0a490c4.tar.bz2
gentoo-9015bb68ace477338299e410925bda10c0a490c4.zip
sci-libs/pdal: bump to v2.8.1
Closes: https://bugs.gentoo.org/937770 Signed-off-by: Thomas Bettler <thomas.bettler@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39201 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/pdal/Manifest1
-rw-r--r--sci-libs/pdal/pdal-2.8.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/sci-libs/pdal/Manifest b/sci-libs/pdal/Manifest
index 284dc6241b45..81a247560380 100644
--- a/sci-libs/pdal/Manifest
+++ b/sci-libs/pdal/Manifest
@@ -2,3 +2,4 @@ DIST PDAL-2.5.3-src.tar.bz2 102669314 BLAKE2B 1c6c8406f8de65a04364cc1141be809c00
DIST PDAL-2.6.2-src.tar.bz2 87274819 BLAKE2B 5855a268889064fdc72d15ec1dbe7ab3ed8eb6bee2fa4ec724e9f287f25d6b9f9f9171829a2121e156bec575c96a42f26e223c807c8aa9d3a88f77c245c3d01c SHA512 4a9c07deaca6fbe994808904a6b90e09beb418155c662369046b6ddea03c8aa57ca2e9b4c2057c8e409bb197b90adb36e334c9c2136034a021be84763fa93551
DIST PDAL-2.7.2-src.tar.bz2 87431434 BLAKE2B f5093008a84c9e5250bb9e8124c694a919b2a31c0f55b750f8d186e954c51c6672b5e63824203dfeb4efa24e6b0a8c0d354229a655416d5ef56336dc2bcd3a80 SHA512 81e4d4b136e292f5a2e4145f730e00375a26a6a2aa52af679bea6d9d371b55c92641475ea332fc8301fe35d237415b70ea311da3fc1bc4ff69013a7448f66896
DIST PDAL-2.8.0-src.tar.bz2 87483358 BLAKE2B 8d15187f2b6a7110d52e2621d65ee8eedce0dd21c415c18fbb1e48dbdb0b24307b42487f4631f227875079ba47031c27196399970458236c7139b8f1418aa3b8 SHA512 d3b02f13e56423c5086e72908f932db384cb0d64f3d3e5cec121c1e283268f8e38f6123ff852d77c07ea9777001a78595bdafed458dc06aa52402d92e76ce995
+DIST PDAL-2.8.1-src.tar.bz2 87507277 BLAKE2B 634ba5f2c5548bfa1fbdcc257185dcd99d2c8bda73e3ac24cf092d378150285912d9c5b48c88e21df14d5502221865273fa6167b82886ef848fc7d445c8937dc SHA512 fb1d0e892ea38518526ce0086415fffd92f356d104d9982f8883d254a206a75b51ff796dbf5db266a4dc8345ae91b825e8a50ae78eb21552c86ab600905850ad
diff --git a/sci-libs/pdal/pdal-2.8.1.ebuild b/sci-libs/pdal/pdal-2.8.1.ebuild
new file mode 100644
index 000000000000..f18bb365d8a9
--- /dev/null
+++ b/sci-libs/pdal/pdal-2.8.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic
+
+DESCRIPTION="A C++ library for translating and manipulating point cloud data"
+HOMEPAGE="https://pdal.io/"
+SRC_URI="https://github.com/PDAL/PDAL/releases/download/${PV}/PDAL-${PV}-src.tar.bz2"
+S="${WORKDIR}/PDAL-${PV}-src"
+
+LICENSE="BSD"
+SLOT="0/18"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug postgres test"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ net-misc/curl
+ app-arch/zstd:=
+ dev-libs/libxml2
+ dev-libs/openssl:=
+ sci-libs/gdal:=
+ sci-libs/libgeotiff:=
+ sys-libs/zlib
+ debug? ( sys-libs/libunwind:= )
+ postgres? ( dev-db/postgresql:*[xml] )
+"
+
+DEPEND="
+ test? ( sci-libs/gdal[geos,jpeg,png] )
+ ${RDEPEND}
+"
+
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/862915
+ # https://github.com/PDAL/PDAL/issues/3836
+ #
+ # only occurs inside unwind support
+ if use debug; then
+ append-flags -fno-strict-aliasing
+ filter-lto
+ fi
+
+ local mycmakeargs=(
+ -DBUILD_PLUGIN_PGPOINTCLOUD="$(usex postgres)"
+ -DWITH_COMPLETION=ON
+ -DWITH_BACKTRACE="$(usex debug)"
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ local myctestargs=(
+ --exclude-regex '(pgpointcloudtest|pdal_info_test|pdal_io_bpf_base_test|pdal_io_bpf_zlib_test|pdal_filters_overlay_test|pdal_filters_stats_test|pdal_app_plugin_test|pdal_merge_test|pdal_io_stac_reader_test)'
+ --output-on-failure
+ -j1
+ )
+
+ cmake_src_test
+}