summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2020-02-28 20:36:35 -0500
committerMichael Orlitzky <mjo@gentoo.org>2020-03-02 12:20:42 -0500
commit5a44063457f2ff8711d1b96fba5e92852620750e (patch)
tree72c64f18ffcfc2770407ed93fd1b49a4d3165594 /sci-libs/suitesparseconfig
parentnet-fs/samba: Bump to version 4.12.0_rc4 (diff)
downloadgentoo-5a44063457f2ff8711d1b96fba5e92852620750e.tar.gz
gentoo-5a44063457f2ff8711d1b96fba5e92852620750e.tar.bz2
gentoo-5a44063457f2ff8711d1b96fba5e92852620750e.zip
sci-libs/suitesparseconfig: new version 5.4.0.
Update to EAPI=7 and fix the HOMEPAGE, SRC_URI, and LICENSE. This is part of a larger SuiteSparse v5.4.0 upgrade thanks to François Bissey whose sage-on-gentoo ebuilds I'm using. There's a newer release (v5.7.1) of SuiteSparse, but v5.4.0 has seen more testing. Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'sci-libs/suitesparseconfig')
-rw-r--r--sci-libs/suitesparseconfig/Manifest1
-rw-r--r--sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/sci-libs/suitesparseconfig/Manifest b/sci-libs/suitesparseconfig/Manifest
index 3bb36d978e7a..ea9fb1eba34d 100644
--- a/sci-libs/suitesparseconfig/Manifest
+++ b/sci-libs/suitesparseconfig/Manifest
@@ -1 +1,2 @@
DIST suitesparseconfig-4.2.1.tar.bz2 256308 BLAKE2B 74993d9a43117e9b71e21856c7b27d4aa6627c64a4235d7d37efa282a0a8e54fa8c6d6aea1cd447902ab8b18bfff1aa1e0d67a6b86d86c2feaf6a9f716ac2f0f SHA512 2363f8adb962d1f932b4390ac54e7203b5eec6005f9275dc155a4b178fd5259ddd42dc34c663a4c82546452c0f1e05619522567a69be1a58efc5d032b6d7a61d
+DIST suitesparseconfig-5.4.0.tar.bz2 257352 BLAKE2B 3832e34281c742a7d704dde866c53c742420486d782075e047b605fb2062d77353cda8670138c4bef62c73d16e123a8a74f65272a01766f124c1e53f9ba32e9d SHA512 e91f60f426b73add473c6341e30512b8fbe65b7850cd83f3852e78f1e74ce067b7ae1577ccc795698e680a841a9d32c2ca073651a4fe95f0b723578721aec874
diff --git a/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild b/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
new file mode 100644
index 000000000000..6e48d59fa270
--- /dev/null
+++ b/sci-libs/suitesparseconfig/suitesparseconfig-5.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Common configurations for all packages in suitesparse"
+HOMEPAGE="http://faculty.cse.tamu.edu/davis/suitesparse.html"
+SRC_URI="http://202.36.178.9/sage/${P}.tar.bz2"
+
+# Upstream says, "no licensing restrictions apply to this file or to the
+# SuiteSparse_config directory".
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_install_all() {
+ if ! use static-libs; then
+ find "${ED}" -name "*.la" -delete || die
+ fi
+}