summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/oc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/oc')
-rw-r--r--sci-libs/oc/Manifest1
-rw-r--r--sci-libs/oc/metadata.xml10
-rw-r--r--sci-libs/oc/oc-2.0.ebuild27
3 files changed, 38 insertions, 0 deletions
diff --git a/sci-libs/oc/Manifest b/sci-libs/oc/Manifest
new file mode 100644
index 000000000000..48bbe9aed779
--- /dev/null
+++ b/sci-libs/oc/Manifest
@@ -0,0 +1 @@
+DIST oc-2.0.tar.gz 1104073 SHA256 4ed67dc543a6125731ccfadac14fe8f40cc0e7a74139f4f0612a6a3b1a4a4bab SHA512 e583fbacc8929ef5b2ae0d0f675816b8f46056b11987f8285688a7321d3dfd244a748be00f009f1b2c2b7f95e5a6ecc8eb8e907f81415e849f10a5ff138e82a4 WHIRLPOOL 2dbb286e1e6a711f6ff85956e778ea0dd627e2e67588093ca41ebf3045f97098d9766265769175777066ba2bfd1b88024810ba2c8d883b3bfb86ec8029f1e94e
diff --git a/sci-libs/oc/metadata.xml b/sci-libs/oc/metadata.xml
new file mode 100644
index 000000000000..9bacf03e2639
--- /dev/null
+++ b/sci-libs/oc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ The New OPeNDAP C API (oc) is an OPeNDAP DAP 2.0 client implementation
+ written in generic C. This new API allows for more funcionality and
+ less complexity than the original C API.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-libs/oc/oc-2.0.ebuild b/sci-libs/oc/oc-2.0.ebuild
new file mode 100644
index 000000000000..a4b53bea5d5c
--- /dev/null
+++ b/sci-libs/oc/oc-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="Network Data Access Protocol client C library"
+HOMEPAGE="http://opendap.org/"
+SRC_URI="http://opendap.org/pub/OC/source/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+# tests need network
+#PROPERTIES=network
+
+src_install() {
+ autotools-utils_src_install
+ use doc; dodoc docs/oc*html && dohtml docs/html/*
+}