summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYiyang Wu <xgreenlandforwyy@gmail.com>2022-05-15 13:54:22 +0800
committerBenda Xu <heroxbd@gentoo.org>2022-06-10 12:33:01 +0800
commit5cd59fb00ddb3175440cf4f1d907c78fdd5d44c2 (patch)
tree9da81a6985045b5049aa26bc54c04337ae04c823 /sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild
parentsci-libs/hipFFT: bump version to 5.0.2 (diff)
downloadgentoo-5cd59fb00ddb3175440cf4f1d907c78fdd5d44c2.tar.gz
gentoo-5cd59fb00ddb3175440cf4f1d907c78fdd5d44c2.tar.bz2
gentoo-5cd59fb00ddb3175440cf4f1d907c78fdd5d44c2.zip
sci-libs/hipBLAS: bump version to 5.0.2
Bug: https://github.com/gentoo/gentoo/pull/25830 Bug: https://bugs.gentoo.org/847469 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Yiyang Wu <xgreenlandforwyy@gmail.com> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild')
-rw-r--r--sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild b/sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild
new file mode 100644
index 000000000000..4bf865ad1d81
--- /dev/null
+++ b/sci-libs/hipBLAS/hipBLAS-5.0.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+DESCRIPTION="ROCm BLAS marshalling library"
+HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipBLAS"
+SRC_URI="https://github.com/ROCmSoftwarePlatform/hipBLAS/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="0/$(ver_cut 1-2)"
+
+RDEPEND="dev-util/hip
+ sci-libs/rocBLAS:${SLOT}
+ sci-libs/rocSOLVER:${SLOT}"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/hipBLAS-rocm-${PV}"
+
+src_prepare() {
+ sed -e "s:<INSTALL_INTERFACE\:include:<INSTALL_INTERFACE\:include/hipblas/:" -i library/src/CMakeLists.txt || die
+ sed -e "/PREFIX hipblas/d" -i library/src/CMakeLists.txt || die
+ sed -e "/rocm_install_symlink_subdir( hipblas )/d" -i library/src/CMakeLists.txt || die
+ sed -e "s:hipblas/include:include/hipblas:" -i library/src/CMakeLists.txt || die
+
+ eapply_user
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}/usr"
+ -DCMAKE_SKIP_RPATH=ON
+ -DBUILD_CLIENTS_TESTS=OFF # currently hipBLAS is a wrapper of rocBLAS which has tests, so no need to perform test here
+ -DBUILD_CLIENTS_BENCHMARKS=OFF
+ )
+
+ cmake_src_configure
+}