summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-19 12:29:48 +0000
committerSam James <sam@gentoo.org>2021-02-19 12:45:27 +0000
commitfe66a10754a70c3abe4dd16bf88c9a7248d4992a (patch)
tree19f637ab095046fe5bc20dbbadb7f0ce02374d44 /sci-libs/getdata
parentsci-libs/hdf: add bug reference to gcc 10 workaround (diff)
downloadgentoo-fe66a10754a70c3abe4dd16bf88c9a7248d4992a.tar.gz
gentoo-fe66a10754a70c3abe4dd16bf88c9a7248d4992a.tar.bz2
gentoo-fe66a10754a70c3abe4dd16bf88c9a7248d4992a.zip
sci-libs/getdata: workaround gcc 10 (fortran) failure
Closes: https://bugs.gentoo.org/723076 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-libs/getdata')
-rw-r--r--sci-libs/getdata/getdata-0.9.0-r3.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/sci-libs/getdata/getdata-0.9.0-r3.ebuild b/sci-libs/getdata/getdata-0.9.0-r3.ebuild
index 9282f0156853..118a1e4daced 100644
--- a/sci-libs/getdata/getdata-0.9.0-r3.ebuild
+++ b/sci-libs/getdata/getdata-0.9.0-r3.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
FORTRAN_STANDARD="95"
FORTRAN_NEEDED=fortran
-inherit autotools fortran-2
+inherit autotools fortran-2 flag-o-matic
DESCRIPTION="Reference implementation of the Dirfile, format for time-ordered binary data"
HOMEPAGE="http://getdata.sourceforge.net/"
@@ -31,6 +31,10 @@ src_prepare() {
}
src_configure() {
+ # GCC 10 workaround
+ # bug #723076
+ append-fflags $(test-flags-FC -fallow-argument-mismatch)
+
econf \
--disable-idl \
--disable-matlab \