summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-22 01:31:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-03-22 01:32:41 +0100
commit9d4a85b0d543b4564beaaa955c2314e70b7e6952 (patch)
tree378942338691922866602911763aaaf64f51283c /sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
parentnet-fs/samba: Fixed typo (diff)
downloadgentoo-9d4a85b0d543b4564beaaa955c2314e70b7e6952.tar.gz
gentoo-9d4a85b0d543b4564beaaa955c2314e70b7e6952.tar.bz2
gentoo-9d4a85b0d543b4564beaaa955c2314e70b7e6952.zip
sci-libs/ceres-solver: Drop USE c++11
Closes: https://bugs.gentoo.org/705192 Package-Manager: Portage-2.3.94, Repoman-2.3.21 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild')
-rw-r--r--sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
index 6b175ba5ec7a..d5241fc699a1 100644
--- a/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
+++ b/sci-libs/ceres-solver/ceres-solver-1.14.0.ebuild
@@ -14,7 +14,7 @@ SRC_URI="http://ceres-solver.org/${P}.tar.gz"
LICENSE="sparse? ( BSD ) !sparse? ( LGPL-2.1 ) cxsparse? ( BSD )"
SLOT="0/1"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cxsparse c++11 doc examples gflags lapack openmp +schur sparse test"
+IUSE="cxsparse doc examples gflags lapack openmp +schur sparse test"
REQUIRED_USE="test? ( gflags ) sparse? ( lapack ) abi_x86_32? ( !sparse !lapack )"
@@ -76,9 +76,7 @@ src_configure() {
-DBUILD_BENCHMARKS=OFF
-DBUILD_EXAMPLES=OFF
-DBUILD_TESTING=$(usex test)
- -DCXX11=$(usex c++11)
-DBUILD_DOCUMENTATION=$(usex doc)
- -DCERES_DOCS_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
-DGFLAGS=$(usex gflags)
-DLAPACK=$(usex lapack)
-DOPENMP=$(usex openmp)
@@ -86,6 +84,9 @@ src_configure() {
-DCXSPARSE=$(usex cxsparse)
-DSUITESPARSE=$(usex sparse)
)
+ use doc && mycmakeargs+=(
+ -DCERES_DOCS_INSTALL_DIR="${EPREFIX}"/usr/share/doc/${PF}
+ )
use sparse || use cxsparse || mycmakeargs+=( -DEIGENSPARSE=ON )
cmake-multilib_src_configure
}