summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/ccolamd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/ccolamd')
-rw-r--r--sci-libs/ccolamd/Manifest1
-rw-r--r--sci-libs/ccolamd/ccolamd-2.8.0.ebuild21
-rw-r--r--sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch60
-rw-r--r--sci-libs/ccolamd/metadata.xml10
4 files changed, 92 insertions, 0 deletions
diff --git a/sci-libs/ccolamd/Manifest b/sci-libs/ccolamd/Manifest
new file mode 100644
index 000000000000..1f5e80f44d10
--- /dev/null
+++ b/sci-libs/ccolamd/Manifest
@@ -0,0 +1 @@
+DIST ccolamd-2.8.0.tar.bz2 309907 SHA256 0e3d0d147f22ef6d3e6eedc7540be6135303a064dae9f10ff443ade1196d12eb SHA512 6a515a8250ed98d52aa932a6f93170174ff32f76c1ecedcedeb1540a471416d0cd40b5613a839b96fbc79c66b3cb5106c6a340a33fafdd695c83b7d949756e77 WHIRLPOOL f999836681321d0f1ee0ccaae8cbc86b934220eb4151792b5163a7a1f115319442a9a3db8cb707b7e42cd50fa092765a0fc49c8e60daf756aaff56fa8eb93169
diff --git a/sci-libs/ccolamd/ccolamd-2.8.0.ebuild b/sci-libs/ccolamd/ccolamd-2.8.0.ebuild
new file mode 100644
index 000000000000..5f19e42750fa
--- /dev/null
+++ b/sci-libs/ccolamd/ccolamd-2.8.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-utils
+
+DESCRIPTION="Constrained Column approximate minimum degree ordering algorithm"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/ccolamd/"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm hppa ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="sci-libs/suitesparseconfig"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
diff --git a/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch b/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch
new file mode 100644
index 000000000000..8386325da742
--- /dev/null
+++ b/sci-libs/ccolamd/files/ccolamd-2.7.1-autotools.patch
@@ -0,0 +1,60 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-29 18:53:56.000000000 +0000
+@@ -0,0 +1,3 @@
++SUBDIRS = Demo Source
++EXTRA_DIST = Doc/ChangeLog README.txt
++include_HEADERS = Include/ccolamd.h
+--- configure.ac 1970-01-01 01:00:00.000000000 +0100
++++ configure.ac 2008-01-29 18:54:17.000000000 +0000
+@@ -0,0 +1,13 @@
++# -*- Autoconf -*-
++AC_PREREQ(2.59)
++AC_INIT(ccolamd, 2.7.1, davis@cise.ufl.edu)
++AM_INIT_AUTOMAKE([foreign])
++AC_PROG_INSTALL
++AC_PROG_LIBTOOL
++AC_CHECK_LIB(m, sqrt)
++AC_CHECK_HEADERS(UFconfig.h)
++AC_CONFIG_FILES([
++ Source/Makefile
++ Demo/Makefile
++ Makefile])
++AC_OUTPUT
+--- Source/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Source/Makefile.am 2008-01-29 18:53:56.000000000 +0000
+@@ -0,0 +1,10 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++lib_LTLIBRARIES = libccolamd.la
++noinst_LTLIBRARIES = libccolamdl.la libccolamdi.la
++
++libccolamdl_la_SOURCES = ccolamd.c
++libccolamdl_la_CPPFLAGS = $(AM_CPPFLAGS) -DDLONG
++libccolamdi_la_SOURCES = ccolamd.c
++
++libccolamd_la_SOURCES = ccolamd_global.c
++libccolamd_la_LIBADD = libccolamdl.la libccolamdi.la
+--- Demo/Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Demo/Makefile.am 2008-01-29 18:55:44.000000000 +0000
+@@ -0,0 +1,22 @@
++AM_CPPFLAGS = -I$(top_srcdir)/Include
++
++check_PROGRAMS = \
++ ccolamd_example \
++ ccolamd_l_example
++
++LDADD = $(top_builddir)/Source/libccolamd.la -lm
++ccolamd_example_SOURCES = ccolamd_example.c
++ccolamd_l_example_SOURCES = ccolamd_l_example.c
++
++check-local: $(check_PROGRAMS)
++ @for i in $(check_PROGRAMS); do \
++ echo "Testing $$i"; \
++ ./$$i > my_$$i.out; \
++ if ! diff $(srcdir)/$$i.out my_$$i.out; then \
++ echo "Test $$i failed!"; \
++ exit 1; \
++ fi \
++ done;
++
++clean-local:
++ rm -f my*.out
diff --git a/sci-libs/ccolamd/metadata.xml b/sci-libs/ccolamd/metadata.xml
new file mode 100644
index 000000000000..2451169809d7
--- /dev/null
+++ b/sci-libs/ccolamd/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ Constrained COLAMD computes an column approximate minimum degree ordering
+ algorithm, (like COLAMD), but it can also be given a set of ordering
+ constraints.
+</longdescription>
+</pkgmetadata>