summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-libs/cbflib/files/0.9.2.10-Makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-libs/cbflib/files/0.9.2.10-Makefile.patch')
-rw-r--r--sci-libs/cbflib/files/0.9.2.10-Makefile.patch269
1 files changed, 269 insertions, 0 deletions
diff --git a/sci-libs/cbflib/files/0.9.2.10-Makefile.patch b/sci-libs/cbflib/files/0.9.2.10-Makefile.patch
new file mode 100644
index 000000000000..9c72300873fc
--- /dev/null
+++ b/sci-libs/cbflib/files/0.9.2.10-Makefile.patch
@@ -0,0 +1,269 @@
+ Makefile_LINUX_gcc42 | 93 ++++++++++++++++++++++++++++------------------------
+ 1 file changed, 50 insertions(+), 43 deletions(-)
+
+diff --git a/Makefile_LINUX_gcc42 b/Makefile_LINUX_gcc42
+index 0aa639a..071863d 100644
+--- a/Makefile_LINUX_gcc42
++++ b/Makefile_LINUX_gcc42
+@@ -250,7 +250,11 @@
+
+
+ # Version string
+-VERSION = 0.9.2
++MAJOR = 0
++MINOR = 9
++MICRO = 3
++VERSION = ${MAJOR}.${MINOR}.${MICRO}
++
+
+
+ #
+@@ -297,12 +301,12 @@ SHAR = /usr/bin/shar
+ #
+ # Program to use to create archives
+ #
+-AR = /usr/bin/ar
++AR ?= ar
+
+ #
+ # Program to use to add an index to an archive
+ #
+-RANLIB = /usr/bin/ranlib
++RANLIB ?= ranlib
+
+ #
+ # Program to use to decompress a data file
+@@ -313,7 +317,7 @@ DECOMPRESS = bunzip2
+ #
+ # Program to use to compress a data file
+ #
+-COMPRESS = /usr/bin/bzip2
++COMPRESS = bzip2
+
+ #
+ # Program to use to generate a signature
+@@ -410,12 +414,12 @@ SETUP_PY = setup.py
+ # with gcc version 4.2
+ #
+ #########################################################
+-CC = gcc
+-C++ = g++
+-CFLAGS = -g -O2 -Wall -D_USE_XOPEN_EXTENDED -fno-strict-aliasing
+-F90C = gfortran
+-F90FLAGS = -g -fno-range-check
+-F90LDFLAGS =
++CC ?= gcc
++CXX ?= g++
++CFLAGS += -Wall -D_USE_XOPEN_EXTENDED -fno-strict-aliasing
++FC ?= gfortran
++FCFLAGS += -g -fno-range-check
++LDFLAGS +=
+ SOCFLAGS = -fPIC
+ SOLDFLAGS = -shared -Wl,-rpath,$(INSTALLDIR)/lib
+ JAVAINCLUDES = -I$(JDKDIR)/include -I$(JDKDIR)/include/linux
+@@ -425,7 +429,7 @@ M4FLAGS = -Dfcb_bytes_in_rec=131072
+ TIME = time
+
+ ifneq ($(NOFORTRAN),)
+-F90C =
++FC =
+ endif
+
+ #
+@@ -491,9 +495,9 @@ RTLPEXPORTS = export LD_LIBRARY_PATH=$(PWD)/solib:$(PWD)/lib;\
+ .m4.f90:
+ m4 -P $(M4FLAGS) $< > $@
+
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ .f90.o:
+- $(F90C) $(F90FLAGS) -c $< -o $@
++ $(FC) $(FCFLAGS) -c $< -o $@
+ endif
+
+
+@@ -701,7 +705,7 @@ default:
+ #
+ # Compile the library and examples
+ #
+-all:: $(BIN) $(SOURCE) $(F90SOURCE) $(HEADERS) $(HDF5)\
++all:: $(BIN) $(SOURCE) $(F90SOURCE) $(HEADERS) \
+ symlinksdone \
+ $(REGEXDEP) \
+ $(LIB)/libcbf.a \
+@@ -725,12 +729,12 @@ all:: $(BIN) $(SOURCE) $(F90SOURCE) $(HEADERS) $(HDF5)\
+ $(BIN)/tiff2cbf
+
+
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ all:: $(BIN)/test_xds_binary \
+ $(BIN)/test_fcb_read_image
+ endif
+
+-shared: $(SOLIB)/libcbf.so $(SOLIB)/libfcb.so $(SOLIB)/libimg.so
++shared: $(SOLIB)/libcbf.so.${VERSION} $(SOLIB)/libfcb.so.${VERSION} $(SOLIB)/libimg.so.${VERSION}
+
+ javawrapper: shared $(JCBF) $(JCBF)/cbflib-$(VERSION).jar $(SOLIB)/libcbf_wrap.so
+
+@@ -969,7 +973,7 @@ $(SRC)/cbf_stx.c: $(SRC)/cbf.stx.y
+ #
+ # CBF library
+ #
+-$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP) $(LIB) $(HDF5)
++$(LIB)/libcbf.a: $(SOURCE) $(HEADERS) $(COMMONDEP) $(LIB)
+ $(CC) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(PYCIFRWFLAG) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
+ $(AR) cr $@ *.o
+ mv *.o $(LIB)
+@@ -977,10 +981,11 @@ ifneq ($(RANLIB),)
+ $(RANLIB) $@
+ endif
+
+-$(SOLIB)/libcbf.so: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB) $(HDF5)
+- $(CC) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(PYCIFRWFLAG) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
+- $(CC) -o $@ *.o $(SOLDFLAGS) $(EXTRALIBS) $(HDF5SOLIBS)
+- rm *.o
++$(SOLIB)/libcbf.so.${VERSION}: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
++ $(CC) $(CFLAGS) $(NOREGEXFLAG) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(SOURCE)
++ mv *.o $(SOLIB)
++ $(CC) $(LDFLAGS) -Wl,-soname,libcbf.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) -o $@ $(SOLIB)/*.o $(EXTRALIBS) $(HDF5SOLIBS)
++ ln -sf libcbf.so.$(VERSION) $(SOLIB)/libcbf.so
+
+ #
+ # IMG library
+@@ -993,9 +998,10 @@ ifneq ($(RANLIB),)
+ endif
+ rm img.o
+
+-$(SOLIB)/libimg.so: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
+- $(CC) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(EXAMPLES)/img.c
+- $(CC) -o $@ img.o $(SOLDFLAGS)
++$(SOLIB)/libimg.so.${VERSION}: $(SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
++ $(CC) $(CFLAGS) $(NOREGEXFLAG) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(EXAMPLES)/img.c
++ $(CC) $(LDFLAGS) -Wl,-soname,libimg.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) -o $@ img.o -lm
++ ln -sf libimg.so.$(VERSION) $(SOLIB)/libimg.so
+ rm img.o
+
+ #
+@@ -1007,25 +1013,26 @@ CBF_IMG_LIBS: $(LIB)/libcbf.a $(LIB)/libimg.a
+ #
+ # FCB library
+ #
+-$(LIB)/libfcb.a: $(F90SOURCE) $(COMMONDEP) $(LIB) $(HDF5)
+-ifneq ($(F90C),)
+- $(F90C) $(F90FLAGS) -c $(F90SOURCE)
++$(LIB)/libfcb.a: $(F90SOURCE) $(COMMONDEP) $(LIB)
++ifneq ($(FC),)
++ $(FC) $(FCFLAGS) -c $(F90SOURCE)
+ $(AR) cr $@ *.o
+ ifneq ($(RANLIB),)
+ $(RANLIB) $@
+ endif
+ rm *.o
+ else
+- echo "Define F90C to build $(LIB)/libfcb.a"
++ echo "Define FC to build $(LIB)/libfcb.a"
+ endif
+
+-$(SOLIB)/libfcb.so: $(F90SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
+-ifneq ($(F90C),)
+- $(F90C) $(F90FLAGS) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(F90SOURCE)
+- $(F90C) $(F90FLAGS) -o $@ *.o $(SOLDFLAGS)
++$(SOLIB)/libfcb.so.${VERSION}: $(F90SOURCE) $(HEADERS) $(COMMONDEP) $(SOLIB)
++ifneq ($(FC),)
++ $(FC) $(FCFLAGS) $(SOCFLAGS) $(INCLUDES) $(WARNINGS) -c $(F90SOURCE)
++ $(FC) $(LDFLAGS) -Wl,-soname,libfcb.so.$(VERSION) $(SOCFLAGS) $(SOLDFLAGS) $(FCFLAGS) -o $@ *.o
++ ln -sf libfcb.so.$(VERSION) $(SOLIB)/libfcb.so
+ rm *.o
+ else
+- echo "Define F90C to build $(SOLIB)/libfcb.so"
++ echo "Define FC to build $(SOLIB)/libfcb.so"
+ endif
+
+
+@@ -1183,7 +1190,7 @@ $(BIN)/cbf_template_t: $(DECTRIS_EXAMPLES)/cbf_template_t.c \
+ # testcell example program
+ #
+ $(BIN)/testcell: $(LIB)/libcbf.a $(EXAMPLES)/testcell.C
+- $(C++) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
++ $(CXX) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
+ $(EXAMPLES)/testcell.C -L$(LIB) \
+ -lcbf $(EXTRALIBS) $(HDF5LIBS) -o $@
+
+@@ -1191,7 +1198,7 @@ $(BIN)/testcell: $(LIB)/libcbf.a $(EXAMPLES)/testcell.C
+ # cif2c example program
+ #
+ $(BIN)/cif2c: $(LIB)/libcbf.a $(EXAMPLES)/cif2c.c
+- $(C++) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
++ $(CXX) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
+ $(EXAMPLES)/cif2c.c -L$(LIB) \
+ -lcbf $(EXTRALIBS) $(HDF5LIBS) -o $@
+
+@@ -1199,7 +1206,7 @@ $(BIN)/cif2c: $(LIB)/libcbf.a $(EXAMPLES)/cif2c.c
+ # sauter_test example program
+ #
+ $(BIN)/sauter_test: $(LIB)/libcbf.a $(EXAMPLES)/sauter_test.C
+- $(C++) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
++ $(CXX) $(CFLAGS) $(NOLLFLAG) $(NOREGEXFLAG) $(INCLUDES) $(WARNINGS) \
+ $(EXAMPLES)/sauter_test.C -L$(LIB) \
+ -lcbf $(EXTRALIBS) $(HDF5LIBS) -o $@
+
+@@ -1253,19 +1260,19 @@ $(BIN)/testflatpacked: $(LIB)/libcbf.a $(EXAMPLES)/testflatpacked.c
+ $(EXAMPLES)/testflatpacked.c -L$(LIB) \
+ -lcbf $(EXTRALIBS) $(HDF5LIBS) -o $@
+
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ #
+ # test_xds_binary example program
+ #
+ $(BIN)/test_xds_binary: $(LIB)/libfcb.a $(EXAMPLES)/test_xds_binary.f90
+- $(F90C) $(F90FLAGS) $(F90LDFLAGS) $(EXAMPLES)/test_xds_binary.f90 \
++ $(FC) $(FCFLAGS) $(LDFLAGS) $(EXAMPLES)/test_xds_binary.f90 \
+ -L$(LIB) -lfcb -o $@
+
+ #
+ # test_fcb_read_image example program
+ #
+ $(BIN)/test_fcb_read_image: $(LIB)/libfcb.a $(EXAMPLES)/test_fcb_read_image.f90
+- $(F90C) $(F90FLAGS) $(F90LDFLAGS) $(EXAMPLES)/test_fcb_read_image.f90 \
++ $(FC) $(FCFLAGS) $(LDFLAGS) $(EXAMPLES)/test_fcb_read_image.f90 \
+ -L$(LIB) -lfcb -o $@
+ endif
+
+@@ -1520,7 +1527,7 @@ basic: $(BIN)/makecbf $(BIN)/img2cif $(BIN)/cif2cbf $(TESTINPUT_BASIC)
+ #
+ # Extra Tests
+ #
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ extra: $(BIN)/convert_image $(BIN)/convert_minicbf $(BIN)/cif2cbf $(BIN)/testcell \
+ $(BIN)/testreals $(BIN)/testflat $(BIN)/testflatpacked \
+ $(BIN)/test_xds_binary $(BIN)/test_fcb_read_image $(BIN)/convert_minicbf \
+@@ -1582,7 +1589,7 @@ endif
+ -cmp testflatin.cbf testflatout.cbf
+ $(TIME) $(BIN)/testflatpacked
+ -cmp testflatpackedin.cbf testflatpackedout.cbf
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ echo testflatout.cbf | $(TIME) $(BIN)/test_xds_binary > test_xds_bin_testflatout.out
+ -$(DIFF) test_xds_bin_testflatout.out test_xds_bin_testflatout_orig.out
+ echo testflatpackedout.cbf | $(TIME) $(BIN)/test_xds_binary > test_xds_bin_testflatpackedout.out
+@@ -1599,7 +1606,7 @@ endif
+ $(TIME) $(BIN)/cif2cbf -I 4 -C 100. -L 0. -e n -c b -i XRD1621.cbf -o XRD1621_I4encbC100.cbf
+ -$(DIFF) XRD1621_I4encbC100.cbf XRD1621_I4encbC100_orig.cbf
+
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ extra_sigs_only: $(BIN)/convert_image $(BIN)/convert_minicbf $(BIN)/cif2cbf $(BIN)/testcell \
+ $(BIN)/testreals $(BIN)/testflat $(BIN)/testflatpacked \
+ $(BIN)/test_xds_binary $(BIN)/test_fcb_read_image $(BIN)/convert_minicbf \
+@@ -1650,7 +1657,7 @@ endif
+ -cmp testflatin.cbf testflatout.cbf
+ $(TIME) $(BIN)/testflatpacked
+ -cmp testflatpackedin.cbf testflatpackedout.cbf
+-ifneq ($(F90C),)
++ifneq ($(FC),)
+ echo testflatout.cbf | $(TIME) $(BIN)/test_xds_binary | \
+ $(SIGNATURE) | $(DIFF) - test_xds_bin_testflatout_orig.out$(SEXT)
+ echo testflatpackedout.cbf | $(TIME) $(BIN)/test_xds_binary | \