summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-08-27 18:03:22 +0300
committerArsen Arsenović <arsen@gentoo.org>2024-09-18 15:06:40 +0200
commit7a3daf8ba3750dda074458a780f42207125bc5a3 (patch)
tree89038ba69e08a0f96ea1184a17e3e59cf77140ca /sci-electronics
parentsci-electronics/geda: switch to new guile mechanism (diff)
downloadgentoo-7a3daf8ba3750dda074458a780f42207125bc5a3.tar.gz
gentoo-7a3daf8ba3750dda074458a780f42207125bc5a3.tar.bz2
gentoo-7a3daf8ba3750dda074458a780f42207125bc5a3.zip
sci-electronics/gwave: switch to new guile mechanism
Bug: https://bugs.gentoo.org/886139 Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Arsen Arsenović <arsen@gentoo.org>
Diffstat (limited to 'sci-electronics')
-rw-r--r--sci-electronics/gwave/files/gwave-20190116-lfs-shim.patch14
-rw-r--r--sci-electronics/gwave/gwave-20190116-r100.ebuild63
2 files changed, 77 insertions, 0 deletions
diff --git a/sci-electronics/gwave/files/gwave-20190116-lfs-shim.patch b/sci-electronics/gwave/files/gwave-20190116-lfs-shim.patch
new file mode 100644
index 000000000000..5957b6a1b6b0
--- /dev/null
+++ b/sci-electronics/gwave/files/gwave-20190116-lfs-shim.patch
@@ -0,0 +1,14 @@
+https://bugs.gentoo.org/886139
+
+--- a/spicefile/sp2sp.c
++++ b/spicefile/sp2sp.c
+@@ -234,7 +234,7 @@
+ }
+ of = stdout;
+ } else {
+- of = (FILE *)fopen64(outfilename, "w"); /* DJW: why is the cast needed? */
++ of = fopen(outfilename, "w");
+ if(!of) {
+ if(errno)
+ perror(outfilename);
+
diff --git a/sci-electronics/gwave/gwave-20190116-r100.ebuild b/sci-electronics/gwave/gwave-20190116-r100.ebuild
new file mode 100644
index 000000000000..2b2cd9972339
--- /dev/null
+++ b/sci-electronics/gwave/gwave-20190116-r100.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_REQ_USE="networking"
+GUILE_COMPAT=( 2-2 )
+inherit autotools desktop flag-o-matic guile-single xdg
+
+DESCRIPTION="Analog waveform viewer for SPICE-like simulations"
+HOMEPAGE="http://gwave.sourceforge.net"
+SRC_URI="https://downloads.sourceforge.net/${PN}/gwave3/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot plotutils"
+SLOT="0"
+
+REQUIRED_USE="${GUILE_REQUIRED_USE}"
+
+DEPEND="
+ ${GUILE_DEPS}
+ >=x11-libs/gtk+-2.8.0:2=
+ sys-libs/readline:0=
+ sys-libs/ncurses:0="
+
+RDEPEND="${DEPEND}
+ sci-electronics/electronics-menu
+ gnuplot? ( sci-visualization/gnuplot )
+ plotutils? ( media-libs/plotutils )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-multiple-little-bugfixes.patch
+ "${FILESDIR}"/${P}-as-needed.patch
+ "${FILESDIR}"/${P}-fix-configure.patch
+ "${FILESDIR}"/${P}-lfs-shim.patch
+)
+
+src_prepare() {
+ guile-single_src_prepare
+
+ sed -i \
+ -e "s|guile-snarf|${GUILESNARF}|" \
+ -e "s|guile-tools|${GUILE/guile/guile-tools}|" \
+ src/Makefile.am || die
+ sed -i \
+ -e "s|guile-tools|${GUILE/guile/guile-tools}|" \
+ scheme/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # https://bugs.gentoo.org/886139
+ append-lfs-flags
+ econf
+}
+
+src_install() {
+ guile-single_src_install
+ newicon icons/wave-drag-ok.xpm gwave.xpm
+ make_desktop_entry gwave "Gwave" gwave "Electronics"
+}