summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGerhard Bräunlich <wippbox@gmx.net>2016-10-21 10:32:49 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-21 20:49:29 +0200
commit1b15d368160986145f333643197e833a73be8ef5 (patch)
tree43a09248ab7642db60d43b69960b86b4d1eeae30 /sci-calculators
parentsci-calculators/pcalc: Removing pcalc-3 (EAPI 4) (diff)
downloadgentoo-1b15d368160986145f333643197e833a73be8ef5.tar.gz
gentoo-1b15d368160986145f333643197e833a73be8ef5.tar.bz2
gentoo-1b15d368160986145f333643197e833a73be8ef5.zip
sci-calculators/qalculator: EAPI bump 4 -> 6
Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/2616 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/qalculator/qalculator-0.4b-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sci-calculators/qalculator/qalculator-0.4b-r1.ebuild b/sci-calculators/qalculator/qalculator-0.4b-r1.ebuild
new file mode 100644
index 000000000000..8e9ef587e0d5
--- /dev/null
+++ b/sci-calculators/qalculator/qalculator-0.4b-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils qmake-utils
+
+DESCRIPTION="A Qt4 based small calculator application"
+HOMEPAGE="http://www.qt-apps.org/content/show.php/Qalculator?content=101326"
+SRC_URI="http://www.qt-apps.org/CONTENT/content-files/101326-${P}-src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtgui:4"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}-src"
+
+src_configure() {
+ eqmake4 Qalculator.pro
+}
+
+src_install() {
+ dobin Qalculator
+ make_desktop_entry Qalculator Qalculator accessories-calculator
+}