summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Beierlein <tomjbe@gentoo.org>2024-02-19 08:46:32 +0100
committerThomas Beierlein <tomjbe@gentoo.org>2024-02-19 08:46:32 +0100
commit791ab23aa4c758477325aea93f376a89e289eb5b (patch)
treeae5f9aff3f11fc484b4b10d5b98b6483c757e517 /net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild
parentdev-embedded/u-boot-tools: Fix missing BDEPENDs (diff)
downloadgentoo-791ab23aa4c758477325aea93f376a89e289eb5b.tar.gz
gentoo-791ab23aa4c758477325aea93f376a89e289eb5b.tar.bz2
gentoo-791ab23aa4c758477325aea93f376a89e289eb5b.zip
net-wireless/soapyplutosdr: add 0.2.2
Signed-off-by: Thomas Beierlein <tomjbe@gentoo.org>
Diffstat (limited to 'net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild')
-rw-r--r--net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild
new file mode 100644
index 000000000000..115e42eb16c6
--- /dev/null
+++ b/net-wireless/soapyplutosdr/soapyplutosdr-0.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Soapy SDR plugin for the Pluto SDR"
+HOMEPAGE="https://github.com/pothosware/SoapyPlutoSDR"
+
+if [ "${PV}" = "9999" ]; then
+ EGIT_REPO_URI="https://github.com/pothosware/SoapyPlutoSDR.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ COMMIT="422a9b306f765499dd3e9a4c3400fa39816dcfdb"
+ SRC_URI="https://github.com/pothosware/SoapyPlutoSDR/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/SoapyPlutoSDR-${COMMIT}
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+RDEPEND="net-wireless/soapysdr:=
+ net-libs/libiio:=
+ net-libs/libad9361-iio:="
+DEPEND="${RDEPEND}"