summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2018-01-07 22:18:17 +0100
committerUlrich Müller <ulm@gentoo.org>2018-01-07 22:18:17 +0100
commit4408fe38ab148d50307f42567077128daf12c6e3 (patch)
treef18667cfa32ad866e99ad3e700a28dc645ddce89 /net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild
parentnet-misc/electrum-ltc: Migrate from LINGUAS to L10N. (diff)
downloadgentoo-4408fe38ab148d50307f42567077128daf12c6e3.tar.gz
gentoo-4408fe38ab148d50307f42567077128daf12c6e3.tar.bz2
gentoo-4408fe38ab148d50307f42567077128daf12c6e3.zip
net-print/kyocera-mita-ppds: Migrate from LINGUAS to L10N.
Bump to EAPI 6. Add REQUIRED_USE condition, in order to have at least one language enabled. Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild')
-rw-r--r--net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild b/net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild
new file mode 100644
index 000000000000..8c66696feaf6
--- /dev/null
+++ b/net-print/kyocera-mita-ppds/kyocera-mita-ppds-8.4-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PPD description files for (some) Kyocera Mita Printers"
+HOMEPAGE="http://www.kyoceramita.it/"
+SRC_URI="Linux_PPDs_KSL${PV/\./_}.zip"
+
+LICENSE="kyocera-mita-ppds"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="l10n_de +l10n_en l10n_es l10n_fr l10n_it l10n_pt"
+REQUIRED_USE="|| ( l10n_de l10n_en l10n_es l10n_fr l10n_it l10n_pt )"
+RESTRICT="fetch bindist"
+
+RDEPEND="net-print/cups"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/PPD's_KSL_${PV}"
+
+pkg_nofetch() {
+ einfo "Please download ${A} from the following URL:"
+ einfo "http://www.kyoceramita.it/index/Service_Departement__/Richiesta_di_Supporto_Tecnico/download_center.false.driver.FS1020D._.IT.html"
+ einfo ""
+ einfo "The FS-1020D driver from the Italian website provides PPDs for a"
+ einfo "number of printers in six languages."
+}
+
+src_install() {
+ insinto /usr/share/cups/model/KyoceraMita
+
+ inslanguage() {
+ if use l10n_$1; then
+ doins $2/*.ppd || die "failed to install $2 ppds"
+ fi
+ }
+
+ inslanguage en English
+ inslanguage fr French
+ inslanguage de German
+ inslanguage it Italian
+ inslanguage pt Portuguese
+ inslanguage es Spanish
+
+ docinto html
+ dodoc ReadMe.htm
+}