summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <ajak@gentoo.org>2024-02-17 10:26:44 -0800
committerJohn Helmert III <ajak@gentoo.org>2024-02-17 10:26:57 -0800
commit4d67fab78b34ba84d34ca2e32bd1b0680112d9ea (patch)
treed8706dea801de44e3bba386be8a87db766ff38c3 /net-p2p
parentnet-p2p/arti: add 1.1.13 (diff)
downloadgentoo-4d67fab78b34ba84d34ca2e32bd1b0680112d9ea.tar.gz
gentoo-4d67fab78b34ba84d34ca2e32bd1b0680112d9ea.tar.bz2
gentoo-4d67fab78b34ba84d34ca2e32bd1b0680112d9ea.zip
net-p2p/arti: sync live
Signed-off-by: John Helmert III <ajak@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/arti/arti-9999.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-p2p/arti/arti-9999.ebuild b/net-p2p/arti/arti-9999.ebuild
index 29269538103c..8a5e2a599e77 100644
--- a/net-p2p/arti/arti-9999.ebuild
+++ b/net-p2p/arti/arti-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -23,9 +23,10 @@ else
fi
LICENSE="MIT Apache-2.0"
+# Dependent crate licenses
LICENSE+="
- Apache-2.0 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 Unlicense
- ZLIB
+ Apache-2.0 BSD Boost-1.0 CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016
+ Unlicense ZLIB
"
SLOT="0"
@@ -47,14 +48,14 @@ src_unpack() {
src_compile() {
for crate in crates/*; do
- pushd crates/arti || die
+ pushd "${crate}" || die
cargo_src_compile
popd >/dev/null || die
done
}
src_install() {
- pushd crates/arti >/dev/null || due
+ pushd crates/arti >/dev/null || die
cargo_src_install
newdoc src/arti-example-config.toml arti.toml