summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-10-22 10:12:08 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-10-22 10:46:54 +0200
commita9d55d543cd8a848dcb3063ce1f97ccd749c7341 (patch)
treea0a6add71090f284ca5ed282f37d00bab7b7f6f8 /net-misc
parentdev-scheme/gambit: bump to 4.9.5 (diff)
downloadgentoo-a9d55d543cd8a848dcb3063ce1f97ccd749c7341.tar.gz
gentoo-a9d55d543cd8a848dcb3063ce1f97ccd749c7341.tar.bz2
gentoo-a9d55d543cd8a848dcb3063ce1f97ccd749c7341.zip
net-misc/gallery-dl: bump to 1.26.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/gallery-dl/Manifest1
-rw-r--r--net-misc/gallery-dl/gallery-dl-1.26.1.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/net-misc/gallery-dl/Manifest b/net-misc/gallery-dl/Manifest
index 052f225f9880..3819101eefb4 100644
--- a/net-misc/gallery-dl/Manifest
+++ b/net-misc/gallery-dl/Manifest
@@ -1,2 +1,3 @@
DIST gallery-dl-1.25.8.gh.tar.gz 570435 BLAKE2B 33cd558c0f30cc31adbd0a51365b9501309be001cb0f7a3bb83e21dc797ca7e097b94e1575e4c0342fad44a5fca07a486d1e44db1a12d90ade06d0bc4acf8384 SHA512 22bd9e330efe24cb56e7b9b3eb219094aa897bb620253c4dd3fcda33df82fc021f1151dd9a6aff1f762c3ed4d426aadc75a398a659b30f64f254780554f46687
DIST gallery-dl-1.26.0.gh.tar.gz 597078 BLAKE2B 7fa140babb63d288c3ebf6ff01a4384fcea5885b4355ed17300b985b29b7897f644ffafeed268553be0660ab5efd5343d665cc13dbed6141f171ee01e9a2a2f6 SHA512 bbefacf137cad2518eff996a357a0803cf40519fbfcd762af0885e6cb791ec5abe3139e6fb23972d447d6d656ff184d16933659468e047afc52f52c78a4cacdd
+DIST gallery-dl-1.26.1.gh.tar.gz 604212 BLAKE2B 980e7b8b3c8ec966bb77db7c4312398490add75580e557f4654ca3aeb62ab287599f85dc401ed5bfae4dc6124e5a87b9254904b442b3a0cc2b10acdf5ce6695a SHA512 60d32ac82df5dd837399b778c118d8f944b7f35c5dfbbe8168841f0ff76471016b6049b617fef4825b3e21b37237c58bbc9f44be3e4e7ddb9bdf97cba11154bb
diff --git a/net-misc/gallery-dl/gallery-dl-1.26.1.ebuild b/net-misc/gallery-dl/gallery-dl-1.26.1.ebuild
new file mode 100644
index 000000000000..b3da2a9c870f
--- /dev/null
+++ b/net-misc/gallery-dl/gallery-dl-1.26.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite,ssl,xml(+)"
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Download image galleries and collections from several image hosting sites"
+HOMEPAGE="https://github.com/mikf/gallery-dl"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/mikf/${PN}.git"
+else
+ SRC_URI="https://github.com/mikf/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+# Tests require network access.
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/requests-2.11.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests setup.py
+
+python_compile_all() {
+ emake PYTHON=${EPYTHON} data/completion/{,_}gallery-dl man
+}
+
+pkg_postinst() {
+ optfeature "Pixiv Ugoira to WebM conversion" media-video/ffmpeg
+ optfeature "video downloads" net-misc/yt-dlp
+}