summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-08-16 23:47:37 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2023-08-16 23:47:37 +0200
commit9ed4ef9fe997d0b378e3c6c03e1386d90d2cd2c1 (patch)
treeabf88d3cdd09b57b4eb3907586d85f6fa245e970 /net-misc
parentwww-apps/nextcloud: add 25.0.10, 26.0.5, 27.0.2 (diff)
downloadgentoo-9ed4ef9fe997d0b378e3c6c03e1386d90d2cd2c1.tar.gz
gentoo-9ed4ef9fe997d0b378e3c6c03e1386d90d2cd2c1.tar.bz2
gentoo-9ed4ef9fe997d0b378e3c6c03e1386d90d2cd2c1.zip
net-misc/wget2: drop 2.0.1, 2.0.1-r2
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wget2/wget2-2.0.1-r2.ebuild92
-rw-r--r--net-misc/wget2/wget2-2.0.1.ebuild125
2 files changed, 0 insertions, 217 deletions
diff --git a/net-misc/wget2/wget2-2.0.1-r2.ebuild b/net-misc/wget2/wget2-2.0.1-r2.ebuild
deleted file mode 100644
index c9f6bad3566c..000000000000
--- a/net-misc/wget2/wget2-2.0.1-r2.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
-HOMEPAGE="https://gitlab.com/gnuwget/wget2"
-SRC_URI="mirror://gnu/wget/${P}.tar.gz"
-
-# LGPL for libwget
-LICENSE="GPL-3+ LGPL-3+"
-SLOT="0/0" # subslot = libwget.so version
-QA_PKGCONFIG_VERSION="2.1.0" # libwget pkg-config versioning
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test xattr zlib"
-
-RDEPEND="
- brotli? ( app-arch/brotli )
- bzip2? ( app-arch/bzip2 )
- !gnutls? ( dev-libs/libgcrypt:= )
- ssl? (
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- dev-libs/openssl:0=
- )
- )
- gpgme? (
- app-crypt/gpgme:=
- dev-libs/libassuan
- dev-libs/libgpg-error
- )
- http2? ( net-libs/nghttp2 )
- idn? ( net-dns/libidn2:= )
- lzip? ( app-arch/lzlib )
- lzma? ( app-arch/xz-utils )
- pcre? ( dev-libs/libpcre2 )
- psl? ( net-libs/libpsl )
- xattr? ( sys-apps/attr )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen[dot] )
-"
-
-RESTRICT="!test? ( test )"
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- --disable-valgrind-tests
- --with-plugin-support
- --with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
- --without-libidn
- --without-libmicrohttpd
- $(use_enable doc)
- $(use_enable xattr)
- $(use_with brotli brotlidec)
- $(use_with bzip2)
- $(use_with gpgme)
- $(use_with http2 libnghttp2)
- $(use_with idn libidn2)
- $(use_with lzip)
- $(use_with lzma)
- $(use_with pcre libpcre2)
- $(use_with psl libpsl)
- $(use_with zlib)
-
- # Avoid calling ldconfig
- LDCONFIG=:
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if [[ ${PV} == *9999 ]] ; then
- if use doc ; then
- local mpage
- for mpage in $(find docs/man -type f -regextype grep -regex ".*\.[[:digit:]]$") ; do
- doman ${mpage}
- done
- fi
- else
- doman docs/man/man{1/*.1,3/*.3}
- fi
-
- find "${D}" -type f -name '*.la' -delete || die
- rm "${ED}"/usr/bin/${PN}_noinstall || die
-}
diff --git a/net-misc/wget2/wget2-2.0.1.ebuild b/net-misc/wget2/wget2-2.0.1.ebuild
deleted file mode 100644
index 974ef7241035..000000000000
--- a/net-misc/wget2/wget2-2.0.1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DESCRIPTION="GNU Wget2 is a file and recursive website downloader"
-HOMEPAGE="https://gitlab.com/gnuwget/wget2"
-if [[ "${PV}" == *9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitlab.com/gnuwget/wget2.git"
-else
- SRC_URI="mirror://gnu/wget/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-# LGPL for libwget
-LICENSE="GPL-3+ LGPL-3+"
-SLOT="0/0" # subslot = libwget.so version
-IUSE="brotli bzip2 doc +gnutls gpgme +http2 idn lzip lzma openssl pcre psl +ssl test xattr zlib"
-
-RDEPEND="
- brotli? ( app-arch/brotli )
- bzip2? ( app-arch/bzip2 )
- !gnutls? ( dev-libs/libgcrypt:= )
- ssl? (
- gnutls? ( net-libs/gnutls:= )
- !gnutls? (
- dev-libs/openssl:0=
- )
- )
- gpgme? (
- app-crypt/gpgme:=
- dev-libs/libassuan
- dev-libs/libgpg-error
- )
- http2? ( net-libs/nghttp2 )
- idn? ( net-dns/libidn2:= )
- lzip? ( app-arch/lzlib )
- lzma? ( app-arch/xz-utils )
- pcre? ( dev-libs/libpcre2 )
- psl? ( net-libs/libpsl )
- xattr? ( sys-apps/attr )
- zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- virtual/pkgconfig
- doc? ( app-doc/doxygen )
-"
-
-RESTRICT="!test? ( test )"
-
-src_unpack() {
- if [[ "${PV}" == *9999 ]] ; then
- git-r3_src_unpack
-
- # We need to mess with gnulib :-/
- EGIT_REPO_URI="https://git.savannah.gnu.org/r/gnulib.git" \
- EGIT_CHECKOUT_DIR="${WORKDIR}/gnulib" \
- git-r3_src_unpack
- else
- default
- fi
-}
-
-src_prepare() {
- default
- if [[ "${PV}" == *9999 ]] ; then
- local bootstrap_opts=(
- --gnulib-srcdir=../gnulib
- --no-bootstrap-sync
- --copy
- --no-git
- --skip-po
- )
- AUTORECONF="/bin/true" \
- LIBTOOLIZE="/bin/true" \
- sh ./bootstrap "${bootstrap_opts[@]}" || die
- eautoreconf
- fi
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-static
- --disable-valgrind-tests
- --with-plugin-support
- --with-ssl="$(usex ssl $(usex gnutls gnutls openssl) none)"
- --without-libidn
- --without-libmicrohttpd
- $(use_enable doc)
- $(use_enable xattr)
- $(use_with brotli brotlidec)
- $(use_with bzip2)
- $(use_with gpgme)
- $(use_with http2 libnghttp2)
- $(use_with idn libidn2)
- $(use_with lzip)
- $(use_with lzma)
- $(use_with pcre libpcre2)
- $(use_with psl libpsl)
- $(use_with zlib)
-
- # Avoid calling ldconfig
- LDCONFIG=:
- )
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- if [[ ${PV} == *9999 ]] ; then
- if use doc ; then
- local mpage
- for mpage in $(find docs/man -type f -regextype grep -regex ".*\.[[:digit:]]$") ; do
- doman ${mpage}
- done
- fi
- else
- doman docs/man/man{1/*.1,3/*.3}
- fi
-
- find "${D}" -type f -name '*.la' -delete || die
- rm "${ED}"/usr/bin/${PN}_noinstall || die
-}