summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRahil Bhimjiani <me@rahil.rocks>2024-03-26 18:41:37 +0530
committerZac Medico <zmedico@gentoo.org>2024-03-31 17:55:00 -0700
commit47be2b31bae315b9c5b8c56733e08b632cc643b0 (patch)
treeb703d56b35f68630c530aa63084f55d3fecb121c /net-misc/passt/passt-2024.03.26.ebuild
parentapp-containers/buildah: cleanup vulnerable versions (diff)
downloadgentoo-47be2b31bae315b9c5b8c56733e08b632cc643b0.tar.gz
gentoo-47be2b31bae315b9c5b8c56733e08b632cc643b0.tar.bz2
gentoo-47be2b31bae315b9c5b8c56733e08b632cc643b0.zip
net-misc/passt: add 2024.03.26
Signed-off-by: Rahil Bhimjiani <me@rahil.rocks> Closes: https://github.com/gentoo/gentoo/pull/35930 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'net-misc/passt/passt-2024.03.26.ebuild')
-rw-r--r--net-misc/passt/passt-2024.03.26.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/passt/passt-2024.03.26.ebuild b/net-misc/passt/passt-2024.03.26.ebuild
new file mode 100644
index 000000000000..90df839f93d9
--- /dev/null
+++ b/net-misc/passt/passt-2024.03.26.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-mode networking daemons for VMs and namespaces, replacement for Slirp"
+HOMEPAGE="https://passt.top/"
+
+RELEASE_COMMIT="4988e2b"
+
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://passt.top/passt"
+else
+ SRC_URI="https://passt.top/passt/snapshot/passt-${RELEASE_COMMIT}.tar.xz -> ${P}.tar.xz"
+ S="${WORKDIR}/${PN}-${RELEASE_COMMIT}"
+ KEYWORDS="~amd64 ~arm64 ~riscv"
+fi
+
+LICENSE="BSD GPL-2+"
+SLOT="0"
+IUSE="static"
+
+PATCHES=(
+ "${FILESDIR}"/Makefile-2024.03.20.patch
+)
+
+src_prepare() {
+ default
+ tc-export CC
+}
+
+src_compile() {
+ [[ ${PV} != 9999* ]] && export VERSION="${PV}"
+ export prefix="${EPREFIX}/usr" docdir="${EPREFIX}/usr/share/doc/${P}"
+
+ emake $(usev static)
+}